Page 3 of 4 FirstFirst 1234 LastLast
Results 41 to 60 of 73

Z28 Still Has Rough Idle Wtf????

This is a discussion on Z28 Still Has Rough Idle Wtf???? within the Camaro / SS forums, part of the Vehicle Specific category; Originally Posted by sscamaro1384 so if this is my problem, what is the solution? new maf? clean existing one? Ok,first, ...

  1. #41
    Junior Member edcmat-l1's Avatar
    Join Date
    Jun 2006
    Location
    Virginia Beach, Va
    Posts
    98
    Quote Originally Posted by sscamaro1384 View Post
    so if this is my problem, what is the solution? new maf? clean existing one?
    Ok,first, pull the MAF off and look thru the screen with a flash light at the hot wires. The little resistors in there. If on the upstream side (the side facing the screen) the hot wires appear dark, or fuzzy, or anything but clean, this is probably your problem. Look at the backside of them to get a comparison of what they should look like clean. To clean them, just knock out the screen, and clean them with a Q tip and some NON RESIDUAL parts cleaner.Dont worry about knocking out the screen, it hardly affects them at all.
    Or, if you want to spend the money, buy a new one.

  2. #42
    Junior Member
    Join Date
    Feb 2007
    Location
    texas
    Posts
    96

    red
    1998 chevy camaro ss

    fixed my problem

    bought "special" maf cleaner. used it, no difference. but i finally did figure out the problem. u should check this also. got the idea off another forum. i noticed the egr tube that plugs into the intake had a slight cut in it wher i could see daylight bent the tube to seal the cut and noticed a difference immediately. rough idle was almost completely gone. the idea i got from the other forum was to jb weld and completely seal the cut.let it sit over night, reset the pcm and put everything back together and noticed a big difference. idle was smoother than it had ever been. think the problem had been there a while because idle has never been so smooth. i think i do see where i bumped the egr tube while changing the water pump and aggravated a problem that i never noticed but was always there. i recommend anyone with the p0171 and po174 codes to check this as well as the maf. i will eventually replace it. seen it on a gm part website for about 80 bucks before shipping, or could get a tune and have the egr deleted and plug it up.

  3. #43
    I lika da Chevy's LETHALxLS1's Avatar
    Join Date
    Oct 2006
    Location
    USA
    Posts
    5,329

    BLACK
    Z/28 LS1

    Quote Originally Posted by sscamaro1384 View Post
    bought "special" maf cleaner. used it, no difference. but i finally did figure out the problem. u should check this also. got the idea off another forum. i noticed the egr tube that plugs into the intake had a slight cut in it wher i could see daylight bent the tube to seal the cut and noticed a difference immediately. rough idle was almost completely gone. the idea i got from the other forum was to jb weld and completely seal the cut.let it sit over night, reset the pcm and put everything back together and noticed a big difference. idle was smoother than it had ever been. think the problem had been there a while because idle has never been so smooth. i think i do see where i bumped the egr tube while changing the water pump and aggravated a problem that i never noticed but was always there. i recommend anyone with the p0171 and po174 codes to check this as well as the maf. i will eventually replace it. seen it on a gm part website for about 80 bucks before shipping, or could get a tune and have the egr deleted and plug it up.
    Glad u got iut fixed man. I am gonna check mine tomorrow!!! Did you notice your fuel gauge jumping any when it idled rough?? I just noticed thats what mine is doing.

  4. #44
    Junior Member
    Join Date
    Feb 2007
    Location
    texas
    Posts
    96

    red
    1998 chevy camaro ss

    nope just the tachometer. jb welds holdin up so far. $4 well spent.

  5. #45
    I lika da Chevy's LETHALxLS1's Avatar
    Join Date
    Oct 2006
    Location
    USA
    Posts
    5,329

    BLACK
    Z/28 LS1

    Quote Originally Posted by sscamaro1384 View Post
    nope just the tachometer. jb welds holdin up so far. $4 well spent.
    Man thats gotta make u sleep better at night!!!

  6. #46
    Junior Member
    Join Date
    Feb 2007
    Location
    texas
    Posts
    96

    red
    1998 chevy camaro ss

    ya. will eventually buy the part when i come across it. what kinda mods u got on your 98 and mileage?

  7. #47
    I lika da Chevy's LETHALxLS1's Avatar
    Join Date
    Oct 2006
    Location
    USA
    Posts
    5,329

    BLACK
    Z/28 LS1

    I just bought the car about 8 months ago.Its a 98 z28 hard top,black-automatic. It has 65,000 miles and is completely stock(which was a big reason why I bought it).
    I put a k/n air filter and a k/n oil filter on it.8.5 MSD wires,NGK TR 55 plugs,17x9 TTM wheels, NITTO 555 275/40/17 tires.LOL. I eventually want to get a air lid,headers,cat back exhaust,port the throttle body,160 degree thermostat, lower it and get some really good struts/shocks,maybe a few suspension mods(strut braces etc.) I have owned 4 z28s before but I love this one the most.I had a 87 IROC completely restored which was my second favorite.What mileage u have?What mods do u have?

  8. #48
    Junior Member
    Join Date
    Feb 2007
    Location
    texas
    Posts
    96

    red
    1998 chevy camaro ss

    mods

    ya i had a 87 t top iroc myself. totally custom, but got stolen. ended up getting it back totally stripped. my 98 is an ss w/ 166k. bought it at 125k. mods include custom catback exhaust, lid, taylor wires, ac delco iridium plugs, ported maf, ported throttle body(done by me), probably could be done better(my first one). 17 by 9.5 zr1 front, 17 by 11 rear w/315/35/17, tokico shocks, 1.5" drop all around, egr mod, throttle body bypass, tornado fuel saver,slp ram air, polyurethane bushings all around, k&n air filter, custom camaro box w 12" audiobahns, rockford punch amp. had the car about two years, never actually noticed but it does have alot of mods but nothing major. custom tune and borla pro xs muffler is next. then maybe hedman or pacesetter headers but that will probably b it for performance mods. also thinkin about the msd wires u got. got the ngks in a box but waitin for the plug wires. mine (taylors) came with the car 2 years ago. need to be replaced. did u see a difference? been through a hypertech programmer already but sold it. liked it but i ve heard alot of bad about it on these forums. had subframes but got rid of em after i lowered the car.also had the tranny rebuilt w/ shift kit at 137k and 3.42 gears.

  9. #49
    I lika da Chevy's LETHALxLS1's Avatar
    Join Date
    Oct 2006
    Location
    USA
    Posts
    5,329

    BLACK
    Z/28 LS1

    Quote Originally Posted by sscamaro1384 View Post
    ya i had a 87 t top iroc myself. totally custom, but got stolen. ended up getting it back totally stripped. my 98 is an ss w/ 166k. bought it at 125k. mods include custom catback exhaust, lid, taylor wires, ac delco iridium plugs, ported maf, ported throttle body(done by me), probably could be done better(my first one). 17 by 9.5 zr1 front, 17 by 11 rear w/315/35/17, tokico shocks, 1.5" drop all around, egr mod, throttle body bypass, tornado fuel saver,slp ram air, polyurethane bushings all around, k&n air filter, custom camaro box w 12" audiobahns, rockford punch amp. had the car about two years, never actually noticed but it does have alot of mods but nothing major. custom tune and borla pro xs muffler is next. then maybe hedman or pacesetter headers but that will probably b it for performance mods. also thinkin about the msd wires u got. got the ngks in a box but waitin for the plug wires. mine (taylors) came with the car 2 years ago. need to be replaced. did u see a difference? been through a hypertech programmer already but sold it. liked it but i ve heard alot of bad about it on these forums. had subframes but got rid of em after i lowered the car.also had the tranny rebuilt w/ shift kit at 137k and 3.42 gears.
    Damn that is alot of mods lol. I really didnt notice any differance with the new wires. I am planning on doing the typical bolt on stuff nothing major. I think I am gonna get one of those custom boxes that has the same plastic as the cars interior. It looks stock like its supposed to be in the car. It holds 10 inch subs. I already have the fosgate amp and subs just need the box.I wana get some infinity door speakers and small sail panel mids also. I am getting my windows tinted this week also. Does your car have any piston slap? mine does when u first start it till its warm. It doesnt seem to bother the car any but I almost sold the car when I first noticed it. I thought something was bad wrong. Glad I kept it though. Its nice to know you have that many miles on your car and it still runs good. Do you get on your car much? 1 other thing do you use that Dexcool antifreeze in your car? Hey I added u on my buddy list too. Hope thats cool.---mike

    ALSO--Hey I read some bad things about those pacesetter headers. Some people have a problem with the headers hitting the oil filter and rubbing a hole in it + making the oil mega hot. I guess you could do a oil filter relocation to fix it though. I was gonna go with those headers because of the price but am having second thoughts now because one guy with the above problem said the customer service is a joke. You probably already know about this but in case you didnt wanted to warn ya.
    Last edited by LETHALxLS1; 03-21-2007 at 09:26 PM.

  10. #50
    Junior Member
    Join Date
    Feb 2007
    Location
    texas
    Posts
    96

    red
    1998 chevy camaro ss

    i usually get on it after a new mod to see if i notice a difference. havent noticed piston slap on my car. ran the dex cool for about a year. almost seemed like it leaked itself out so i switched to the new green prestone(any make, any color, any year)works good. how about those msd wires and ngks? just got spanked by a mean soundin' ta about 1.5 lengths , he definentely had headers and one hell of an exhaust. i think hes kicked my ass before about a year ago. seen him around town. might be time for my headers or a tune. he was a 12 second car for sure.

  11. #51
    I lika da Chevy's LETHALxLS1's Avatar
    Join Date
    Oct 2006
    Location
    USA
    Posts
    5,329

    BLACK
    Z/28 LS1

    Thumbs up

    Quote Originally Posted by sscamaro1384 View Post
    i usually get on it after a new mod to see if i notice a difference. havent noticed piston slap on my car. ran the dex cool for about a year. almost seemed like it leaked itself out so i switched to the new green prestone(any make, any color, any year)works good. how about those msd wires and ngks? just got spanked by a mean soundin' ta about 1.5 lengths , he definentely had headers and one hell of an exhaust. i think hes kicked my ass before about a year ago. seen him around town. might be time for my headers or a tune. he was a 12 second car for sure.
    I noticed a slight increase in throttle response from the plugs/wires but not anything major. I go to a place called rev xtreme and they only work on ls1s and vettes and they say for the money the MSD 8.5 wires are the shit. You could get those Granatelli for $160.00 which have close to no resistance but I cant see paying that for wires. The MSD 8.5 wires have 50 ohms resistance I believe and cost $60.00.I think the NGK tr 55 plugs were about $1.50 each. I have never raced my car even though a few people tried to get me to. I want to get headers/exhaust,lid and a couple other things before I try it. I love this car though. The first time I really got on it I was surprised as hell and had a big ass grin on my face. Even that IROC I had wasnt shit compared to this car plus I love the way this car looks. Hey I was also wondering how much it cost you to rebuild your tranny. Thanks---mike

  12. #52
    Junior Member
    Join Date
    Feb 2007
    Location
    texas
    Posts
    96

    red
    1998 chevy camaro ss

    with labor it was like 1000 bucks. any difference in your car yet?

  13. #53
    I lika da Chevy's LETHALxLS1's Avatar
    Join Date
    Oct 2006
    Location
    USA
    Posts
    5,329

    BLACK
    Z/28 LS1

    Quote Originally Posted by sscamaro1384 View Post
    with labor it was like 1000 bucks. any difference in your car yet?
    It seemed to calm down a bit on its own. I am gonna have em take a look at it again when I take it in next week to get my new dash installed. The only thing wrong with my car when I bought it was a cracked dash and some scratches on the hood. I bought a porter cable 7424 buffer and took care of the scratches already. Next I am gettin one of those clear air lids from MTI. I just think they look cool plus I wanna give it more air. I am gettin tint also. Man if I had 10 grand I would probably blow it all on this car!! LOL Take car man---mike

  14. #54
    Member Orange99z28's Avatar
    Join Date
    Aug 2005
    Location
    joliet il
    Age
    33
    Posts
    231

    orange
    99 z28

    i'll second the egr tubes possibly bein messed up. i got screwed by a shop (atr motorsports in joliet il) and i finally pinned the last problem they caused. really ghetto homemade egr tubing up where i couldn't see it way in the back by the firewall. symptoms were rough idle and raspy sound w/check engine light. night and day difference, and very cheap to fix if that is the problem (they might be dry rotted too). $5 at home depot for parts....after replacing an exhaust manifold gasket...now that wasn't fun! def. check the obvious\easy first

  15. #55
    I lika da Chevy's LETHALxLS1's Avatar
    Join Date
    Oct 2006
    Location
    USA
    Posts
    5,329

    BLACK
    Z/28 LS1

    Its been a while since I started this thread-I found out what the problem was as my car began to run so rough and have no power. The shop I went to that "specialized' IN F bodies and vettes put my plugs in and didnt bother gapping them. 2 Plugs were gapped way too large. This is the same shop that charged me $150.00 to put a dash pad in(a 15 minute job) and the same shop that gave my car back to me with a loud banging noise when it shifted into 3rd gear. I am 99% certain they beat on my car while joyriding it and ruined my transmission. I had to get my transmission rebuilt since the banging turned into a blown tranny. The funny part is I called the owner of the shop out on this and he acted like I was nuts. The best part is that I specifically told the shop I want noone test driving my car but me-because I know better. They took the car and drove it anyways and reset the trip meter like I was a dumbass who wouldnt know any differance. Do you really need to test drive a car for a plugs and wires change? I dont think so. I wish I had a hidden camera in my car because then they would have been sued.

  16. #56
    Junior Member
    Join Date
    Aug 2007
    Location
    Fort Worth, Tx
    Age
    27
    Posts
    29

    Black
    2002 Camaro Z28

    im havin a similar problem, although my idle is around 500-600rpms, in cold weather( freezing or near freezing) the car misses on start up, bad. shakes the whole car. check engine light came on a few times, autozone tester said multiple misfire on multiple cylinders, still havent had enough time to check the plugs. but if anyone has some suggestions other than plugs and wires and coil packs, let me know. 2002 z28 a4

  17. #57
    I lika da Chevy's LETHALxLS1's Avatar
    Join Date
    Oct 2006
    Location
    USA
    Posts
    5,329

    BLACK
    Z/28 LS1

    If its getting misfire codes change the plugs and wires.

  18. #58
    Member WARP211's Avatar
    Join Date
    Feb 2007
    Location
    FairField, CA
    Age
    36
    Posts
    398

    RED 35TH ANIVERSARY PKG
    2002 CAMARO SS 35th LE

    Quote Originally Posted by LETHALxLS1 View Post
    Its been a while since I started this thread-I found out what the problem was as my car began to run so rough and have no power. The shop I went to that "specialized' IN F bodies and vettes put my plugs in and didnt bother gapping them. 2 Plugs were gapped way too large. This is the same shop that charged me $150.00 to put a dash pad in(a 15 minute job) and the same shop that gave my car back to me with a loud banging noise when it shifted into 3rd gear. I am 99% certain they beat on my car while joyriding it and ruined my transmission. I had to get my transmission rebuilt since the banging turned into a blown tranny. The funny part is I called the owner of the shop out on this and he acted like I was nuts. The best part is that I specifically told the shop I want noone test driving my car but me-because I know better. They took the car and drove it anyways and reset the trip meter like I was a dumbass who wouldnt know any differance. Do you really need to test drive a car for a plugs and wires change? I dont think so. I wish I had a hidden camera in my car because then they would have been sued.

    I'm pretty sure when you change the plugs that your not suppose to gap them.. as they are already gap.. I read it some here in the forms and it was actually recall on the gap for the plugs.. I believe its in the internal engin.. part.. As far as the shop now.. I'm an automotive technician myself.. And their are suppose to test drive the car before and after.. Before to verify the problem and after to make sure the problem went away.. But if you request it not to be driven then they should of just left it alone and wrote it down on the paper work(Not to be Driven after work).. The main reason shops do this is to protect them from getting sued in the court system..

  19. #59
    I lika da Chevy's LETHALxLS1's Avatar
    Join Date
    Oct 2006
    Location
    USA
    Posts
    5,329

    BLACK
    Z/28 LS1

    Quote Originally Posted by WARP211 View Post
    I'm pretty sure when you change the plugs that your not suppose to gap them.. as they are already gap.. I read it some here in the forms and it was actually recall on the gap for the plugs.. I believe its in the internal engin.. part.. As far as the shop now.. I'm an automotive technician myself.. And their are suppose to test drive the car before and after.. Before to verify the problem and after to make sure the problem went away.. But if you request it not to be driven then they should of just left it alone and wrote it down on the paper work(Not to be Driven after work).. The main reason shops do this is to protect them from getting sued in the court system..
    WTF are you talking about? If you are a "tech" then you should know to check all plugs for the proper gap. NEVER trust a plug to be correctly gapped.
    Ask anyone on these forums if they let people drive their cars after a repair. They know better as well. In fact most everyone one these forums tries to do all their own work so shit like this doesnt happen. The only reason I took my car in for plugs was because of health reasons.

  20. #60
    Awaiting Activation
    Join Date
    Aug 2007
    Location
    odessa,texas
    Posts
    1,056

    69 hugger orange
    98 z28

    if nothi else around here the local oil change places do a injector cleaner service where they hook some shit up dont know too much about it other than they hooked it up to a 15 year old truck and ran it,the whole shop filled up with smoke that startyed coming from the exhaust and they ran it untill it was clean,clear air coming out and the trucked idled way better after that,befors ir would barely stay started

    i aked how much and the service was only about a hundred dollars ,well worth it if you had seen the smoke coming out of this truck and then go clear

Page 3 of 4 FirstFirst 1234 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Rough Idle
    By thacher2189 in forum LT1
    Replies: 3
    Last Post: 02-19-2012, 03:04 PM
  2. Help: Rough Idle
    By 1WickedWS6 in forum GM Trucks
    Replies: 12
    Last Post: 01-04-2012, 08:16 AM
  3. Help: intermittant rough idle, off idle hesitation
    By Matto4785 in forum General Help
    Replies: 1
    Last Post: 09-21-2009, 06:12 AM
  4. Help: rough idle
    By RLamas in forum Firebird / WS6
    Replies: 8
    Last Post: 05-01-2009, 05:59 PM
  5. C5 Rough Idle
    By BlkNBlkC5 in forum Corvette
    Replies: 1
    Last Post: 04-14-2007, 07:42 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •