Page 2 of 3 FirstFirst 123 LastLast
Results 21 to 40 of 43

Why dont my 10.5" fit!!!!

This is a discussion on Why dont my 10.5" fit!!!! within the Camaro / SS forums, part of the Vehicle Specific category; Originally Posted by Spikito gonna go beat up my fender wells today.... lifting at the rear didnt help?...

  1. #21
    Senior Member 2001camaroSS's Avatar
    Join Date
    Feb 2010
    Location
    Greenwood, IN
    Posts
    3,508

    Light Pewter Metallic
    2001 Camaro SS

    Quote Originally Posted by Spikito View Post
    gonna go beat up my fender wells today....
    lifting at the rear didnt help?

  2. #22
    its short but its skinny. jiveass's Avatar
    Join Date
    Oct 2009
    Location
    The Woodlands/spring/houston
    Posts
    2,142

    pewter
    99 trans am

    im telling you, its not necessary to beat the wellls in....just remove the bump stop and cut out the mount....

  3. #23
    Senior Member 2001camaroSS's Avatar
    Join Date
    Feb 2010
    Location
    Greenwood, IN
    Posts
    3,508

    Light Pewter Metallic
    2001 Camaro SS

    Quote Originally Posted by jiveass View Post
    im telling you, its not necessary to beat the wellls in....just remove the bump stop and cut out the mount....
    i didnt even have to do that.

  4. #24
    James Bond Spikito's Avatar
    Join Date
    Aug 2007
    Location
    Texas
    Age
    30
    Posts
    4,546

    2001 3.8 Black - sold
    2000 SS Black M6

    well I'm going to try those first obviously....

  5. #25
    James Bond Spikito's Avatar
    Join Date
    Aug 2007
    Location
    Texas
    Age
    30
    Posts
    4,546

    2001 3.8 Black - sold
    2000 SS Black M6

    sadly i dont own a grinder....but my gf does, lol...so I'm gonna mess with it when she gets out of class and brings it over

  6. #26
    Socially Unacceptable 1LOMARO's Avatar
    Join Date
    Mar 2009
    Location
    Concord NC
    Posts
    59

    Silver
    98 Camaro

    IS this just a one side issue or is it doing it on both sides??

  7. #27
    Member jetaws6's Avatar
    Join Date
    Apr 2009
    Location
    Fallston, Maryland
    Posts
    576

    Black
    1998 Trans Am Ws6

    Quote Originally Posted by Spikito View Post

    is it possible that wed need to pick the rear up by the axle rather than let the suspension bottom out by picking it up on the sub frames?
    Did you try this yet? It sounds like you solved your own problem

  8. #28
    James Bond Spikito's Avatar
    Join Date
    Aug 2007
    Location
    Texas
    Age
    30
    Posts
    4,546

    2001 3.8 Black - sold
    2000 SS Black M6

    Quote Originally Posted by 1LOMARO View Post
    IS this just a one side issue or is it doing it on both sides??
    At the shop we only tried the one side, just the rim hit pretty bad, without a tire even on it.

  9. #29
    Visualize°Design°Create SSwt00SS's Avatar
    Join Date
    Dec 2005
    Location
    Dallas, TX
    Posts
    9,287

    '12 Silver SS 1SS
    '00 Black SS #8617

    hate to say i told you so,but...i told you so!

    if you're running a +56mm offset, im not sure why you are having the issue, unless the rim is simply to wide. i have 17x10's and dont have this problem even at a +53mm offset.

    hopefully you find a quick and inexpensive solution to your problem. good luck!

  10. #30
    its short but its skinny. jiveass's Avatar
    Join Date
    Oct 2009
    Location
    The Woodlands/spring/houston
    Posts
    2,142

    pewter
    99 trans am

    i had this issue last weekend...cut the bump stops and mount location....my 18x10.5s fit right in after that....

  11. #31
    O U 8 1 2 Spaz's Avatar
    Join Date
    Nov 1999
    Location
    over here...
    Age
    39
    Posts
    25,692

    []D [] []V[] []D
    1999 trans am

    if you go the spacer route get two 1/2" spacers... you'll need to take out the axles to put in new bolts because the stockers won't be long enough to accomodate the spacers and the tire... you'll get maybe 4 threads deep before they stop...

  12. #32
    LSX whore allbaugh_04's Avatar
    Join Date
    Mar 2007
    Location
    Omaha, NE
    Age
    32
    Posts
    5,895

    Pewter
    2000 Z28 Camaro

    Take em back.

  13. #33
    its short but its skinny. jiveass's Avatar
    Join Date
    Oct 2009
    Location
    The Woodlands/spring/houston
    Posts
    2,142

    pewter
    99 trans am

    cut out the bump stops!! that is all!!

  14. #34
    Member JRENIGAR's Avatar
    Join Date
    Oct 2009
    Location
    arkansas
    Posts
    371

    red
    99 camaro

    Quote Originally Posted by jiveass View Post
    cut out the bump stops!! that is all!!
    Agreed!!! I just put 17x11 zr1's on and had to completely cut the bumpstop mount out. They fit fine after that jacking up each side from the subframe conn. Still using stock panhard rod. No issues with bottoming out with out bumpstops either on a stock height car. Good luck.

  15. #35
    never enough ponyslayer's Avatar
    Join Date
    Jul 2007
    Location
    Garner, North Carolina
    Age
    35
    Posts
    53

    Black
    1998 Trans-Am

    I have the same rims (except mine are black with crome lip) from the same company on my T/A and its lowered with no problems. I lifted from rear end.

  16. #36
    James Bond Spikito's Avatar
    Join Date
    Aug 2007
    Location
    Texas
    Age
    30
    Posts
    4,546

    2001 3.8 Black - sold
    2000 SS Black M6

    Quote Originally Posted by SSwt00SS View Post
    hate to say i told you so,but...i told you so!

    if you're running a +56mm offset, im not sure why you are having the issue, unless the rim is simply to wide. i have 17x10's and dont have this problem even at a +53mm offset.

    hopefully you find a quick and inexpensive solution to your problem. good luck!
    nope....still wrong....lifted from the rear end, bolted up no problem....

    its a little close, I'm not too worried about rubbing, but the distance between tire, and trailing arm, is way close, i have small fingers and i cant fit them between. I got 295's and I don't think 305s would have made it

    Anyway, got the tires mounted and balanced today, took em home, mounted em up, no issue what-so-ever. But when I let the car down, the right rear sank to the ground, guess he didn't tighten the valve stem enough or whatever...Poor kid was bragging about is 98 civic, wanting to race, wasn't paying attention to his job.

    I'll air it up in the morning, see what happens from there...pics to come soon.


    oh and btw, I put the rear back on jacks so I didn't leave my rim sitting on a flat tire all night.

  17. #37
    Visualize°Design°Create SSwt00SS's Avatar
    Join Date
    Dec 2005
    Location
    Dallas, TX
    Posts
    9,287

    '12 Silver SS 1SS
    '00 Black SS #8617

    Quote Originally Posted by Spikito View Post
    nope....still wrong....lifted from the rear end, bolted up no problem....

    its a little close, I'm not too worried about rubbing, but the distance between tire, and trailing arm, is way close, i have small fingers and i cant fit them between. I got 295's and I don't think 305s would have made it

    Anyway, got the tires mounted and balanced today, took em home, mounted em up, no issue what-so-ever. But when I let the car down, the right rear sank to the ground, guess he didn't tighten the valve stem enough or whatever...Poor kid was bragging about is 98 civic, wanting to race, wasn't paying attention to his job.

    I'll air it up in the morning, see what happens from there...pics to come soon.


    oh and btw, I put the rear back on jacks so I didn't leave my rim sitting on a flat tire all night.
    consider getting an adjustable panhard bar. underload (car on the ground) it should help to center side to side. when jacked up, (not underload) it ends up shifting to one side slightly.

  18. #38
    James Bond Spikito's Avatar
    Join Date
    Aug 2007
    Location
    Texas
    Age
    30
    Posts
    4,546

    2001 3.8 Black - sold
    2000 SS Black M6

    suspension stuff is next....prob gonna get one of those after SFCs

    well actually, intake, headers, exhaust, and tune are next....talking with East Texas Muscle Cars now to set up a appointment

  19. #39
    The Demon Demon_Z28's Avatar
    Join Date
    Feb 2008
    Location
    WA
    Posts
    648

    Bright Rally Red
    2001 Camaro SS

    yea my 17x11's hit the bump stops if I don't jack it by the axle.

  20. #40
    James Bond Spikito's Avatar
    Join Date
    Aug 2007
    Location
    Texas
    Age
    30
    Posts
    4,546

    2001 3.8 Black - sold
    2000 SS Black M6

    havent had any rubbing issues yet...took a few hard corners, and stepped on it from a dig a few times, make it squat.

    but my apt complex has speed bumps, hitting that brought on a pretty solid thunk, dunno, but it doesnt matter, im moving into my house as we speak

Page 2 of 3 FirstFirst 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. "We Dont Have an Immediate Crisis in Terms of Debt"...(vid)
    By wileyCoyote in forum Political / Debate Forum
    Replies: 1
    Last Post: 03-14-2013, 08:50 PM
  2. "Dont hit my girl"
    By BadBlueBird* in forum Almost Anything Goes
    Replies: 32
    Last Post: 09-24-2006, 09:14 PM
  3. "I just cant understand why people dont trust us cops?"
    By Modulistic in forum Political / Debate Forum
    Replies: 223
    Last Post: 08-27-2006, 09:37 PM
  4. For those who still dont know WTF is a "YARIS"
    By FSANE in forum Almost Anything Goes
    Replies: 37
    Last Post: 06-29-2006, 04:40 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •