Results 1 to 10 of 10

weird noise when putting it to the floor.

This is a discussion on weird noise when putting it to the floor. within the Camaro / SS forums, part of the Vehicle Specific category; hey guys got a quick question for you. Ok so when im driving my car and decide to punch it ...

  1. #1
    Junior Member
    Join Date
    Jun 2007
    Location
    las vegas
    Posts
    12

    silver
    2000 camaro z28

    weird noise when putting it to the floor.

    hey guys got a quick question for you. Ok so when im driving my car and decide to punch it the car is suddenly kind of doggy and it makes a noise like a faint tick or knock i know its not an engine rod knocking. what is weird is that my dad had a siverado and i could notice that noise in his truck when i would drive that sometimes. so what is it? to me it almost sounds like it could be a vaccume leak or maybe a bad coil pack. if anyone has had problems like this or anyone has any suggestions would you please let me know. i have had my 2000 camaro z28 for about a year and a half, noticed the sound a while ago but i really didn't pay much attention to it. thank you in advance.

    --MIKE--

  2. #2
    Senior Member camarojunky74's Avatar
    Join Date
    Jun 2007
    Location
    corona ca
    Age
    31
    Posts
    2,258

    white, white and pewter
    Rip99SSA4,74Z28M4,02SSM6

    sounds like your having a lot of knock retard, is the check engine light on? if not could you scan it for codes anyways, i will need some more info to try and point you in the right direction.

  3. #3
    Junior Member
    Join Date
    Jun 2007
    Location
    las vegas
    Posts
    12

    silver
    2000 camaro z28

    Like i said it doesn't sound like an engine knock. i have heard an engine knock before. it doesn't do it when the car is at idle its just when i punch it.the check engine light is not on and i wont be able to scan it for codes for probbly another couple month due to the fact that i am in Iraq.

  4. #4
    Member TexasLS1's Avatar
    Join Date
    Sep 2005
    Location
    Cedar Park, Texas
    Posts
    250

    Red
    '72 Chevy C10 SWB

    My old car would do it a lot, too, but never any engine codes, and it didn't get sluggish. Sounded like something rattling or really bad detonation. My scanner wouldn't show a whole lot of knock retard like I would have expected, so it made me wonder if something was wrong with a knock sensor or wiring. I don't know, though. I tried to get someone at a dealership to listen to it, but he just blew it off saying I needed to run better gas, even though I ran 93 all the time and even octane boosters wouldn't eliminate it. I wanted to slap him.

    I have heard that a bad foil gasket between the AIR pipe and the exhaust manifold can also cause that rattle, so you may want to check that. Did not cure mine, though.

    I would love to find out more info on this, hopefully someone can help.

  5. #5
    Member TexasLS1's Avatar
    Join Date
    Sep 2005
    Location
    Cedar Park, Texas
    Posts
    250

    Red
    '72 Chevy C10 SWB

    Hope everything goes well in Iraq. I couldn't even begin to understand how tough of a job that is. I work for LaRue Tactical here in Texas (you may have heard of us), and we're pretty proud of our troops. Be safe and good luck!!

  6. #6
    Junior Member
    Join Date
    Jun 2007
    Location
    las vegas
    Posts
    12

    silver
    2000 camaro z28

    hey thanks for the reply. someone replied to my other one and said that it sounds like detonation to him so im going to just start with looking at the injectors,change the fuel pump and stuff. start with the cheaper things i am just glad that it is a common problem with the ls1 and nothing major. after talking with people here it was starting to bug me cause it was hard to explain so i figured i would post this to find out better info. if you find out anything else let me know oh yeah i probbly would have wanted to slap that dealer too. things in iraq are going ok as good as they can get. i haven't heard of that company but i really don't pay attention to the names on the stuff we get but i will for sure be looking now. thanks for your support. if i hear anything else on this i will let you know.

  7. #7
    Senior Member camarojunky74's Avatar
    Join Date
    Jun 2007
    Location
    corona ca
    Age
    31
    Posts
    2,258

    white, white and pewter
    Rip99SSA4,74Z28M4,02SSM6

    Quote Originally Posted by mikemurray13 View Post
    Like i said it doesn't sound like an engine knock. i have heard an engine knock before. it doesn't do it when the car is at idle its just when i punch it.the check engine light is not on and i wont be able to scan it for codes for probbly another couple month due to the fact that i am in Iraq.
    lol. knock retard, and detonation are the same thing these days, what i meant was your engine is detonating probably caused by a faulty knock sensor, the term they use is knock retard. anyhow yes its a common problem for the wiring and or the sensor to go out, good luck

  8. #8
    Junior Member
    Join Date
    Jun 2007
    Location
    las vegas
    Posts
    12

    silver
    2000 camaro z28

    so what would you suggest? replace the knock sensor and wiring, then would i have to get it tuned? thanks for all the info im still learning about the Ls1 its my first real nice car so i want it to last a while.

  9. #9
    Senior Member camarojunky74's Avatar
    Join Date
    Jun 2007
    Location
    corona ca
    Age
    31
    Posts
    2,258

    white, white and pewter
    Rip99SSA4,74Z28M4,02SSM6

    you need to get a scanner first before we go any further. i understand your in iraq right now, just pm me when you get back, ill help you out.

  10. #10
    Member GNICTRY's Avatar
    Join Date
    Jun 2007
    Location
    Virginia
    Posts
    558

    Silver
    2000 Trans Am WS6 Ram Air

    i have a weird noise in mine when at wot and about to shift (a4)...not sure if this helps...sub. to learn...

    when i did my cam i replaced my knock sensors and the noise is still there...not touch wiring thou

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: Weird Noise on take off
    By 01SsRacing in forum General Help
    Replies: 6
    Last Post: 09-19-2012, 01:44 PM
  2. Help: noise after i floor it past 3500rpm
    By ls1nightrider in forum General Help
    Replies: 11
    Last Post: 04-02-2012, 04:37 PM
  3. weird noise...
    By Ramairgod84 in forum General Help
    Replies: 4
    Last Post: 04-01-2010, 11:13 AM
  4. weird m6 noise
    By slimm4357 in forum Manual Transmission
    Replies: 1
    Last Post: 06-18-2008, 11:39 AM
  5. Question about putting noise in second
    By Patsy57 in forum External Engine
    Replies: 5
    Last Post: 03-22-2008, 04:25 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •