Results 1 to 16 of 16

Turn Signals Light But Do Not Blink

This is a discussion on Turn Signals Light But Do Not Blink within the Camaro / SS forums, part of the Vehicle Specific category; I am a brand new member and this is my first post. I have finally got my SS (Black 1998) ...

  1. #1
    Junior Member
    Join Date
    Apr 2008
    Location
    Fremont, Ca
    Posts
    4

    Black
    1998 SS

    Turn Signals Light But Do Not Blink

    I am a brand new member and this is my first post. I have finally got my SS (Black 1998) and am really enjoying it.
    Problem - The turn signals light, but they do not blink. The hazard flashers and back-up lights work fine. Brake lights work fine. Both turn signals worked fine and then they stopped blinking a few days ago.
    What do you think the problem is?

  2. #2
    Junior Member
    Join Date
    Oct 2007
    Location
    Connecticut
    Age
    32
    Posts
    60

    Red
    2000 Camaro SS M6

    Could just be a broken relay...cheap part

  3. #3
    Junior Member
    Join Date
    Apr 2008
    Location
    Fremont, Ca
    Posts
    4

    Black
    1998 SS

    Where Is The Relay Located?

    Thank you for your quick reply? Can you tell me where th erelay is located?

  4. #4
    Ebaaaaaaaaa Speedy_Gonzales's Avatar
    Join Date
    Sep 2006
    Location
    Georgia
    Posts
    11,019

    Black
    2014 Camaro 1LS

    welcome to the site...........I would try replacing the bulbs first, they can light up but still be bad causing it not to blink

  5. #5
    Junior Member joker_01z28's Avatar
    Join Date
    Mar 2007
    Location
    Colorado Springs
    Posts
    51

    Maroon
    2000 Silverado

    might sound stupid but check if the bulb is fully connected, mine was coming loose, same thing happened to me.

  6. #6
    Just me Y2KPewterSS's Avatar
    Join Date
    Nov 2006
    Location
    Broken Arrow, OK
    Age
    42
    Posts
    23,353

    Pewter metallic
    2000 Camaro SS

    Quote Originally Posted by SpeedAddict38 View Post
    welcome to the site...........I would try replacing the bulbs first, they can light up but still be bad causing it not to blink
    That has happened to me before, I would try the bulb first as well.
    CCW SP 500s 18x10 275/35 18x11 295/35
    SLP CME with GMMG style catback
    Painted manta stripe

    Quote Originally Posted by konigandy6 View Post
    I'd rather be bi than full homo!!!!

  7. #7
    Junior Member
    Join Date
    Apr 2008
    Location
    Fremont, Ca
    Posts
    4

    Black
    1998 SS

    Changed Bulbs - No Difference

    I changed both of the rear bulbs and the problem is the same. Turn signals - light goes on, stays on, does not blink. Hazard Flashers - work fine. Brake lights - work fine. Any other ideas?

  8. #8
    Ebaaaaaaaaa Speedy_Gonzales's Avatar
    Join Date
    Sep 2006
    Location
    Georgia
    Posts
    11,019

    Black
    2014 Camaro 1LS

    Quote Originally Posted by sween View Post
    I changed both of the rear bulbs and the problem is the same. Turn signals - light goes on, stays on, does not blink. Hazard Flashers - work fine. Brake lights - work fine. Any other ideas?
    change the front ones
    Last edited by Speedy_Gonzales; 04-05-2008 at 06:53 PM.

  9. #9
    Member ZForce1's Avatar
    Join Date
    Jul 2007
    Location
    Maine
    Posts
    124

    red
    1999 camaro Z28

    changing bulbs will not work. If the flashers work then the bulbs are fine - that is how to troubleshoot finding one bulb being out amongst all of them. It is most likely the flasher unit under the dash that controls the turn signals.

  10. #10
    Junior Member
    Join Date
    Apr 2008
    Location
    Fremont, Ca
    Posts
    4

    Black
    1998 SS

    How/Where To Replace Flasher Unit?

    Thanks. My next purchase will have to be the factory shop manuals!
    Can you tell me where the flasher unit is located and how it is replaced?

  11. #11
    Ebaaaaaaaaa Speedy_Gonzales's Avatar
    Join Date
    Sep 2006
    Location
    Georgia
    Posts
    11,019

    Black
    2014 Camaro 1LS

    Quote Originally Posted by ZForce1 View Post
    changing bulbs will not work. If the flashers work then the bulbs are fine - that is how to troubleshoot finding one bulb being out amongst all of them. It is most likely the flasher unit under the dash that controls the turn signals.
    I had the exact same problem and it turned out to be the front bulb
    Last edited by Speedy_Gonzales; 04-05-2008 at 07:18 PM.

  12. #12
    Ebaaaaaaaaa Speedy_Gonzales's Avatar
    Join Date
    Sep 2006
    Location
    Georgia
    Posts
    11,019

    Black
    2014 Camaro 1LS

    Quote Originally Posted by sween View Post
    Thanks. My next purchase will have to be the factory shop manuals!
    Can you tell me where the flasher unit is located and how it is replaced?
    where is the flasher for the blinker located ?
    There is a pic of the flasher in this thread...........unclip and unplug is all

  13. #13
    Member camaross19973's Avatar
    Join Date
    Mar 2007
    Location
    Los Angeles
    Age
    44
    Posts
    238

    blue
    1999 camaro ss #976

    yes ck ur bulb i had same problem,has to be one of them.

  14. #14
    A friggin fish! LOL buswwa's Avatar
    Join Date
    May 2007
    Location
    Vernon, CT
    Posts
    653

    Pewter
    2000 Z28

    Also check the front turn signal housings for water. Both of my bulbs in the front went this week due to water collecting in the lense. Last set of turn signals I had this happen with actually melted due to the heat/water and the bulbs literally exploded. Oh, and enjoy getting to those bulbs. In case no one told you, you have to remove the headlight assembly to get to the front turn signals.
    FOR SALE 2000 Z28 M6
    It's pretty much Raw Awesome

  15. #15
    Ebaaaaaaaaa Speedy_Gonzales's Avatar
    Join Date
    Sep 2006
    Location
    Georgia
    Posts
    11,019

    Black
    2014 Camaro 1LS

    Quote Originally Posted by buswwa View Post
    Also check the front turn signal housings for water. Both of my bulbs in the front went this week due to water collecting in the lense. Last set of turn signals I had this happen with actually melted due to the heat/water and the bulbs literally exploded. Oh, and enjoy getting to those bulbs. In case no one told you, you have to remove the headlight assembly to get to the front turn signals.
    its much easier to change them from under the car. Just remove the bolt/bolts for the plastic flap to fold down

  16. #16
    A friggin fish! LOL buswwa's Avatar
    Join Date
    May 2007
    Location
    Vernon, CT
    Posts
    653

    Pewter
    2000 Z28

    Eh, its either a few bolts form underneath, and I think one, maybe two to pop out the headlights. The design is to remove the one or two from the headlight, and then they just slide out as one piece. Ill let ya know after I change em tomorrow.

    edit Nope, it was defintitely easier to do them from the top. One bolt on the headlight housing, and disconnect the headlights. Slide the headlight housings out and the turn signals are right there below. The turn signal socket is even mounted on top, so I would bet its much easier then going in from the underside. Also, foglight bulbs are very easy to change once the headlights are out of the way.
    Last edited by buswwa; 04-06-2008 at 04:36 PM. Reason: Had em out today

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: turn on right blinker, ALL lights blink??? HELP
    By ggino85 in forum Stereo and Electronics
    Replies: 4
    Last Post: 08-25-2009, 05:40 PM
  2. turn signal doesn't blink but the light comes on
    By ajonesz28 in forum Camaro / SS
    Replies: 20
    Last Post: 03-23-2009, 04:02 PM
  3. help turn signals dont blink
    By Speedy_Gonzales in forum Camaro / SS
    Replies: 11
    Last Post: 05-26-2007, 12:55 PM
  4. RunnWS7's Fog Light and Turn Signals
    By KiD WiCKeD in forum Firebird / WS6
    Replies: 13
    Last Post: 04-24-2007, 09:50 AM
  5. Turn Signals
    By topgun1851 in forum General Help
    Replies: 4
    Last Post: 07-19-2006, 09:45 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •