Results 1 to 19 of 19

turn signal

This is a discussion on turn signal within the Camaro / SS forums, part of the Vehicle Specific category; ya so i touch my car out and the turn signals dont work in or out of the car and ...

  1. #1
    Member SSMOKEshow's Avatar
    Join Date
    Feb 2008
    Location
    in the world
    Age
    30
    Posts
    227

    black
    1999 Camaro SS

    turn signal

    ya so i touch my car out and the turn signals dont work in or out of the car and it doesnt even make the clicking noise what can it be

  2. #2
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    Either the fuse or the flasher comes to mind. I changed fuses and they kept popping. I changed my flasher yesterday and I haven't had any probs...YET.

  3. #3
    ls1ftw tigersport14's Avatar
    Join Date
    Sep 2006
    Location
    Tulsa
    Age
    29
    Posts
    2,035

    NBM
    98 trans am

    sockets, bulbs... idk. i always get that problem. i gave up and i have no blinkers

  4. #4
    Senior Member JaycenK's Avatar
    Join Date
    Nov 2008
    Location
    Holiday,FL
    Age
    40
    Posts
    1,378

    Green
    1997 Camaro Z-28

    Check the plugs at the base of the steering column if none of the above stuff works. Had a 94 that the high beams would not work after I had my wife take it to pepboy to have the low beams replaced and it turns out either the bastards unpluged the high beam harness at the base of the column to try and get her to buy high beams as well or the conector (that had clips on both sides) some how had fallen off. lol

  5. #5
    Army Dude robcas47's Avatar
    Join Date
    Nov 2007
    Location
    Ft. Rucker Area, Lower AL
    Posts
    674

    Arctic White
    01 TA / 06 Duc 749D

    I just went through this with my d/s turn signal. It was the bulb, try swapping out your bulbs and hopefully that will be the end of that problem.

  6. #6
    Member devil6rr's Avatar
    Join Date
    Oct 2008
    Location
    NJ
    Posts
    440

    SOM / NBM
    2002 Pro Z28/2001 TurboTA

    Hey robcas47 what hood is that in your avatar?

  7. #7
    Army Dude robcas47's Avatar
    Join Date
    Nov 2007
    Location
    Ft. Rucker Area, Lower AL
    Posts
    674

    Arctic White
    01 TA / 06 Duc 749D

    It's a stingray hood from vfn. I had the cowl and horn painted gloss black and had the front of the cowl cut open.

  8. #8
    Junior Member
    Join Date
    Aug 2008
    Location
    LOS ANGELES
    Posts
    66
    did you check if the wires are getting power

  9. #9
    900hp for 08 PhillyLs1's Avatar
    Join Date
    Mar 2007
    Location
    Philly/MD
    Posts
    401

    Sebring Silver
    00 Camaro SS/09 LS3 Vette

    Quote Originally Posted by SSMOKEshow View Post
    ya so i touch my car out and the turn signals dont work in or out of the car and it doesnt even make the clicking noise what can it be
    I've heard that poor punctuation and grammar is usually the culprit.

  10. #10
    Member SSMOKEshow's Avatar
    Join Date
    Feb 2008
    Location
    in the world
    Age
    30
    Posts
    227

    black
    1999 Camaro SS

    thanx i try

  11. #11
    SS-EIAN SSNAKEATER23's Avatar
    Join Date
    Oct 2005
    Location
    CHICAGO
    Age
    37
    Posts
    616

    SILVER
    1999 CAMARO SS

    Try the nomal tests.....

    1. Bulbs
    2. Fuses
    3. Wires and Harness
    4. Flasher

    It sounds like a flasher issue, I had an issue w that in my monte carlo. With no clicking at all. Changed the flasher and it was all good.

  12. #12
    Member 6sw00's Avatar
    Join Date
    May 2006
    Location
    N.Y
    Age
    31
    Posts
    282

    black
    2000 trans am ws6

    my signals just struggle to blink. its strange, im guessing its the flasher but i have no clue where it is..

  13. #13
    Member FullBlack4thGen's Avatar
    Join Date
    Mar 2009
    Location
    Longisland
    Posts
    120

    Black
    98 Z28

    Make sure you change the turning light bulbs and not the daytime running bulbs.

    Big bulb = Right
    Little bulb = Not Right

  14. #14
    Member
    Join Date
    Nov 2008
    Location
    harrisburg pa.
    Age
    61
    Posts
    868

    black
    02 vette vert

    Quote Originally Posted by FullBlack4thGen View Post
    Make sure you change the turning light bulbs and not the daytime running bulbs.

    Big bulb = Right
    Little bulb = Not Right
    big bulb= turn signal, parking, drl. dual filament bulb.

    little bulb= side marker light. single filament bulb.

  15. #15
    Aw shucks. bluefields88's Avatar
    Join Date
    Jul 2006
    Location
    Berkeley, CA
    Posts
    3,619

    Red
    2000 Camaro SS #3574 A4

    It's your bulbs. Check to see which one wont light up as a running light. Change the bulb. problem solved. I had to do it. Easiest way to get access is to remove the headlight and go in from the top, or you can unbolt some stuff on the bottom and reach up and do it.

  16. #16
    Aw shucks. bluefields88's Avatar
    Join Date
    Jul 2006
    Location
    Berkeley, CA
    Posts
    3,619

    Red
    2000 Camaro SS #3574 A4

    Quote Originally Posted by FullBlack4thGen View Post
    Make sure you change the turning light bulbs and not the daytime running bulbs.

    Big bulb = Right
    Little bulb = Not Right
    When it happened to me my running light didn't light up until I swapped out my blinker bulb.

  17. #17
    Member
    Join Date
    Nov 2008
    Location
    harrisburg pa.
    Age
    61
    Posts
    868

    black
    02 vette vert

    Quote Originally Posted by bluefields88 View Post
    When it happened to me my running light didn't light up until I swapped out my blinker bulb.
    your running light is your blinker bulb.

  18. #18
    Aw shucks. bluefields88's Avatar
    Join Date
    Jul 2006
    Location
    Berkeley, CA
    Posts
    3,619

    Red
    2000 Camaro SS #3574 A4

    Quote Originally Posted by dklowrider View Post
    your running light is your blinker bulb.
    That's what I thought. It looked like you guys were saying there were two different sized bulbs. I only saw one. Getting me all confused.

  19. #19
    Member
    Join Date
    Nov 2008
    Location
    harrisburg pa.
    Age
    61
    Posts
    868

    black
    02 vette vert

    Quote Originally Posted by bluefields88 View Post
    That's what I thought. It looked like you guys were saying there were two different sized bulbs. I only saw one. Getting me all confused.
    in your housing you have a 3157 for park, turn and drl, you also have a 194 bulb [small one to the side of the housing] which is your side marker light when you turn on the lights, goes along with the one on the side in the rear, except rear is red. two bulbs.
    Last edited by dklowrider; 06-09-2009 at 04:21 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question: turn signal keeps going out.
    By dav-02ws6-m6 in forum General Help
    Replies: 5
    Last Post: 02-02-2012, 03:19 AM
  2. Turn signal?
    By GrapeApeTA in forum General Help
    Replies: 15
    Last Post: 01-23-2011, 12:14 PM
  3. right turn signal
    By bgon99ss in forum Stereo and Electronics
    Replies: 18
    Last Post: 04-19-2010, 09:49 AM
  4. Turn Signal
    By Z28boy2000 in forum Stereo and Electronics
    Replies: 1
    Last Post: 03-30-2009, 12:36 PM
  5. Turn Signal PLEASE HELP
    By TA2FST4U in forum General Help
    Replies: 2
    Last Post: 06-01-2006, 08:35 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •