Page 1 of 4 1234 LastLast
Results 1 to 20 of 68

SLP Lid installed

This is a discussion on SLP Lid installed within the Camaro / SS forums, part of the Vehicle Specific category; I installed my lid but I was curious. Is it suppose to have a hole in the side? Take a ...

  1. #1
    Member Eric1987's Avatar
    Join Date
    Jun 2008
    Location
    Long Beach, California
    Posts
    853

    Black
    1999 Z28 Convert

    SLP Lid installed

    I installed my lid but I was curious. Is it suppose to have a hole in the side? Take a look.



  2. #2
    Senior Member Rhinohuey's Avatar
    Join Date
    Mar 2007
    Location
    Glendale, AZ
    Posts
    1,460

    Black
    1999 Trans Am

    should have came with a plug to plug it since you have a 99

  3. #3
    Senior Member Rhinohuey's Avatar
    Join Date
    Mar 2007
    Location
    Glendale, AZ
    Posts
    1,460

    Black
    1999 Trans Am

    see picture http://us.st12.yimg.com/us.st.yimg.c..._2033_86082765

    you could probably find something that will work just as good

  4. #4
    Member Eric1987's Avatar
    Join Date
    Jun 2008
    Location
    Long Beach, California
    Posts
    853

    Black
    1999 Z28 Convert

    The list didnt say anything about a plug. I used all the supplies it came with. What do you guys suggest I use? And how do I get rid of the rattle sound from my PS pulley? WD40 works for like 20 seconds then it comes back.

  5. #5
    OOHHH YEAH! jray0305usa's Avatar
    Join Date
    Apr 2008
    Location
    toledo ohio
    Age
    31
    Posts
    253

    black
    99 z28 a4

    shoulda came ith a plug... i just installed mine sure u didnt get the wrong one?

  6. #6
    Member c5z28's Avatar
    Join Date
    Apr 2008
    Location
    Bay Area
    Posts
    8,120

    On your ass flashing
    my highbeams

    that's for the air pump hose just go to home depot and find a cap.

  7. #7
    GET SOME claytonr's Avatar
    Join Date
    Apr 2007
    Location
    San Antonio, Texas
    Age
    28
    Posts
    374

    Pewter Metallic
    2002 Pontiac Trans AM

    cover it with duct tape or something til you find an adequite plug you dont want shit gettin in there for dam sure..mine came with a plug..you ordered the wrong year..or they sent you one for the wrong year..i would raise some hell and make them send it!

  8. #8
    Impounded
    Join Date
    Jul 2008
    Location
    ...
    Age
    29
    Posts
    674
    you need to get a bellow bro?

  9. #9
    Member Eric1987's Avatar
    Join Date
    Jun 2008
    Location
    Long Beach, California
    Posts
    853

    Black
    1999 Z28 Convert

    Quote Originally Posted by 99TransAmSLP View Post
    you need to get a bellow bro?
    I dont know what that is. And I ordered it off ebay. I dont think I checked the year but its no big deal anyways. My dad is gonna seal it up for me.

    EDIT: The one I got http://cgi.ebay.com/ebaymotors/ws/eB...3AIT&viewitem=

    So I ordered the wrong one I guess. It says 2000-2002
    Last edited by Eric1987; 01-21-2009 at 05:35 PM.

  10. #10

  11. #11
    Member Eric1987's Avatar
    Join Date
    Jun 2008
    Location
    Long Beach, California
    Posts
    853

    Black
    1999 Z28 Convert

    Seems kinda retarded 60 bucks for that. And also anyone know what to do about my PS pulley noise? WD40 makes it okay temporarily.

  12. #12
    Impounded
    Join Date
    Jul 2008
    Location
    ...
    Age
    29
    Posts
    674
    haha
    might wanna try and fix it

  13. #13
    Impounded
    Join Date
    Jul 2008
    Location
    ...
    Age
    29
    Posts
    674
    haha
    might wanna try and fix it

  14. #14
    Junior Member
    Join Date
    May 2007
    Location
    groves TX
    Posts
    36
    Quote Originally Posted by 99TransAmSLP View Post
    you need to get a bellow bro?
    a bellow is a waste of cash, if you are dead set on getting rid of the accordian do the fernco mod

  15. #15
    TJEA Retirement Home Dr.Crash's Avatar
    Join Date
    Feb 2006
    Location
    U. S And A Greatest country in all of world
    Posts
    3,383

    Stock
    2002 Camaro

    Quote Originally Posted by streetassasin View Post
    a bellow is a waste of cash, if you are dead set on getting rid of the accordian do the fernco mod
    Whats that?

  16. #16

  17. #17
    Member Eric1987's Avatar
    Join Date
    Jun 2008
    Location
    Long Beach, California
    Posts
    853

    Black
    1999 Z28 Convert

    I might buy the bellow later on but yeah I am putting my LTs on tomorrow morning! Wish me good luck!

  18. #18
    Senior Member clg82's Avatar
    Join Date
    Feb 2007
    Location
    California
    Age
    35
    Posts
    2,453
    2000 Trans Am

    Quote Originally Posted by Eric1987 View Post
    I might buy the bellow later on but yeah I am putting my LTs on tomorrow morning! Wish me good luck!
    how are you putting on long tubes with cali smog? i want to do the same thing but am affraid to because of smog........

  19. #19
    Member Eric1987's Avatar
    Join Date
    Jun 2008
    Location
    Long Beach, California
    Posts
    853

    Black
    1999 Z28 Convert

    I am just running without the cats until I gotta smog my car. By then I'll know how to do it then switch it out. Or find someone who'll pass me for a fee.

  20. #20
    Impounded
    Join Date
    Oct 2007
    Location
    Beaver Dam KY
    Posts
    7,746

    79 T/A -91 Firebird
    1998 Trans Am -Oynx Black

    Have you changed the belt/tensioner yet? If its squeeky its probably not the pulley. It had no bearings.. you have very bad luck with pumps bro.. You can try changing out the pulley with a billet one for 60 bucks lol

Page 1 of 4 1234 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. PHB installed
    By Formula Dave in forum Suspension and Handling
    Replies: 18
    Last Post: 01-21-2008, 10:11 AM
  2. just installed B&M..!?
    By NIKDSC5 in forum Corvette
    Replies: 6
    Last Post: 12-31-2007, 03:31 PM
  3. Need a Cam installed in MD
    By INeedLS1 in forum Eastern Members
    Replies: 6
    Last Post: 05-16-2007, 04:21 PM
  4. Got my cam installed
    By BlackBeastLS1 in forum Internal Engine
    Replies: 18
    Last Post: 08-23-2006, 12:02 PM
  5. Anybody installed one of these?
    By CamaroKillZ28 in forum Manual Transmission
    Replies: 9
    Last Post: 03-15-2006, 07:11 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •