Results 1 to 8 of 8

serpentine belt help!!

This is a discussion on serpentine belt help!! within the Camaro / SS forums, part of the Vehicle Specific category; Ok my car (2000 ss) has the notorious "belt squeel". I went and bought a new tensioner and serp belt, ...

  1. #1
    Junior Member 2kss's Avatar
    Join Date
    Dec 2006
    Location
    south jersey
    Posts
    21

    pewter
    2000 camaro ss

    serpentine belt help!!

    Ok my car (2000 ss) has the notorious "belt squeel". I went and bought a new tensioner and serp belt, put them both on and it still squeels....but now that is the least of my problems. I asked a friend who has a 99 vette on any suggestions for the squeel. He said to take the belt off and turn it around. I didnt see how that could help but i figured id give it a shot. So i went out the next morning and took the belt off and turned it around. now heres where the problem comes. when i went to put the belt back on...it easily slipped around every pulley and the tensioner with out having to even move the tensioner. so it almost seems like it is like 6" too long.?? Yes i have it on correctly. no pulleys were missed. two other people (not f-body people) have looked at it just to make sure i didnt make any mistakes that i may have over looked. No the new belt and tensioner are not the wrong ones. i put the new belt and tensioner on one day and drove it then took it off the next and now wont go on correctly. even went out and bought another new tensioner and pulley and the same thing happens. please any suggestions or ideas would be greatly appreciated. im pretty new to these cars so maybe something else moved or broke that im not seeing. thanks

  2. #2
    We'll be back... GatorSS's Avatar
    Join Date
    Aug 2005
    Location
    THE SWAMP
    Posts
    1,446

    Light Pewter Metallic
    2000 Camaro SS M6

    I can't imagine a belt stretching that much, so something must be mounted wrong. It has to be. Otherwise, you would have a severely defective belt. Just to check, take the belt and compare its length to another new one.

    As far as the belt squeal, it's probably one of your other pulleys, such as one or both on the A/C belt.

  3. #3
    Junior Member 2kss's Avatar
    Join Date
    Dec 2006
    Location
    south jersey
    Posts
    21

    pewter
    2000 camaro ss

    yea belts dont stretch like that. i had the same idea also. i took the belt to the store...compared it and it was the same size. just for shits and giggles. i bought another new belt and tensioner. same thing. the part that i dont understand is that the new belt and tensioner installed perfectly the day before, but when i took the belt off the next day it is too long???? haha im so past the point of frustration that its become funny. anyone else have any ideas?

  4. #4
    Member SSmoky01's Avatar
    Join Date
    Sep 2006
    Location
    Central,Texas
    Age
    38
    Posts
    447

    Navy Blue Metallic
    2000 Camaro Z-28 SS

    Quote Originally Posted by GatorSS View Post
    I can't imagine a belt stretching that much, so something must be mounted wrong. It has to be. Otherwise, you would have a severely defective belt. Just to check, take the belt and compare its length to another new one.

    As far as the belt squeal, it's probably one of your other pulleys, such as one or both on the A/C belt.
    I am with GatorSS. The belt squeal is probably your AC belt or tensioner. Mine just started squealin' to and I replaced my main belt. Still squealin' so now I will replace my AC belt today.

  5. #5
    Member SSmoky01's Avatar
    Join Date
    Sep 2006
    Location
    Central,Texas
    Age
    38
    Posts
    447

    Navy Blue Metallic
    2000 Camaro Z-28 SS

    What brand of belt is it and what is your part number off the belt? If you have one of your reciepts.

  6. #6
    Junior Member 2kss's Avatar
    Join Date
    Dec 2006
    Location
    south jersey
    Posts
    21

    pewter
    2000 camaro ss

    yea the squeeling im not worried about now. i just want to get the car running again. its been sitting for a week now because of a damn serp belt.
    blet brand is dayco and the part number on the receipt from pep boys is 89338, number on belt is 5060790...thanks but also keep in mind i drove the car for a day and it was fine. next day i took it off it didnt fit. so the belt fir fine at one point.

  7. #7
    Member SSmoky01's Avatar
    Join Date
    Sep 2006
    Location
    Central,Texas
    Age
    38
    Posts
    447

    Navy Blue Metallic
    2000 Camaro Z-28 SS

    Well the part number is correct. The only possible way that the belt is 6" too long is that it was not installed correctly. All I can say is be sure that when you slip the over the tensioner be sure that it is one every pulley just like it shows on the diagram on the car.

  8. #8
    Junior Member 2kss's Avatar
    Join Date
    Dec 2006
    Location
    south jersey
    Posts
    21

    pewter
    2000 camaro ss

    yes its over every one. ive taken it off probally 40 times just to make sure. even had some one else do it. something else had to have broken or something

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: Serpentine belt
    By derekbuckner1 in forum General Help
    Replies: 21
    Last Post: 08-15-2012, 07:44 AM
  2. Question: serpentine belt
    By txoutlaw69 in forum Firebird / WS6
    Replies: 3
    Last Post: 01-19-2012, 06:56 PM
  3. Serpentine belt
    By 00hawk109 in forum External Engine
    Replies: 6
    Last Post: 06-20-2009, 04:14 PM
  4. Help: Serpentine Belt!
    By slowss416 in forum General Help
    Replies: 10
    Last Post: 04-04-2008, 11:55 AM
  5. Serpentine belt
    By derbs in forum LT1
    Replies: 3
    Last Post: 03-28-2007, 05:54 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •