Results 1 to 4 of 4

Power loss

This is a discussion on Power loss within the Camaro / SS forums, part of the Vehicle Specific category; So i posted this in the manual trans section and got no responce. But i rburnt my clutch slightly about ...

  1. #1
    Member
    Join Date
    Nov 2009
    Location
    North Carolina
    Posts
    379

    Black
    2001 Camaro Z28

    Power loss

    So i posted this in the manual trans section and got no responce. But i rburnt my clutch slightly about 1000 miles ago and the other day when i drove it hard for the first time since then I realized i couldnt bark third at all. I thought it was a clutch problem? But now it seems like im not getting the power i once was and the car feels like its lacking acceleration any ideas? Its a 2001 z28 M6 23,000 miles

  2. #2
    Moderator 35th-ANV-SS's Avatar
    Join Date
    Oct 2008
    Location
    Wherever life takes me
    Posts
    12,465

    Red
    02 35th LE Camaro SS

    Any SES light?

    Have you tried cleaning the MAF? If the power loss is significant enough, it could be cats or even a fuel issue. I would start with the MAF cleaning, then move on to checking fuel pressure.

    If your clutch is slipping, you would definitely be able to feel that. Your RPMs would probably jump without the car accelerating. Is the clutch stock or aftermarket?

  3. #3
    Member
    Join Date
    Sep 2010
    Location
    WI
    Posts
    129
    2000 Trans Am

    Are you up to date on all the routine maintenance? (plugs, air filter, fuel filter etc..) Has gas mileage gone to crap?

    I would try sea foaming the car and go from there. It could be just the beginning of the end for your clutch but only time will tell. It may just not grab as well as it once used to.

  4. #4
    Member
    Join Date
    Nov 2009
    Location
    North Carolina
    Posts
    379

    Black
    2001 Camaro Z28

    checked the MAF and it was absolutely filthy cleaned it off and now just waiting for the rain to stop and roads to try to see if it worked

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How much power loss ?
    By karpetcm in forum Computer & Tuning
    Replies: 2
    Last Post: 03-22-2010, 02:22 PM
  2. Loss of power
    By 99RTA in forum General Help
    Replies: 0
    Last Post: 05-19-2009, 06:52 AM
  3. Help: Power loss
    By BIG GUNS in forum Internal Engine
    Replies: 1
    Last Post: 10-20-2008, 01:44 PM
  4. is this why i have power loss???
    By 02sscamaro in forum General Help
    Replies: 1
    Last Post: 09-13-2007, 02:15 PM
  5. Power loss
    By Even10Flow in forum Convertible
    Replies: 5
    Last Post: 05-16-2007, 08:26 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •