Results 1 to 11 of 11

power bost!!!

This is a discussion on power bost!!! within the Camaro / SS forums, part of the Vehicle Specific category; so i have a 2002 camaro z28 m6 its stock rite now and i think is low on hp i ...

  1. #1
    REAPER Z28 reaper ws6's Avatar
    Join Date
    Apr 2009
    Location
    Tyler TX
    Age
    28
    Posts
    516

    Navy Blue Metallic/Black
    02 camaro z28/01 wife t/a

    power bost!!!

    so i have a 2002 camaro z28 m6 its stock rite now and i think is low on hp i use suprem and royal purple on it so i dont think is the fluids but if ya have any suggestions as to better fluids please let me know? i have a stock air box lid and stock exhaust i was thinking on goin slp on it with the full air kick and exhaust and i was wondering if there is any thing better then slp for hp bost?? but is my daily driver so i dont want cams i herd there really bad for your dailly driver?? thanks for yall help


    also wen i cold star it it back fires on me i was wondering why?? but only on cold starts i dont think it gots a catalytic converter and the exhaust is really crapy is all rusted and stuff?? i am goin to get a new catalytic converter and different exhaust but i was wondering why does it back fire??
    Last edited by reaper ws6; 09-15-2009 at 09:24 PM.

  2. #2
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Welcome to the site. Royal purple is garbage I'd get it out of your car before it gets damaged!

    Check this out. I'm a Oil Junkie
    :\Users\Steven\Pictures\d6ftg5nh.gif


    Suggestion: If you are particularly irritated by another member's posting habits and are constantly fighting the urge to flame them, you can click on that person's profile, and select "Add to ignore list." This will make that person's posts invisible to you.

  3. #3
    Senior Member tatertot91's Avatar
    Join Date
    Oct 2008
    Location
    Coral Springs, Fl
    Posts
    5,773

    Sunset Orange Metalic
    2001 Camaro SS

    just a lil popping when revving cold?
    you can get a good streetable cam
    Read up on that oil thread
    Magnaflow and hooker are good exhaust sytems, so are corsa and borla if you wanna go big bucks
    SLP lid is good
    Headers will help
    Dont do headers with slp exhaust unless you like rasp

  4. #4
    Moderator 35th-ANV-SS's Avatar
    Join Date
    Oct 2008
    Location
    Wherever life takes me
    Posts
    12,465

    Red
    02 35th LE Camaro SS

    Quote Originally Posted by tatertot91 View Post
    just a lil popping when revving cold?
    you can get a good streetable cam
    Read up on that oil thread
    Magnaflow and hooker are good exhaust sytems, so are corsa and borla if you wanna go big bucks
    SLP lid is good
    Headers will help
    Dont do headers with slp exhaust unless you like rasp
    SLP exhaust will only be raspy with SLP headers. I have SLP LM2 with Kooks LTs and it sounds AMAZING.

    To the OP, You don't want to get SLP headers, they have clearance issues.

  5. #5
    James Bond Spikito's Avatar
    Join Date
    Aug 2007
    Location
    Texas
    Age
    30
    Posts
    4,546

    2001 3.8 Black - sold
    2000 SS Black M6

    I forget who makes it but they make some popular cams i think its like M3 and M4, or MS3 and MS4, i dunno but whatever they are, the lower numbered one is supposed to be good if you still want a DD. You can always get a custom grind from Comp Cams. but you need new pushrods and valve springs as well...total job is gonna cost about $1300 unless you install youself

  6. #6
    Moderator 35th-ANV-SS's Avatar
    Join Date
    Oct 2008
    Location
    Wherever life takes me
    Posts
    12,465

    Red
    02 35th LE Camaro SS

    I thought the MS3 cam was kinda radical for a DD

  7. #7
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,567

    Black & Blue
    '02 WS.6 / '07 Suburban

    Welcome. Before dumping money in mods, you may want to try some maintenance items. If you have not yet done so, clean the MAF, replace your spark plugs, ensure that your air filter is in good shape, replace your fuel filter and run a fuel system cleaner such as Chevron Techron. You may also have power issues if your catalytic converters are on the way out.

  8. #8
    REAPER Z28 reaper ws6's Avatar
    Join Date
    Apr 2009
    Location
    Tyler TX
    Age
    28
    Posts
    516

    Navy Blue Metallic/Black
    02 camaro z28/01 wife t/a

    Quote Originally Posted by pajeff02 View Post
    Welcome. Before dumping money in mods, you may want to try some maintenance items. If you have not yet done so, clean the MAF, replace your spark plugs, ensure that your air filter is in good shape, replace your fuel filter and run a fuel system cleaner such as Chevron Techron. You may also have power issues if your catalytic converters are on the way out.
    thanks man yeah she is gettin a tune the spark plugs belts and the air filter are all being replace...

  9. #9
    REAPER Z28 reaper ws6's Avatar
    Join Date
    Apr 2009
    Location
    Tyler TX
    Age
    28
    Posts
    516

    Navy Blue Metallic/Black
    02 camaro z28/01 wife t/a

    thanks for the help as to my back firering problem its just a little popping on cold starts but its only for a few secons once it gets heat up it doesn't make it any more and if i rev it on a cold start to like 1500 rpm it doesn't make it at all i think the exhaust just needs to get heat up?? and wen im driving and shifting it doesn't make it eighter only wen first starting the maro does it make it and only for like 20 or 30 secons mabey les then that?? so what do you guys think the problem is???

  10. #10
    Exalted Cyclops 67CamaroRSSS's Avatar
    Join Date
    Feb 2007
    Location
    San Diego, CA
    Posts
    5,824

    2002 Z28 A4 NBM
    Sadly now demodded :(

    Quote Originally Posted by reaper ws6 View Post
    thanks for the help as to my back firering problem its just a little popping on cold starts but its only for a few secons once it gets heat up it doesn't make it any more and if i rev it on a cold start to like 1500 rpm it doesn't make it at all i think the exhaust just needs to get heat up?? and wen im driving and shifting it doesn't make it eighter only wen first starting the maro does it make it and only for like 20 or 30 secons mabey les then that?? so what do you guys think the problem is???
    My 98 does this during cold start. I ignore it as it's the only time it does it. The again it's got almost 180,xxx on it and the cats are probably shot....

  11. #11
    Senior Member
    Join Date
    Mar 2009
    Location
    Milwaukee
    Posts
    3,260

    Arctic White, red/gray
    1997 Corvette, 92 Typhoon

    Quote Originally Posted by 35th-ANV-SS View Post
    I thought the MS3 cam was kinda radical for a DD
    It is 237/242 .6++/.6++ is a bit high for streetable. You can use it as a DD but its not gonna be as nice as some other cams that can still get you decent numbers.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: Stereo and power windows losing power randomly
    By Woodles in forum Stereo and Electronics
    Replies: 5
    Last Post: 10-11-2010, 01:00 PM
  2. HYPERTECH POWER PROGRAMMER III Power Gains?
    By 180ls1 in forum Computer & Tuning
    Replies: 10
    Last Post: 11-07-2007, 10:41 AM
  3. throttle body bost
    By Evil Goat in forum GTO
    Replies: 1
    Last Post: 03-28-2007, 09:42 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •