Page 2 of 2 FirstFirst 12
Results 21 to 33 of 33

I think I broke my ASR?

This is a discussion on I think I broke my ASR? within the Camaro / SS forums, part of the Vehicle Specific category; You're the first person to shed light on this for me, thank you very much. By the way I'm about ...

  1. #21
    Member ezwip's Avatar
    Join Date
    May 2008
    Location
    purgatory
    Posts
    354

    Black
    02 Z28 M6

    You're the first person to shed light on this for me, thank you very much. By the way I'm about 10 years older then that and I've always driven stick. I intend to have this fixed by the end of the week, but it's been a true test of patience. As you can tell I'm not coping with it very well at all! Maybe with what you just said it will be easier to get by. Thanks again.

  2. #22
    Exalted Cyclops 67CamaroRSSS's Avatar
    Join Date
    Feb 2007
    Location
    San Diego, CA
    Posts
    5,824

    2002 Z28 A4 NBM
    Sadly now demodded :(

    You're welcome. Glad I could be of some help.

    IMHO, 4th gen's with LS1 power are the best bang for the buck out there.

  3. #23
    Member ezwip's Avatar
    Join Date
    May 2008
    Location
    purgatory
    Posts
    354

    Black
    02 Z28 M6

    I knew it had to be faster then a skateboard but I couldn't find any proof on the interweb!

  4. #24
    Aw shucks. bluefields88's Avatar
    Join Date
    Jul 2006
    Location
    Berkeley, CA
    Posts
    3,619

    Red
    2000 Camaro SS #3574 A4

    Quote Originally Posted by ezwip View Post
    I knew it had to be faster then a skateboard but I couldn't find any proof on the interweb!
    go to any Mustang forum, they'll tell you.

  5. #25
    SS Driver aerojt's Avatar
    Join Date
    Jul 2007
    Location
    Ohio
    Posts
    553

    Black
    1998 Camaro SS M6 #1871

    Don't be fooled in thinking the skip shift is always working. It only slides into fourth when you are going like below 20mph and under 2000 rpm. It also depends on the engines temp. Like it was said earlier, wide open throttle or even hard accelerating eliminates the skip shift. Personally, im prob the only one, I like the skip shift just for putting around town. It has never gotten in my way when I needed to open up the car for a quick sprint.

  6. #26
    Member ezwip's Avatar
    Join Date
    May 2008
    Location
    purgatory
    Posts
    354

    Black
    02 Z28 M6

    I had noticed it wasn't always forcing me into fourth. For whatever reason I got it in my head that I had to go really slow in first. The slightest pressure on the gas and I'm stuck in fourth. You should see me taking off it's comical. A skateboarder really would pass me. I'm going to experiment with this new knowledge on the way home in a few minutes.

  7. #27
    Member SAGGIN's Avatar
    Join Date
    May 2007
    Location
    Elk Grove, CA
    Posts
    994

    RED
    02 SS, 03 BMW 745

    Quote Originally Posted by Mr. Hyde View Post
    Consider yourself blessed! Now just take out that bulb and go on with your life, no one likes that ASR anyway.
    I think its good to have driving in rain and bad weather.

  8. #28
    Pony Killer Insert's Avatar
    Join Date
    Apr 2008
    Location
    Mississauga, Ontario, Canada
    Age
    29
    Posts
    242

    Black
    2002 Camaro SS M6

    Quote Originally Posted by bluefields88 View Post
    well, I swapped out my head unit with a Alpine system, and now the light on my ASR switch doesn't light up. I had my friend in the car and I stomped on the gas for a good time, and my wheels broke loose, yet the traction control wasn't turn off. It didn't kick my foot or let off the gas or anything. Yet, if I flip the switch it says "ASR OFF". what is up with this????
    wow, if only i could break mine like that.

    ps. i dont recommend wasting the time or money to fix it again.

  9. #29
    Senior Member Too Fast's Avatar
    Join Date
    Nov 2006
    Location
    Indianapolis
    Age
    54
    Posts
    5,170

    Black
    2000 WS6 6spd Hooker LT

    Skip shift wasn't that much of a PITA when mine was working, easily defeated by just not shifting out of first when you see the light. the light will go out after a few seconds that way anyway. It never caused me to lose any race, I eliminated it with the SLP thing, and now I can shift into 4th if I desire because the light still lights when appropriate, and it is my choice to do it or not.

    Come on ezwip, it's really not that difficult to work around until you get it eliminated.

  10. #30
    Member Joe00SS's Avatar
    Join Date
    Oct 2005
    Location
    CT
    Age
    46
    Posts
    465

    White Liquid Silver
    2000 Camaro SS/ 02 YZF-R1

    Quote Originally Posted by Mr. Hyde View Post
    Consider yourself blessed! Now just take out that bulb and go on with your life, no one likes that ASR anyway.
    + 1

  11. #31
    Member Joe00SS's Avatar
    Join Date
    Oct 2005
    Location
    CT
    Age
    46
    Posts
    465

    White Liquid Silver
    2000 Camaro SS/ 02 YZF-R1

    Quote Originally Posted by camarojunky74 View Post
    whats wrong with just flipping your switch when your going to race?
    Its the very first thing I do after starting the car EVERYTIME I get in it...

  12. #32
    Stang Smoker
    Join Date
    Feb 2008
    Location
    alameda, CA
    Age
    27
    Posts
    60

    red
    1994 z28

    oh i was gonna say ur fuse is out cuz the same thing happened to me. I switched my jensen to a alpine and i blew a fuse. next thing i knew my odomoter and my asr light wasnt working.

  13. #33
    Your dealership guy konigandy6's Avatar
    Join Date
    Aug 2007
    Location
    Romeo, MI
    Posts
    6,557

    Velocity Yellow
    2008 Corvette Z06

    Wasn't ASR included on all standard SS packages? My Z doesn't have it, and every SS I have been in does. Don't quote me because I could be wrong.

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: I broke something
    By claytonr in forum External Engine
    Replies: 7
    Last Post: 02-01-2011, 09:20 PM
  2. I'm broke
    By c5z28 in forum Almost Anything Goes
    Replies: 19
    Last Post: 10-14-2009, 05:33 PM
  3. Help: Broke this too...wtf is it?
    By third_shift|studios in forum External Engine
    Replies: 9
    Last Post: 02-10-2009, 02:44 PM
  4. I broke this and don't know what it is
    By third_shift|studios in forum External Engine
    Replies: 3
    Last Post: 02-07-2009, 05:53 PM
  5. I think my tcs broke something..
    By pocheasy in forum Suspension and Handling
    Replies: 3
    Last Post: 02-08-2007, 09:32 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •