Results 1 to 3 of 3

HU install now battery dead?

This is a discussion on HU install now battery dead? within the Camaro / SS forums, part of the Vehicle Specific category; So I just installed a new head unit. I got it all figured out and then after I put it ...

  1. #1
    Member Eric1987's Avatar
    Join Date
    Jun 2008
    Location
    Long Beach, California
    Posts
    853

    Black
    1999 Z28 Convert

    HU install now battery dead?

    So I just installed a new head unit. I got it all figured out and then after I put it all together I went to start the car and all it would make was a clicking noise. The gauges would move like crazy and my windows VERY slowly move up and down not like normal speed. My stereo plays but only when the car is off. Other than that the stereo comes on and off rapidly. I checked my fuses right near the dash and the two large metal ones seemed fine. Is it a dead battery?


    EDIT: Also the alarm makes a weak sound too. When I set it of course.
    Last edited by Eric1987; 02-04-2009 at 01:01 PM.

  2. #2
    Senior Member bigrondownhiller's Avatar
    Join Date
    Feb 2006
    Location
    Orange County, NY
    Age
    42
    Posts
    2,674

    Black
    1996 Camaro Z28 vert

    Sounds like the battery is just dead. Did you use a harness adapter or splice the wires?

  3. #3
    Member Eric1987's Avatar
    Join Date
    Jun 2008
    Location
    Long Beach, California
    Posts
    853

    Black
    1999 Z28 Convert

    Well I figured it out. I just needed a jump now everything is back to normal. I used a wire harness from circuit city.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: Dead Battery
    By 35th-ANV-SS in forum General Help
    Replies: 30
    Last Post: 03-29-2011, 07:53 PM
  2. Dead Battery
    By j nix in forum Stereo and Electronics
    Replies: 6
    Last Post: 01-15-2011, 09:02 AM
  3. Question: dead battery
    By slimss in forum General Help
    Replies: 7
    Last Post: 09-11-2010, 02:54 PM
  4. Help: Battery Dead..can't start
    By molecularmann in forum General Help
    Replies: 6
    Last Post: 08-10-2010, 07:56 PM
  5. Trunk, dead battery.
    By INeedLS1 in forum Firebird / WS6
    Replies: 3
    Last Post: 06-19-2009, 03:03 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •