Results 1 to 10 of 10

help with turn signal

This is a discussion on help with turn signal within the Camaro / SS forums, part of the Vehicle Specific category; My 99 Z28 turn signals when on flashes so fast it's like it's a solid light. All bulbs are good ...

  1. #1
    Junior Member
    Join Date
    Jul 2008
    Location
    Twin Falls, Idaho
    Age
    40
    Posts
    42

    blue
    99 Z28 Camaro LS1

    Question help with turn signal

    My 99 Z28 turn signals when on flashes so fast it's like it's a solid light. All bulbs are good and fuses ok too! Does anyone have idea what's going one here?

  2. #2
    Member
    Join Date
    Aug 2005
    Location
    Tulsa,OK
    Age
    37
    Posts
    914

    Quick Silver
    2002 Z06

    Might be a bad flasher.. They are cheap.. Just buy one and try it out.


    Slow Passenger Window - Want Passenger Express Down - Tired of Replacing DayTime Running Light Bulbs

    Camaro Owners Click Here
    Firebird Owners Click Here

    Need instructions to replace your F-Body window motor?
    www.AutoTrix.net

  3. #3
    Junior Member BlackbirdRamAir's Avatar
    Join Date
    Dec 2009
    Location
    Canada
    Age
    36
    Posts
    65

    White
    1999 Trans Am WS-6

    Alternator might be overcharging... had that happen with my 91 GTA

  4. #4
    Junior Member
    Join Date
    Jul 2008
    Location
    Twin Falls, Idaho
    Age
    40
    Posts
    42

    blue
    99 Z28 Camaro LS1

    K I got the flasher replaced and turn signal works properly now, thanks! But, I forgot to ask about my horn, it sounds only when I use my keyless remote but not at the wheel. I think it might be a relay but don't see it under dash. There's one under the hood, swaped it with another and nothing changes! Any ideas on this one?
    Last edited by danmeksch; 01-07-2010 at 04:34 PM.

  5. #5
    Member
    Join Date
    Aug 2005
    Location
    Tulsa,OK
    Age
    37
    Posts
    914

    Quick Silver
    2002 Z06

    Since the horn works with the keyless entry all relays and power to it are probably fine..

    Its just the connector you are pushing on the steering wheel. I have never taken a 4th gen sterring wheel apart but my old 3rd gen just had some copper that touched and it could break real easy.

  6. #6
    Junior Member
    Join Date
    Jul 2008
    Location
    Twin Falls, Idaho
    Age
    40
    Posts
    42

    blue
    99 Z28 Camaro LS1

    K I'll try that tomorrow. Thanks!

  7. #7
    Member bryceslu's Avatar
    Join Date
    Jul 2007
    Location
    Chicago, IL
    Posts
    467

    Black
    00 NHRA Formula

    Quote Originally Posted by danmeksch View Post
    K I got the flasher replaced and turn signal works properly now, thanks! But, I forgot to ask about my horn, it sounds only when I use my keyless remote but not at the wheel. I think it might be a relay but don't see it under dash. There's one under the hood, swaped it with another and nothing changes! Any ideas on this one?
    bad Flasher? i am having a very similar issue...blinkers go at mach 5. what do you mean by flasher?

  8. #8
    Junior Member
    Join Date
    Jul 2008
    Location
    Twin Falls, Idaho
    Age
    40
    Posts
    42

    blue
    99 Z28 Camaro LS1

    Pull off your panel under steering wheel and to the right of column there will be a clip holding a small round silver canister. This is your turn signal flasher. Note- it is not all the column but to the right of it! The part is under $4. Cheap fix!

  9. #9
    Member bryceslu's Avatar
    Join Date
    Jul 2007
    Location
    Chicago, IL
    Posts
    467

    Black
    00 NHRA Formula

    Quote Originally Posted by danmeksch View Post
    Pull off your panel under steering wheel and to the right of column there will be a clip holding a small round silver canister. This is your turn signal flasher. Note- it is not all the column but to the right of it! The part is under $4. Cheap fix!
    Is this the flasher relay?

  10. #10
    Junior Member
    Join Date
    Jul 2008
    Location
    Twin Falls, Idaho
    Age
    40
    Posts
    42

    blue
    99 Z28 Camaro LS1

    yes

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question: turn signal keeps going out.
    By dav-02ws6-m6 in forum General Help
    Replies: 5
    Last Post: 02-02-2012, 03:19 AM
  2. Turn signal?
    By GrapeApeTA in forum General Help
    Replies: 15
    Last Post: 01-23-2011, 12:14 PM
  3. Question: turn signal
    By SSMOKEshow in forum Camaro / SS
    Replies: 18
    Last Post: 06-09-2009, 04:18 PM
  4. Turn Signal
    By Z28boy2000 in forum Stereo and Electronics
    Replies: 1
    Last Post: 03-30-2009, 12:36 PM
  5. Turn Signal PLEASE HELP
    By TA2FST4U in forum General Help
    Replies: 2
    Last Post: 06-01-2006, 08:35 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •