Page 1 of 2 12 LastLast
Results 1 to 20 of 38

Hatch release problem

This is a discussion on Hatch release problem within the Camaro / SS forums, part of the Vehicle Specific category; Hey guys, been having a problem with the hatch release on my 2000 ss. It hangs up all the time, ...

  1. #1
    Junior Member mdcrabbie's Avatar
    Join Date
    Jan 2009
    Location
    MD
    Posts
    71

    Silver
    2000 Camaro SS

    Hatch release problem

    Hey guys, been having a problem with the hatch release on my 2000 ss. It hangs up all the time, it pops but then hangs up and I have to press and hold the remote to release it. Someone told me I need to upgrade my spring on the relaese mechanism since the SS spoilers are heavier and this is a common problem. Anyone have a part # or where I can get the upgraded spring?

  2. #2
    Member
    Join Date
    Nov 2008
    Location
    Cheswick, PA
    Posts
    149

    Silver
    1998 Camaro Z28

    try spraying some pb/wd-40 or lithium grease on it?

  3. #3
    TJEA Retirement Home Dr.Crash's Avatar
    Join Date
    Feb 2006
    Location
    U. S And A Greatest country in all of world
    Posts
    3,383

    Stock
    2002 Camaro


  4. #4
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    You can piggyback another spring over the stock one - available at your local hardware store. Visit www.installuniversity.com and click on Rear Hatch Release Fix 2.

  5. #5
    Moderator Firebirdjones's Avatar
    Join Date
    May 2006
    Location
    Arizona
    Posts
    12,552
    Quote Originally Posted by mdcrabbie View Post
    Hey guys, been having a problem with the hatch release on my 2000 ss. It hangs up all the time, it pops but then hangs up and I have to press and hold the remote to release it. Someone told me I need to upgrade my spring on the relaese mechanism since the SS spoilers are heavier and this is a common problem. Anyone have a part # or where I can get the upgraded spring?
    I have the exact same issue with my wifes 2000 SS. I've tried WD-40 and that didn't work.
    I adjusted the latch a few times trying to find that happy spot and have been successfull in making it work a little better. Now it hangs up only once in a while.

  6. #6
    Moderator Firebirdjones's Avatar
    Join Date
    May 2006
    Location
    Arizona
    Posts
    12,552
    Quote Originally Posted by Dr.Crash View Post
    I will look into that but I think I may rather just tinker with the factory spring and try to make that work a little better rather than just sticking another spring onto it. Thanks for the ideas though.

  7. #7
    Impounded
    Join Date
    May 2008
    Location
    Verdigris, OK
    Posts
    2,165

    NBM
    99 z28

    Quote Originally Posted by mdcrabbie View Post
    Hey guys, been having a problem with the hatch release on my 2000 ss. It hangs up all the time, it pops but then hangs up and I have to press and hold the remote to release it. Someone told me I need to upgrade my spring on the relaese mechanism since the SS spoilers are heavier and this is a common problem. Anyone have a part # or where I can get the upgraded spring?
    I have the same problem on my Z. Atleast when I hit the release button thats to the left of the steering wheel. I never hassled with it so I always just use my key fob. When I use my key fob it opens every time.

  8. #8
    Moderator Firebirdjones's Avatar
    Join Date
    May 2006
    Location
    Arizona
    Posts
    12,552
    Quote Originally Posted by Danger731 View Post
    ^ wrong answer

  9. #9
    Millennium Falcon mpfranks's Avatar
    Join Date
    Sep 2007
    Location
    Akron, Oh
    Posts
    689

    Red
    2000 Trans Am WS.6

    im gonna try that, cuz mine hangs up a bit too

  10. #10
    Just me Y2KPewterSS's Avatar
    Join Date
    Nov 2006
    Location
    Broken Arrow, OK
    Age
    42
    Posts
    23,353

    Pewter metallic
    2000 Camaro SS

    Quote Originally Posted by 2001NBMZ28 View Post
    You can piggyback another spring over the stock one - available at your local hardware store. Visit www.installuniversity.com and click on Rear Hatch Release Fix 2.
    I did this to mine 3-4 years ago. Didn't solve it completely, but helped it a lot. It works correctly about 80% of the time now.
    CCW SP 500s 18x10 275/35 18x11 295/35
    SLP CME with GMMG style catback
    Painted manta stripe

    Quote Originally Posted by konigandy6 View Post
    I'd rather be bi than full homo!!!!

  11. #11
    Moderator Firebirdjones's Avatar
    Join Date
    May 2006
    Location
    Arizona
    Posts
    12,552
    I looked mine over and came up with what I think is a better solution for my taste. I just don't like the idea of a piggyback spring on there,,,kinda hillbilly.
    Tomorrow I can remove the arm, weld the hole for the spring and re-drill slightly higher for more spring tension. If that ends up not being enough I can straighten the arm slightly for a little more tension. Thats probably all I will need since a little time adjusting has already taken care of 90% of it.
    It only hangs 1 out of 10 tries.

  12. #12
    LSX whore allbaugh_04's Avatar
    Join Date
    Mar 2007
    Location
    Omaha, NE
    Age
    32
    Posts
    5,895

    Pewter
    2000 Z28 Camaro

    Quote Originally Posted by Y2KPewterSS View Post
    I did this to mine 3-4 years ago. Didn't solve it completely, but helped it a lot. It works correctly about 80% of the time now.
    Yep, me too

  13. #13
    Junior Member mdcrabbie's Avatar
    Join Date
    Jan 2009
    Location
    MD
    Posts
    71

    Silver
    2000 Camaro SS

    actually I understand the problem is in the stut supports (getting weak) not with the lock mechanism. Thats why the spring trick dosen't always work

  14. #14
    Senior Member SS02's Avatar
    Join Date
    Dec 2006
    Location
    ...
    Posts
    2,819

    None
    ...

    My struts are very solid!
    I have to work to pull my hatch down... it is the at the release, for
    me. When it pops it is up just like that!

    Maybe just my SS?
    It is a latch issue here!

  15. #15
    Junior Member
    Join Date
    Dec 2008
    Location
    johnson city
    Posts
    5

    red
    2002 chevy camaro ss slp

    On the problem with the trunk release or back hatch what ever you call it ,my car has 2900 miles on it ,this has happened from new ,so i stretched out the stock spring ,worked for a while back too the same old thing .

  16. #16
    Junior Member mdcrabbie's Avatar
    Join Date
    Jan 2009
    Location
    MD
    Posts
    71

    Silver
    2000 Camaro SS

    mine's a 2000 with only 5800 miles on it. I figured it's 9 yrs old and maybe the struts are weak. Have ordered new ones and will see how that helps. I will really be pissed if if still hangs up after spending 80+ on struts.

  17. #17
    Moderator Firebirdjones's Avatar
    Join Date
    May 2006
    Location
    Arizona
    Posts
    12,552
    Quote Originally Posted by mdcrabbie View Post
    mine's a 2000 with only 5800 miles on it. I figured it's 9 yrs old and maybe the struts are weak. Have ordered new ones and will see how that helps. I will really be pissed if if still hangs up after spending 80+ on struts.
    Wow they cost that much??

  18. #18
    Junior Member mdcrabbie's Avatar
    Join Date
    Jan 2009
    Location
    MD
    Posts
    71

    Silver
    2000 Camaro SS

    I got the oem Gm parts off the Gm parts direct site for about 41.00 each, half what the stealer would charge. Interesting they have different prices for each side. Whats up with that?

  19. #19
    Senior Member KyleLs1's Avatar
    Join Date
    Aug 2005
    Location
    Canada eh
    Posts
    3,534

    NBM
    99 TA

    mine did the same, even with new struts - piggy backing a spring works perfectly, if you try it and it doesn't work.... you are not using a small enough spring.

  20. #20
    Junior Member
    Join Date
    Jul 2009
    Location
    Reading, PA
    Posts
    58

    Bronze
    1984 Corvette

    I tried to adjust my latch down, so there was more tension on the seals (thus pop better), plus it never seemed to be down as far as it could be. And I got water in it once ... but doing that did not help.
    With the button, or the key fob, I get maybe a 1 in 10 chance that it will open.
    I am going to modify the spring to give it more tension .... if not I will go for new struts.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question: Hatch Release
    By justinmc978 in forum Firebird / WS6
    Replies: 6
    Last Post: 05-07-2010, 12:13 PM
  2. NEED help with trunk hatch problem
    By BAD WS6 in forum General Help
    Replies: 8
    Last Post: 08-17-2009, 07:30 PM
  3. Help: Tecnical service bulletin on hatch release ?
    By mdcrabbie in forum Camaro / SS
    Replies: 0
    Last Post: 02-25-2009, 06:33 PM
  4. Help: hatch release still won't work
    By mdcrabbie in forum Camaro / SS
    Replies: 14
    Last Post: 02-17-2009, 11:41 PM
  5. Rear Hatch Trunk Release Button
    By AFASTYZFR1 in forum Parts For Sale / Trade
    Replies: 3
    Last Post: 10-06-2008, 06:07 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •