Page 1 of 3 123 LastLast
Results 1 to 20 of 54

Do all LS1 engines have the piston knock ?

This is a discussion on Do all LS1 engines have the piston knock ? within the Camaro / SS forums, part of the Vehicle Specific category; Do all the LS1 engines have the piston slap at start up, that goes away ?...

  1. #1
    Ebaaaaaaaaa Speedy_Gonzales's Avatar
    Join Date
    Sep 2006
    Location
    Georgia
    Posts
    11,019

    Black
    2014 Camaro 1LS

    Do all LS1 engines have the piston knock ?

    Do all the LS1 engines have the piston slap at start up, that goes away ?
    Last edited by Speedy_Gonzales; 11-25-2006 at 07:38 PM.

  2. #2
    Member fast droptop's Avatar
    Join Date
    Jul 2005
    Location
    Charlotte, NC
    Age
    48
    Posts
    643

    sunset orange
    2001 SS VERT

    My 98 didnt but my 01 does at start up some of the time. Goes away in a matter of mins
    2001 SOM SS Vert 1 of 37 verts with a 6 speed. Kook LT's with cats, fast 90mm ported intake, Nick Williams 90mm TB, AFR 205's and so on. Tuning/installs done by Williams Performance.

  3. #3
    Ebaaaaaaaaa Speedy_Gonzales's Avatar
    Join Date
    Sep 2006
    Location
    Georgia
    Posts
    11,019

    Black
    2014 Camaro 1LS

    Quote Originally Posted by fast droptop View Post
    My 98 didnt but my 01 does at start up some of the time. Goes away in a matter of mins
    ya thats the way mine does. I was worried at first lol

  4. #4
    Just me Y2KPewterSS's Avatar
    Join Date
    Nov 2006
    Location
    Broken Arrow, OK
    Age
    42
    Posts
    23,353

    Pewter metallic
    2000 Camaro SS

    I have had a pair of 2000 LS1's now and been fortunate that neither of them had the piston slap.
    CCW SP 500s 18x10 275/35 18x11 295/35
    SLP CME with GMMG style catback
    Painted manta stripe

    Quote Originally Posted by konigandy6 View Post
    I'd rather be bi than full homo!!!!

  5. #5
    Ebaaaaaaaaa Speedy_Gonzales's Avatar
    Join Date
    Sep 2006
    Location
    Georgia
    Posts
    11,019

    Black
    2014 Camaro 1LS

    Quote Originally Posted by Y2KPewterSS View Post
    I have had a pair of 2000 LS1's now and been fortunate that neither of them had the piston slap.
    will it hurt anything ??

  6. #6
    Senior Member SeVeReDiStOrTiOn's Avatar
    Join Date
    Aug 2005
    Location
    Roseville, CA
    Posts
    8,164

    05 Wrangler
    00 Z28 sold :-(

    I have it...goes away way before reaching op temp

  7. #7
    car enthusiast djvaly's Avatar
    Join Date
    Nov 2005
    Location
    Philly area
    Posts
    9,863
    make sure ur on 91 or 93.. else it would knock..

  8. #8
    Member 98Z-28Camaro's Avatar
    Join Date
    Nov 2005
    Location
    Oklahoma City
    Age
    32
    Posts
    164

    black
    1998 Z-28 Camaro

    Mine doesn't as of right now. 77k
    Last edited by 98Z-28Camaro; 11-25-2006 at 08:09 AM. Reason: Added mileage
    Black 98 Z-28, whisper air lid, ported polished descreened maf, slp smooth bellow, modified tb, 04 gto plug wires, ngk TR6 plugs, Megan underdrive pulley, cold fusion nitrous kit, k&n, removed cats, glass pack , casper o2 simulators, 3.73 gears, Burnt up 4l-60e, drilled and slotted rotors,

  9. #9
    car enthusiast djvaly's Avatar
    Join Date
    Nov 2005
    Location
    Philly area
    Posts
    9,863
    Quote Originally Posted by KageSS View Post
    Higher octane doesn't have anything to do with it.
    engine knock he is talking about right?

  10. #10
    Ebaaaaaaaaa Speedy_Gonzales's Avatar
    Join Date
    Sep 2006
    Location
    Georgia
    Posts
    11,019

    Black
    2014 Camaro 1LS

    Quote Originally Posted by KageSS View Post
    He's talking about tapping noise that lifters make on start-ups when Eng. is cold. I think.

    I know he said pistons, but i think he meant to say lifters.
    ya lifters knock on cold start then go away

  11. #11
    Rollo Tomassee AKIRA's Avatar
    Join Date
    Aug 2005
    Location
    Outside the box
    Age
    37
    Posts
    2,887
    Quote Originally Posted by KageSS View Post
    He's talking about tapping noise that lifters make on start-ups when Eng. is cold. I think.

    I know he said pistons, but i think he meant to say lifters.
    He got it right. The term is called piston slap. However, it isnt cured by higher octane as you said earlier.

  12. #12
    Senior Member Tyler_LS1's Avatar
    Join Date
    Sep 2006
    Location
    Canby, Oregon
    Age
    29
    Posts
    2,121

    Pewter
    1999 Camaro SS-M6 #1775

    LS1 have Hydraulic lifters right? it may be that one is sticking just a bit.
    I know my Truck sticks a bit at a cold start.
    1999 Camaro SS/ Pewter/ #1775 - LS1 6-speed - Predator 3 Custom Tune - Pro 5.0 - LS7 Clutch - 3.90's - Koni's - Strano Springs and Sway Bars - SFC's - Full UMI Chassis and Suspension - LS6 Intake PnP TB - ARH LT's and Kitty Ran Away - Magnaflow.

    12.6 at 112

    http://www.fquick.com/Tyler_LS1

  13. #13
    car enthusiast djvaly's Avatar
    Join Date
    Nov 2005
    Location
    Philly area
    Posts
    9,863
    Quote Originally Posted by KageSS View Post
    Like i said before, it doesn't have anything to do with the octane rating.
    aha, yeah I see, I thought u are just having knock problem, piston slaping
    not sure mine does that,,, probably until the engine warms up, maybe it has to do with the starting temperature of the engine until it gets to warm level.
    like here in TX it doesn't dip below 40 usually. but in Colorado it dips to 15-20F so it may start piston slap at that low of temp. not sure. mine doesn't do it.

  14. #14
    car enthusiast djvaly's Avatar
    Join Date
    Nov 2005
    Location
    Philly area
    Posts
    9,863
    Quote Originally Posted by KageSS View Post
    I don't have that problem. You have me confused with someone else. And i'm from Texas also.......
    ayy. u are right,, TX pal, I'd like to piston slap that avatar of urz.
    I know ur from TX I was just making a point, other people like in Colorado etc may experience it more often,, I dunno

  15. #15
    Senior Member Tyler_LS1's Avatar
    Join Date
    Sep 2006
    Location
    Canby, Oregon
    Age
    29
    Posts
    2,121

    Pewter
    1999 Camaro SS-M6 #1775

    Quote Originally Posted by djvaly View Post
    ayy. u are right,, TX pal, I'd like to piston slap that avatar of urz.
    I know ur from TX I was just making a point, other people like in Colorado etc may experience it more often,, I dunno
    I think that HIS girl.
    LOL

  16. #16
    car enthusiast djvaly's Avatar
    Join Date
    Nov 2005
    Location
    Philly area
    Posts
    9,863
    Quote Originally Posted by Tyler_LS1 View Post
    I think that HIS girl.
    LOL
    oops, lol

  17. #17
    car enthusiast djvaly's Avatar
    Join Date
    Nov 2005
    Location
    Philly area
    Posts
    9,863
    hahahhaha.. more piston "power" to you!

  18. #18
    Junior Member
    Join Date
    Sep 2006
    Location
    Ontario Canada
    Age
    53
    Posts
    48

    Black
    2001 Camaro ss

    ...you may want to experiment by plumming a coolant heater or plug in your engine block...(if you have one)..and see if that makes a difference..these engines are mild racing engines right off the show room floor so it's possible the clearances are a little loose....allways let them warm up before driving them and there should be no issues.....and like others say it clears up...

  19. #19
    Junior Member COYOTE SS's Avatar
    Join Date
    Oct 2006
    Location
    Des Moines
    Posts
    26

    Red
    2002 SS

    I have it and it doesn't go away once the car warms up. It seems to have gotten worse since the day I bought it ( with 1,900 miles on it ). I put some Sea Foam ( I don't know if that is how it is spelled ) in it and got a Dyno-Tune, that help briefly. I'll try the Sea Foam again next Spring.

  20. #20
    Member A~NICE~CAR~IS~A~NICE~CAR's Avatar
    Join Date
    Sep 2006
    Location
    Albuquerque,New Mexico
    Age
    31
    Posts
    174

    Rally Red/race stripes
    2002 Super Sport

    same here, it stays till its warm, sounds like a sewing machine.....

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Piston Slap or Engine Knock Sensor Bad
    By ramontgo in forum Internal Engine
    Replies: 0
    Last Post: 04-23-2012, 05:51 PM
  2. knock knock...who's there? wait...engine knock...
    By jiveass in forum Internal Engine
    Replies: 60
    Last Post: 04-26-2011, 08:04 AM
  3. knock sensor code with new knock sensors?
    By zaaronz in forum General Help
    Replies: 13
    Last Post: 02-27-2011, 07:26 AM
  4. Anybody know any good knock knock jokes?
    By preston1980 in forum Almost Anything Goes
    Replies: 15
    Last Post: 07-22-2009, 02:35 PM
  5. Knock or Piston Slap ?
    By kool-aide in forum General Help
    Replies: 13
    Last Post: 11-21-2007, 03:17 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •