Page 1 of 2 12 LastLast
Results 1 to 20 of 39

Cruise control issues?

This is a discussion on Cruise control issues? within the Camaro / SS forums, part of the Vehicle Specific category; I have a '99 Z28 Conv. A4 that I love but it has this really anoying problem with the cruise ...

  1. #1
    Junior Member
    Join Date
    Dec 2005
    Location
    Palm Bay, Florida
    Age
    38
    Posts
    7

    Black
    '99 Z28 Conv

    Cruise control issues?

    I have a '99 Z28 Conv. A4 that I love but it has this really anoying problem with the cruise control.

    Whenever I set or resume the cruise control, there is this distinct lag before it picks up. Ie I set it at 75, take my foot off the gas, then it slows down to around 70, then accelerates back up to 75 where I set it originally.

    Ive tried to keep it at speed with the gas pedal, after I set it, hoping it is just a time lag but no dice, I have to take my foot off the gas and let it coast down about 5 MPH in order to get the cruise to actuate.

    It works fine after this and stays whatever speed I set it to, so I guess I could deal if I had to, but this lag period is driving me nucking futs!

    None of my mopars has ever had this problem, you hit cruise and it engages immediately, is this just a GM thing (GOD I hope not) or is my cruise malfuntioning?

  2. #2
    Now in Summit LT1 Flavor! Y2KArcticSS's Avatar
    Join Date
    Mar 2007
    Location
    Henryetta/Tulsa Oklahoma
    Posts
    3,483

    Summit White
    2016 Camaro SS

    My F-150 does that...but not my SS...maybe she has Fordibulosis?

    2016 Summit White 1SS - The DD
    2001 NBM Trans Am WS6 - Wifey's Grocery Getter
    2000 Arctic White SS #1667 - Sold

  3. #3
    Moderator Firebirdjones's Avatar
    Join Date
    May 2006
    Location
    Arizona
    Posts
    12,552
    Man even my old cable driven vacuum actuated cruise control works faster than that on my classic cars

    Seriously though, neither of my 4th gens react that slow either. There may be a 1-2 mph period before it reacts. Being a computer I would think there should be no lag at all.
    Could there be slop in the cable or something causing a slight delay???? I'm just thinking outloud here.

  4. #4
    515 HP TrickFlow Package BADASS2000SS's Avatar
    Join Date
    Feb 2008
    Location
    Palm Beach, FL
    Age
    40
    Posts
    1,702

    440 RWHP / 410 TQ
    2000 SLP CAMARO SS

    Quote Originally Posted by Y2KArcticSS View Post
    My F-150 does that...but not my SS...maybe she has Fordibulosis?
    Thats what you get for buying a Fucked Over Rebuilt Dodge!
    2000 SLP Camaro SS M6 * 515 HP TrickFlow Package * FAST 92 MM Intake * Nick Williams 92 MM TB * Volant CAI * Granatelli MAF * Full Custom True Dual Exhaust with X-Pipe * Tuned by Breathless Performance

  5. #5
    Your dealership guy konigandy6's Avatar
    Join Date
    Aug 2007
    Location
    Romeo, MI
    Posts
    6,557

    Velocity Yellow
    2008 Corvette Z06

    Quote Originally Posted by IanR View Post
    I have a '99 Z28 Conv. A4 that I love but it has this really anoying problem with the cruise control.

    Whenever I set or resume the cruise control, there is this distinct lag before it picks up. Ie I set it at 75, take my foot off the gas, then it slows down to around 70, then accelerates back up to 75 where I set it originally.

    Ive tried to keep it at speed with the gas pedal, after I set it, hoping it is just a time lag but no dice, I have to take my foot off the gas and let it coast down about 5 MPH in order to get the cruise to actuate.

    It works fine after this and stays whatever speed I set it to, so I guess I could deal if I had to, but this lag period is driving me nucking futs!

    None of my mopars has ever had this problem, you hit cruise and it engages immediately, is this just a GM thing (GOD I hope not) or is my cruise malfuntioning?
    Maybe a fluctuation between speedometer speed and wheel speed sensor speed? That would definitely F with the computer. Other than that, I dunno.

    Quote Originally Posted by BADASS2000SS View Post
    Thats what you get for buying a Fucked Over Rebuilt Dodge!
    ooooh... insubordinate much? Atleast it's American!

    2008 Z06 - Velocity Yellow - OEM

    2017 Silverado Z71 5.3 - OEM

    2002 Z06 - Electron Blue Metallic - D1 - E85 - 701 rwhp 687 rwtq **sold**

    2002 Z28: M6 NBM - cam and boltons - 396rwhp 357 rwtq **sold**

  6. #6
    515 HP TrickFlow Package BADASS2000SS's Avatar
    Join Date
    Feb 2008
    Location
    Palm Beach, FL
    Age
    40
    Posts
    1,702

    440 RWHP / 410 TQ
    2000 SLP CAMARO SS

    Quote Originally Posted by konigandy6 View Post
    Maybe a fluctuation between speedometer speed and wheel speed sensor speed? That would definitely F with the computer. Other than that, I dunno.



    ooooh... insubordinate much? Atleast it's American!
    I would rather drive a g-dam Hyundai than a FORD! And BTW....sorry Capt!
    Last edited by BADASS2000SS; 04-15-2009 at 12:55 PM.

  7. #7
    Moderator Firebirdjones's Avatar
    Join Date
    May 2006
    Location
    Arizona
    Posts
    12,552
    Quote Originally Posted by BADASS2000SS View Post
    I would rather drive a g-dam Hyundai than a FORD! And BTW....sorry Capt!
    Wow, I just didn't hear that did I???

    I'd drive anything american before I jump in some foreign crap.

  8. #8
    Now in Summit LT1 Flavor! Y2KArcticSS's Avatar
    Join Date
    Mar 2007
    Location
    Henryetta/Tulsa Oklahoma
    Posts
    3,483

    Summit White
    2016 Camaro SS

    Quote Originally Posted by BADASS2000SS View Post
    I would rather drive a g-dam Hyundai than a FORD! And BTW....sorry Capt!
    I've actually owned a Hyundai.... a 2007 Tiburon GS, it was a nice car (but GUTLESSSSSS), right up to the time it got flooded all the way up to the intake....the same day about 10 inches of water was standing in the first floor of my wife's job.....then we got the Ford.....and I wish I would have just driven the flooded Hyundai now

  9. #9
    TJEA Retirement Home Dr.Crash's Avatar
    Join Date
    Feb 2006
    Location
    U. S And A Greatest country in all of world
    Posts
    3,383

    Stock
    2002 Camaro

    Quote Originally Posted by Y2KArcticSS View Post
    I've actually owned a Hyundai.... a 2007 Tiburon GS, it was a nice car (but GUTLESSSSSS), right up to the time it got flooded all the way up to the intake....the same day about 10 inches of water was standing in the first floor of my wife's job.....then we got the Ford.....and I wish I would have just driven the flooded Hyundai now
    all that water a you didnt manage to hydro lock your engine? man you really do need my help

  10. #10
    2004 HEAD/CAM CTS-V 9t8z28's Avatar
    Join Date
    Oct 2006
    Location
    doylestown, Pa
    Posts
    6,818

    SILVER
    2004 CTS-V

    Yes, all F-bodys do this. To eliminate this issue, (for example) if you want to cruise at 75 you will need to get the car to 70 and hit the set button then hold the accelerate button until you are doing 75. I know it's more than you should have to do but it will eliminate this annoying process. If you for some reason must slow down and then you want the cruise to resume, you should hit the resume button while you are under the preset speed.

  11. #11
    515 HP TrickFlow Package BADASS2000SS's Avatar
    Join Date
    Feb 2008
    Location
    Palm Beach, FL
    Age
    40
    Posts
    1,702

    440 RWHP / 410 TQ
    2000 SLP CAMARO SS

    Quote Originally Posted by Firebirdjones View Post
    Wow, I just didn't hear that did I???

    I'd drive anything american before I jump in some foreign crap.
    Easy buddy...I was just messing around!

  12. #12
    Now in Summit LT1 Flavor! Y2KArcticSS's Avatar
    Join Date
    Mar 2007
    Location
    Henryetta/Tulsa Oklahoma
    Posts
    3,483

    Summit White
    2016 Camaro SS

    Quote Originally Posted by Dr.Crash View Post
    all that water a you didnt manage to hydro lock your engine? man you really do need my help
    Totaled and paid off, I have no idea what the damage was, but the adjuster said it wouldn't move, and the mechanic said basically everything electrical would need replaced... (I think he tried to start it, and shorted everything out, but that's just my opinion... ) It all worked out, thanks to having GAP insurance...it depreciated about 2k right off the lot, and I had the payoff for Starla's old Dodge truck behind it, so I was WAY upside down.... GAP even paid my insurance deductible

    What sucks though is it was the only brand new car I had ever bought....had 45 miles on it off the lot...had 6k on it when it flooded...

  13. #13
    Moderator Firebirdjones's Avatar
    Join Date
    May 2006
    Location
    Arizona
    Posts
    12,552
    Quote Originally Posted by BADASS2000SS View Post
    Easy buddy...I was just messing around!
    Nothing meant by it. I really like that little faint guy. I think it describes me to a "T" when I hear some of the stuff on this board

  14. #14
    TJEA Retirement Home Dr.Crash's Avatar
    Join Date
    Feb 2006
    Location
    U. S And A Greatest country in all of world
    Posts
    3,383

    Stock
    2002 Camaro

    Quote Originally Posted by Y2KArcticSS View Post
    Totaled and paid off, I have no idea what the damage was, but the adjuster said it wouldn't move, and the mechanic said basically everything electrical would need replaced... (I think he tried to start it, and shorted everything out, but that's just my opinion... ) It all worked out, thanks to having GAP insurance...it depreciated about 2k right off the lot, and I had the payoff for Starla's old Dodge truck behind it, so I was WAY upside down.... GAP even paid my insurance deductible

    What sucks though is it was the only brand new car I had ever bought....had 45 miles on it off the lot...had 6k on it when it flooded...
    Thats sucks, but atleast you had the gap insurance. good thing to since you were that deep into it. i always try and tell people that it is so worth it to get gap insurance.

  15. #15
    515 HP TrickFlow Package BADASS2000SS's Avatar
    Join Date
    Feb 2008
    Location
    Palm Beach, FL
    Age
    40
    Posts
    1,702

    440 RWHP / 410 TQ
    2000 SLP CAMARO SS

    Quote Originally Posted by Firebirdjones View Post
    Nothing meant by it. I really like that little faint guy. I think it describes me to a "T" when I hear some of the stuff on this board
    Alright, I didnt want to have to meet you at the bike rack after school Firebirdjones! Were cool!

  16. #16
    TJEA Retirement Home Dr.Crash's Avatar
    Join Date
    Feb 2006
    Location
    U. S And A Greatest country in all of world
    Posts
    3,383

    Stock
    2002 Camaro

    Quote Originally Posted by BADASS2000SS View Post
    Alright, I didnt want to have to meet you at the bike rack after school Firebirdjones! Were cool!


    awe man and i had everyone ready to meet during recess to watch you to go at it. damn!

  17. #17
    Moderator Firebirdjones's Avatar
    Join Date
    May 2006
    Location
    Arizona
    Posts
    12,552
    Quote Originally Posted by BADASS2000SS View Post
    Alright, I didnt want to have to meet you at the bike rack after school Firebirdjones! Were cool!
    You don't want any of that.

    But hey, in my defense, you didn't have any smiley face indicating that was a joke,,,,scooter

  18. #18
    515 HP TrickFlow Package BADASS2000SS's Avatar
    Join Date
    Feb 2008
    Location
    Palm Beach, FL
    Age
    40
    Posts
    1,702

    440 RWHP / 410 TQ
    2000 SLP CAMARO SS

    Quote Originally Posted by Firebirdjones View Post
    You don't want any of that.

    But hey, in my defense, you didn't have any smiley face indicating that was a joke,,,,scooter
    Ahhh, for the record, my nickname is "skeeter" and I dont use Smiles in my posts....ever! But you can pretty much garuntee that everything I post is joking or in fun! I am only serious about an hour a day, if that!
    Last edited by BADASS2000SS; 04-17-2009 at 03:31 AM.

  19. #19
    515 HP TrickFlow Package BADASS2000SS's Avatar
    Join Date
    Feb 2008
    Location
    Palm Beach, FL
    Age
    40
    Posts
    1,702

    440 RWHP / 410 TQ
    2000 SLP CAMARO SS

    Quote Originally Posted by Dr.Crash View Post
    awe man and i had everyone ready to meet during recess to watch you to go at it. damn!
    Shut it Crash or you will be next.....This time, behind the gym after football practice! (Note for firebirdjones....no smilies but just joking around!)

  20. #20
    TJEA Retirement Home Dr.Crash's Avatar
    Join Date
    Feb 2006
    Location
    U. S And A Greatest country in all of world
    Posts
    3,383

    Stock
    2002 Camaro

    Quote Originally Posted by BADASS2000SS View Post
    Shut it Crash or you will be next.....This time, behind the gym after football practice! (Note for firebirdjones....no smilies but just joking around!)
    hey hey thems fightin words!

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. No Cruise Control
    By oharam in forum General Help
    Replies: 8
    Last Post: 03-01-2011, 09:53 PM
  2. Cruise Control?
    By FutureWS6 in forum Firebird / WS6
    Replies: 17
    Last Post: 01-13-2011, 09:55 AM
  3. cruise control with traction control
    By basballny2 in forum General Help
    Replies: 12
    Last Post: 06-17-2010, 12:57 AM
  4. Traction control issues
    By PGH_WS6 in forum General Help
    Replies: 1
    Last Post: 08-25-2008, 10:21 AM
  5. Cruise Control Issues??
    By Wesman in forum General Help
    Replies: 5
    Last Post: 03-18-2007, 05:21 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •