Page 2 of 2 FirstFirst 12
Results 21 to 24 of 24

Complete Power Loss!

This is a discussion on Complete Power Loss! within the Camaro / SS forums, part of the Vehicle Specific category; try swapping the coil packs for some stockers as well....

  1. #21
    CAMARO not Maro asshead! HASTINGSRJ's Avatar
    Join Date
    Jan 2001
    Location
    MASSHOLE in Jville NC
    Age
    44
    Posts
    2,012

    Black/Gray
    00 SS Vert#0540/ 03 GMC

    try swapping the coil packs for some stockers as well.

    http://www.gmhightechperformance.com...aro/index.html
    Black 00 SS M6, vert, #0540 414 C.I. iron block 501hp 448tq -slipping clutch
    old times 11.39@123 tuned by RPM
    11.49run


    DD 03 GMC Sierra, Durmax CCSB 2500, 17" XD's, 5" tubo back exhaust, AFE intake, EFI Live, DSP5, 3" body lift, tuned by Diesel Addiction 347hp 645tq

    rwhp.us

  2. #22
    Member camaroluvr447's Avatar
    Join Date
    Sep 2009
    Location
    Steubenville, Ohio
    Age
    27
    Posts
    234

    Pewter
    2000 Pewter Z28 M6

    update

    hey guys the fuel pressure was low and i changed the filter, that seems to have solved it for now. There is still a very slight blip at 2500 rpm but I can live that (for now). Thanks for the help!

  3. #23
    Senior Member Too Fast's Avatar
    Join Date
    Nov 2006
    Location
    Indianapolis
    Age
    54
    Posts
    5,170

    Black
    2000 WS6 6spd Hooker LT

    Well, don't kill the messenger, but usually a dirty fuel filter will cause a lot of strain on the fuel pump, making it die rather quickly.

  4. #24
    CAMARO not Maro asshead! HASTINGSRJ's Avatar
    Join Date
    Jan 2001
    Location
    MASSHOLE in Jville NC
    Age
    44
    Posts
    2,012

    Black/Gray
    00 SS Vert#0540/ 03 GMC

    Glad you figured out what the problem was. I still wouldnt trust those MSD coil packs though.

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: Power loss
    By davidz28 in forum Camaro / SS
    Replies: 3
    Last Post: 09-11-2010, 09:00 AM
  2. Loss of power
    By 99RTA in forum General Help
    Replies: 0
    Last Post: 05-19-2009, 06:52 AM
  3. power loss??
    By junior19 in forum Drivetrain
    Replies: 0
    Last Post: 11-27-2007, 09:12 AM
  4. is this why i have power loss???
    By 02sscamaro in forum General Help
    Replies: 1
    Last Post: 09-13-2007, 02:15 PM
  5. Power loss
    By Even10Flow in forum Convertible
    Replies: 5
    Last Post: 05-16-2007, 08:26 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •