Page 1 of 2 12 LastLast
Results 1 to 20 of 24

Complete Power Loss!

This is a discussion on Complete Power Loss! within the Camaro / SS forums, part of the Vehicle Specific category; For several years now my car has had a slight blip around 2500 RPM, just a split second power loss. ...

  1. #1
    Member camaroluvr447's Avatar
    Join Date
    Sep 2009
    Location
    Steubenville, Ohio
    Age
    27
    Posts
    234

    Pewter
    2000 Pewter Z28 M6

    Complete Power Loss!

    For several years now my car has had a slight blip around 2500 RPM, just a split second power loss. Almost unnoticable and nothing I was too concerned about. Over the course of last week however it has gotten drastically worse and is rapidly becoming un-drivable. In any gear, but most commonly third, it will randomly lose 95% of its power through all rpm ranges. When in first gear and it happens I cannot top 10 mph. My first thought was a bad coil pack or something interfering with the spark, however there is no chugging or misfire like sounds, just a instant and very smooth power loss. I have not been able to correlate this with wet or dry weather, or any other environmental factors. It is happening for increasingly long periods of time. Usually I can get it to go away by quickly working the pedal until the engine just comes back to life. I have msd coil packs, plugs and wires, engine appears to be healthy with routine maintainence. I am stumped, any ideas?
    2000 Z28 Pewter, M6, T-Tops, K&N Intake, LS6 Manifold, SS Hood, MSD Ignition, Magnaflow Cat-Back, Stage 3 Clutch, Short Shifter.

  2. #2
    CAMARO not Maro asshead! HASTINGSRJ's Avatar
    Join Date
    Jan 2001
    Location
    MASSHOLE in Jville NC
    Age
    44
    Posts
    2,012

    Black/Gray
    00 SS Vert#0540/ 03 GMC

    clean the Maf, new plugs, wires, O2's

    http://www.gmhightechperformance.com...aro/index.html
    Black 00 SS M6, vert, #0540 414 C.I. iron block 501hp 448tq -slipping clutch
    old times 11.39@123 tuned by RPM
    11.49run


    DD 03 GMC Sierra, Durmax CCSB 2500, 17" XD's, 5" tubo back exhaust, AFE intake, EFI Live, DSP5, 3" body lift, tuned by Diesel Addiction 347hp 645tq

    rwhp.us

  3. #3
    Senior Member Too Fast's Avatar
    Join Date
    Nov 2006
    Location
    Indianapolis
    Age
    54
    Posts
    5,170

    Black
    2000 WS6 6spd Hooker LT

    Check your fuel pressure. Sounds like the pump is dying. It may be a dirty MAF, but usually this is a constant thing, not off and on. SES light on?

  4. #4
    CAMARO not Maro asshead! HASTINGSRJ's Avatar
    Join Date
    Jan 2001
    Location
    MASSHOLE in Jville NC
    Age
    44
    Posts
    2,012

    Black/Gray
    00 SS Vert#0540/ 03 GMC

    another question, when you say MSD ignition in your sig, are you talking about MSD coil packs?

  5. #5
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Quote Originally Posted by camaroluvr447 View Post
    For several years now my car has had a slight blip around 2500 RPM, just a split second power loss. Almost unnoticable and nothing I was too concerned about. Over the course of last week however it has gotten drastically worse and is rapidly becoming un-drivable. In any gear, but most commonly third, it will randomly lose 95% of its power through all rpm ranges. When in first gear and it happens I cannot top 10 mph. My first thought was a bad coil pack or something interfering with the spark, however there is no chugging or misfire like sounds, just a instant and very smooth power loss. I have not been able to correlate this with wet or dry weather, or any other environmental factors. It is happening for increasingly long periods of time. Usually I can get it to go away by quickly working the pedal until the engine just comes back to life. I have msd coil packs, plugs and wires, engine appears to be healthy with routine maintainence. I am stumped, any ideas?
    Quote Originally Posted by HASTINGSRJ View Post
    another question, when you say MSD ignition in your sig, are you talking about MSD coil packs?
    yup

    OP, still running factory cats?

  6. #6
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Quote Originally Posted by Too Fast View Post
    Check your fuel pressure. Sounds like the pump is dying. It may be a dirty MAF, but usually this is a constant thing, not off and on. SES light on?
    ....and this...

  7. #7
    Member camaroluvr447's Avatar
    Join Date
    Sep 2009
    Location
    Steubenville, Ohio
    Age
    27
    Posts
    234

    Pewter
    2000 Pewter Z28 M6

    msd coil packs, plugs and wires. they are not that old either, maybe 20,000 miles. And yes stock cats. Why would stock cats matter?

  8. #8
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Quote Originally Posted by camaroluvr447 View Post
    msd coil packs, plugs and wires. they are not that old either, maybe 20,000 miles. And yes stock cats. Why would stock cats matter?
    lol clogged cat/s will definetly cause power loss..

  9. #9
    Your dealership guy konigandy6's Avatar
    Join Date
    Aug 2007
    Location
    Romeo, MI
    Posts
    6,557

    Velocity Yellow
    2008 Corvette Z06

    Quote Originally Posted by Smittro View Post
    lol clogged cat/s will definetly cause power loss..
    +1

    SES light will tell you. Is it on? Does it come on and flash while the problem is happening?

  10. #10
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Thumbs up

    Quote Originally Posted by konigandy6 View Post
    +1

    SES light will tell you. Is it on? Does it come on and flash while the problem is happening?
    Tho mine was a 3800, when my cat was dieing it did'nt code right away.

    But it would'nt even climb a small grade either.. Later on I got the efficiency code..

  11. #11
    Member camaroluvr447's Avatar
    Join Date
    Sep 2009
    Location
    Steubenville, Ohio
    Age
    27
    Posts
    234

    Pewter
    2000 Pewter Z28 M6

    ses light is always on because I installed a manual override switch for the cooling fan and left out the resistor. I am going to advance today to check the codes. Also buying a fuel filter, and I will rent a fuel pressure gauge and I will clean the MAF. Do you guys really think the cats could be bad at 105,000?

  12. #12
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Quote Originally Posted by camaroluvr447 View Post
    ses light is always on because I installed a manual override switch for the cooling fan and left out the resistor. I am going to advance today to check the codes. Also buying a fuel filter, and I will rent a fuel pressure gauge and I will clean the MAF. Do you guys really think the cats could be bad at 105,000?
    Mine died @ 80k and there are some here in the LS1's that had issue around the same mileage when thiers died..

    However untill you get it scanned it all guess work really.

  13. #13
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Oh yeah and when my fuel pump died the car simply stopped but would idle some after sitting then die..

  14. #14
    Your dealership guy konigandy6's Avatar
    Join Date
    Aug 2007
    Location
    Romeo, MI
    Posts
    6,557

    Velocity Yellow
    2008 Corvette Z06

    Quote Originally Posted by camaroluvr447 View Post
    ses light is always on because I installed a manual override switch for the cooling fan and left out the resistor. I am going to advance today to check the codes. Also buying a fuel filter, and I will rent a fuel pressure gauge and I will clean the MAF. Do you guys really think the cats could be bad at 105,000?
    Absolutely could be bad... That is why GM extended the warranty for the converters to 10 years/120k.

    I'm surprised they haven't plugged yet.

  15. #15
    Member camaroluvr447's Avatar
    Join Date
    Sep 2009
    Location
    Steubenville, Ohio
    Age
    27
    Posts
    234

    Pewter
    2000 Pewter Z28 M6

    well if it is the cats then I guess I am forced to go get an off road y and pacesetters. What a misfortune! lol!

  16. #16
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Thumbs up

    Quote Originally Posted by camaroluvr447 View Post
    well if it is the cats then I guess I am forced to go get an off road y and pacesetters. What a misfortune! lol!

  17. #17
    Your dealership guy konigandy6's Avatar
    Join Date
    Aug 2007
    Location
    Romeo, MI
    Posts
    6,557

    Velocity Yellow
    2008 Corvette Z06

    Quote Originally Posted by camaroluvr447 View Post
    well if it is the cats then I guess I am forced to go get an off road y and pacesetters. What a misfortune! lol!
    OH NOES!!!!! Not more power!!!!!



    Do it!!!!

  18. #18
    CAMARO not Maro asshead! HASTINGSRJ's Avatar
    Join Date
    Jan 2001
    Location
    MASSHOLE in Jville NC
    Age
    44
    Posts
    2,012

    Black/Gray
    00 SS Vert#0540/ 03 GMC

    did this problem start after the MSD coil packs were put on the car? I have heard nothing but bad things about those things. My buddy had a problem with his car misfireing with those coil packs

  19. #19
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Quote Originally Posted by HASTINGSRJ View Post
    did this problem start after the MSD coil packs were put on the car? I have heard nothing but bad things about those things. My buddy had a problem with his car misfireing with those coil packs
    Same here. The factory units are fine in most cases and the gains from after market coils are not anything to write home about..imho

  20. #20
    Member camaroluvr447's Avatar
    Join Date
    Sep 2009
    Location
    Steubenville, Ohio
    Age
    27
    Posts
    234

    Pewter
    2000 Pewter Z28 M6

    The msd coils were on the car when I bought it unfortunatly. I replaced the Air Temp Sensor as the car was throwing code p0113 (Air temp circuit input too high) and a fuel pump. Havnt driven it yet, I will post up the results!

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: Power loss
    By davidz28 in forum Camaro / SS
    Replies: 3
    Last Post: 09-11-2010, 09:00 AM
  2. Loss of power
    By 99RTA in forum General Help
    Replies: 0
    Last Post: 05-19-2009, 06:52 AM
  3. power loss??
    By junior19 in forum Drivetrain
    Replies: 0
    Last Post: 11-27-2007, 09:12 AM
  4. is this why i have power loss???
    By 02sscamaro in forum General Help
    Replies: 1
    Last Post: 09-13-2007, 02:15 PM
  5. Power loss
    By Even10Flow in forum Convertible
    Replies: 5
    Last Post: 05-16-2007, 08:26 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •