Results 1 to 3 of 3

Bottomed out, Dash lights not working??

This is a discussion on Bottomed out, Dash lights not working?? within the Camaro / SS forums, part of the Vehicle Specific category; So last night i was on the highway following some friends somewhere, and we come up on some railroad tracks. ...

  1. #1
    Member
    Join Date
    Oct 2006
    Location
    Springfield
    Age
    30
    Posts
    330

    Silver
    2004 SVT Cobra

    Bottomed out, Dash lights not working??

    So last night i was on the highway following some friends somewhere, and we come up on some railroad tracks. Well the speed limit was 55, and i was doing about 50. I didnt realize though that there was a huge dropoff on the other side of the tracks, Too bad there wasnt the usual warning sign there. Anyways my car bottomed out extremely hard, the guys behind me said they saw sparks flying out everywhere. Suprisingly though the only thing that doesnt work is my interior dash lights. I found out it was a blown fuse, dont know how that happened, but everytime i replace it the new one instantly blows out. i guess a wire shorted out somewhere maybe? Any advice on where to start looking or what else it could be??

  2. #2
    I lika da Chevy's LETHALxLS1's Avatar
    Join Date
    Oct 2006
    Location
    USA
    Posts
    5,328

    BLACK
    Z/28 LS1

    I advise you to inspect underneath your car-but that sucks about the dash lights. That may be a bitch to figure out.

  3. #3
    Member camaross19973's Avatar
    Join Date
    Mar 2007
    Location
    Los Angeles
    Age
    44
    Posts
    238

    blue
    1999 camaro ss #976

    that happen to me to but i didnt bottom out my lights in the dash wont work tommrow am talkking it to an electricion

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help! Dash lights off & when headlights on radio lights off
    By BlackWS6TA in forum Firebird / WS6
    Replies: 2
    Last Post: 07-20-2012, 11:39 AM
  2. Replies: 0
    Last Post: 09-07-2010, 05:25 AM
  3. temp gauge isnt working and dash cluster question
    By laserredgt in forum General Help
    Replies: 4
    Last Post: 07-06-2010, 07:09 PM
  4. No running lights, dash lights
    By 77k5 in forum General Help
    Replies: 10
    Last Post: 01-07-2010, 12:35 PM
  5. Dash lights and others not working
    By Red Chevy in forum Stereo and Electronics
    Replies: 3
    Last Post: 10-19-2006, 12:08 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •