Results 1 to 3 of 3

boggging out

This is a discussion on boggging out within the Camaro / SS forums, part of the Vehicle Specific category; alright so i just got back from deployment car ws running good..then the other day i was headin to the ...

  1. #1
    Junior Member playboy's Avatar
    Join Date
    Apr 2009
    Location
    evergreen Park IL
    Posts
    58

    black
    1998 Camaro Z28

    boggging out

    alright so i just got back from deployment car ws running good..then the other day i was headin to the office and it started to choke and sounded like it just stopped gettin gas..started right back up then did the same thing again. when i went to restart it the batter was completely dead.. not even the check engine light would come on...any ideas
    its a 98 z28

  2. #2
    None Shall Pass Knight's Avatar
    Join Date
    Jan 2010
    Location
    East of Cleveland, Ohio
    Posts
    3,828

    Black
    99 WS.6 - Modified

    Few things I'd start checking - check the battery terminals for corrosion and good connections, same for the main grounds, check fuel pressure at the rail for around 58 psi, try cleaning the MAF, ect. Check the easy stuff first, and that'll usually help narrow things down.

  3. #3
    Your dealership guy konigandy6's Avatar
    Join Date
    Aug 2007
    Location
    Romeo, MI
    Posts
    6,557

    Velocity Yellow
    2008 Corvette Z06

    Most likely a battery issue. Low voltage problems to weird things to vehicles.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •