Results 1 to 7 of 7

Black Betty is back !!!!!!!!!!!

This is a discussion on Black Betty is back !!!!!!!!!!! within the Camaro / SS forums, part of the Vehicle Specific category; Finally got my car back today. After 3 shops, working on it myself and $800 later it is fixed. Thank ...

  1. #1
    Ebaaaaaaaaa Speedy_Gonzales's Avatar
    Join Date
    Sep 2006
    Location
    Georgia
    Posts
    11,019

    Black
    2014 Camaro 1LS

    Black Betty is back !!!!!!!!!!!

    Finally got my car back today. After 3 shops, working on it myself and $800 later it is fixed. Thank goodness I found a good mechanic ! It was two bad wires that go to the tranny that was the problem. The tranny had to be removed in order to get to the wires. Man it feels great to have my LS1 back. I been miserable the past month. Soon as I got it home gave it a good bath. I will be out looking for a race tomorrow

  2. #2
    GM made me do it!! IT_SS's Avatar
    Join Date
    Sep 2007
    Location
    Los Angeles
    Age
    29
    Posts
    290

    Black
    2002 A4 Z/28

    congrats!

  3. #3
    Member NSSTG8TR98's Avatar
    Join Date
    Dec 2007
    Location
    Mesa, AZ
    Posts
    500

    Black Vert
    1998 Camaro SS M6 #1160

    How's she running?

  4. #4
    Just me Y2KPewterSS's Avatar
    Join Date
    Nov 2006
    Location
    Broken Arrow, OK
    Age
    42
    Posts
    23,353

    Pewter metallic
    2000 Camaro SS

    CCW SP 500s 18x10 275/35 18x11 295/35
    SLP CME with GMMG style catback
    Painted manta stripe

    Quote Originally Posted by konigandy6 View Post
    I'd rather be bi than full homo!!!!

  5. #5
    Member Joe00SS's Avatar
    Join Date
    Oct 2005
    Location
    CT
    Age
    46
    Posts
    465

    White Liquid Silver
    2000 Camaro SS/ 02 YZF-R1

    Nice job troubleshooting, I bet it feels good to find the problem yourself and get it back up and running!

  6. #6
    Ebaaaaaaaaa Speedy_Gonzales's Avatar
    Join Date
    Sep 2006
    Location
    Georgia
    Posts
    11,019

    Black
    2014 Camaro 1LS

    Quote Originally Posted by Joe00SS View Post
    Nice job troubleshooting, I bet it feels good to find the problem yourself and get it back up and running!
    well I didnt find it myself, the tranny had to be pulled to fix the problem

  7. #7
    Ebaaaaaaaaa Speedy_Gonzales's Avatar
    Join Date
    Sep 2006
    Location
    Georgia
    Posts
    11,019

    Black
    2014 Camaro 1LS

    Quote Originally Posted by NSSTG8TR98 View Post
    How's she running?
    runs good but I gotta clean the MAF

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. new pics of Black Betty
    By Speedy_Gonzales in forum Member's Rides
    Replies: 22
    Last Post: 06-09-2008, 03:29 AM
  2. Black Betty is back !!!!!!!!
    By Speedy_Gonzales in forum Almost Anything Goes
    Replies: 6
    Last Post: 03-20-2008, 10:21 PM
  3. Black Betty might just be back and running !
    By Speedy_Gonzales in forum Almost Anything Goes
    Replies: 3
    Last Post: 02-25-2008, 04:40 PM
  4. Black Betty Is Back !!!
    By Speedy_Gonzales in forum Almost Anything Goes
    Replies: 1
    Last Post: 04-10-2007, 12:56 AM
  5. Black Betty Is Back !!!
    By Speedy_Gonzales in forum Camaro / SS
    Replies: 8
    Last Post: 04-09-2007, 06:23 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •