Results 1 to 10 of 10

after changing fuel filter, something happened

This is a discussion on after changing fuel filter, something happened within the Camaro / SS forums, part of the Vehicle Specific category; so i drove it down the street and i made a u turn and something snapped, popped and when i ...

  1. #1
    Member L...S...1's Avatar
    Join Date
    Jul 2009
    Location
    NOR*CAL
    Posts
    118

    Red
    2000 SS

    after changing fuel filter, something happened

    so i drove it down the street and i made a u turn and something snapped, popped and when i accelerate its like a scrapping noise right under the middle of the car. i checked the fuel filter and it was still on and everything. i dont know what it is but it only makes the noice when i touch the gas pedal......any help?!?!

  2. #2
    Senior Member bigrondownhiller's Avatar
    Join Date
    Feb 2006
    Location
    Orange County, NY
    Age
    42
    Posts
    2,674

    Black
    1996 Camaro Z28 vert

    Check the trans mount and u-joints.

  3. #3
    Member L...S...1's Avatar
    Join Date
    Jul 2009
    Location
    NOR*CAL
    Posts
    118

    Red
    2000 SS

    ok thanks, and it kinda seems like the whole back of the car is sitting a little lower than it was before

  4. #4
    Member L...S...1's Avatar
    Join Date
    Jul 2009
    Location
    NOR*CAL
    Posts
    118

    Red
    2000 SS

    any idea how much u joints are???? i called my mechanic and he said it sounds like the u-joints.

  5. #5
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Location
    Bragg NC
    Posts
    2,835

    Met. Sunset Orange
    01 SS

    Jack up the rear of the car, Put a block under the front tire to prevent it from rolling, put the tranny in neutral and turn the driveshaft and see if you can pinpoint the u joint.
    When you changed the fuel filter where did you jack it up at?
    U joints vary in price but are under 20 bucks, its the labor that will get ya.
    J
    2001 SS, Its not the car its the Driver that matters....

  6. #6
    Member L...S...1's Avatar
    Join Date
    Jul 2009
    Location
    NOR*CAL
    Posts
    118

    Red
    2000 SS

    i jacked it up by the rear tire on the drivers side for easy access. and everyhting was good till i made the u turn

  7. #7
    Member
    Join Date
    Oct 2009
    Location
    NorCal
    Posts
    260
    02 Z28

    wassup bro! sorry to hear about the maro, but as one of the guys said on top of me, i'd deff check out the u joint, tranny mount, driveshaft.

  8. #8
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    10,461

    Black
    1999 TA WS.6

    Before You go throwing money the problem, get it back up in the air. Like said, turn the driveshaft. I have had my car completely up in the air on four Jack stands and ran the are looking for problems. Do this before you buy any parts because at this point you have no idea what the problem may be.
    370 CI - Twin 6766 Turbo - Jakes stage 5 4L80E - MWC 9" - Holley Dominator

    Build in progress...

  9. #9
    Senior Member Orcus79's Avatar
    Join Date
    Feb 2006
    Location
    Canada
    Age
    38
    Posts
    1,346

    black
    2002 WS6

    U-joints won't make a scraping noise, more of a hollow thunk pink noise. A snap and scraping noise sounds like something mount related. Could be tranny mount or torque arm. Either way it needs to get back up in the air and be thoroughly checked. get it secured and give everything a once over and wiggle.

  10. #10
    11's "CLUB" SS SLP2's Avatar
    Join Date
    Aug 2005
    Location
    Silsbee, Tx
    Posts
    146

    Black
    Y2K Camero SS

    rear spring may have moved on its mount when car was jacked up, I would check springs and HPB
    just my .02's Johnny
    Y2K SS (SLP #239)
    Completly STOCK heads/bore/stroke/weight
    & NOTHING else ---is stock
    "NAW-NAW- just a Sunday goto meeting car, my best time is not in the 12's------- any more "
    ps: I am not soliticing work as I am retired
    >>>info on alignments
    http://www.jgruggles.com

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question: Changing fuel filter
    By SS Camaro UK in forum General Help
    Replies: 21
    Last Post: 10-24-2012, 06:36 PM
  2. Changing my Fuel Rail setup
    By ls1camino in forum General Help
    Replies: 2
    Last Post: 09-29-2011, 05:23 PM
  3. kinked fuel line while changing fuel filter
    By krese in forum Firebird / WS6
    Replies: 4
    Last Post: 10-04-2010, 04:02 PM
  4. Question: Does a new fuel pump mean a new fuel filter too?
    By RaceMyLS1 in forum General Help
    Replies: 3
    Last Post: 02-17-2009, 12:11 AM
  5. fuel filter or fuel pump?
    By formulaon18s in forum General Help
    Replies: 6
    Last Post: 11-20-2007, 05:14 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •