Results 1 to 3 of 3

After 95xxx miles - my water pump went out :( ...

This is a discussion on After 95xxx miles - my water pump went out :( ... within the Camaro / SS forums, part of the Vehicle Specific category; i've already bought a new one and installed it my question is .. do i have to replace anything else ...

  1. #1
    Member Sayed_000's Avatar
    Join Date
    Oct 2008
    Location
    Middle East - Bahrain
    Posts
    257

    Pewter
    Camaro 2000 SS M6

    Unhappy After 95xxx miles - my water pump went out :( ...

    i've already bought a new one and installed it

    my question is .. do i have to replace anything else to keep my car/engine healthy ?
    i mean regularly replacements ?!


    sorry i posted in the wrong section .. move the post to it place ..thnks

  2. #2
    Exalted Cyclops 67CamaroRSSS's Avatar
    Join Date
    Feb 2007
    Location
    San Diego, CA
    Posts
    5,824

    2002 Z28 A4 NBM
    Sadly now demodded :(

    You're lucky. The water pump on my 02 started seeping at 40,xxxx. My old 96 LT1 started at 30,xxx (covered under warranty - they replaced the opti then also).

  3. #3
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Location
    Bragg NC
    Posts
    2,835

    Met. Sunset Orange
    01 SS

    Just normal maint. Listen to those little squeaks and rattles and fix them as soon as they start.
    change the normal stuff on intervals, ie fuel filter, oil, oil filter, air filter, tranny filter and fluid if auto. Have your coolant flushed, change diff oil, inspect everything else...
    J
    2001 SS, Its not the car its the Driver that matters....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Water pump help
    By jetaws6 in forum External Engine
    Replies: 4
    Last Post: 08-01-2010, 02:50 PM
  2. water pump
    By Pete Rock98 in forum General Help
    Replies: 25
    Last Post: 05-17-2009, 02:46 PM
  3. Water pump going out 3.8
    By Spikito in forum External Engine
    Replies: 5
    Last Post: 03-24-2009, 08:48 AM
  4. Do electric water pumps pump enough water for daily use?
    By xinthenight in forum External Engine
    Replies: 6
    Last Post: 08-02-2007, 10:04 PM
  5. Water pump going bad??
    By 00\/\/S6 in forum External Engine
    Replies: 9
    Last Post: 03-08-2006, 12:15 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •