Results 1 to 6 of 6

AC problems

This is a discussion on AC problems within the Camaro / SS forums, part of the Vehicle Specific category; i have a 1998 Z28 M6 and the ac barely gets cold!. its fukkin hot out here these days. It ...

  1. #1
    Junior Member stevo5662's Avatar
    Join Date
    Feb 2006
    Location
    california
    Posts
    83

    Red
    1998 Z28 6-speed

    AC problems

    i have a 1998 Z28 M6 and the ac barely gets cold!. its fukkin hot out here these days. It gets a little cool but not really cold like it should get and i already had the system checked for leaks and there is none and i also recharged the freeon. anyone have an idea what might be wrong with it? I WANT TO BE dammit

  2. #2
    Senior Member ss~zoso~ss's Avatar
    Join Date
    Dec 2004
    Location
    )
    Posts
    9,128

    SS: NBM, tan top
    1998-SS, 2010 Jetta TDI

    just go to the local oil change place and have them recharge it, dont try to do it yourself, my friend did and blew the compressor (900$$) fix

  3. #3
    Junior Member stevo5662's Avatar
    Join Date
    Feb 2006
    Location
    california
    Posts
    83

    Red
    1998 Z28 6-speed

    No im not worried about that. my dad is an ASE certified master tech and we have our own machine for recharging freeon. that and i work in a lube shop so i have access to pretty much anything i need.

  4. #4
    Senior Member ss~zoso~ss's Avatar
    Join Date
    Dec 2004
    Location
    )
    Posts
    9,128

    SS: NBM, tan top
    1998-SS, 2010 Jetta TDI

    do you hear the A/C activating? your compressor could be shot? idk thats a stumper
    98' SS Convertible Camaro-76k-Build # 1471, Cragar SS rims, RK SFC's, MAC Panhard, LSX Tune, Shaner S3,
    SLP:short thro,Strut tower brace,fan switch
    MTI Power induction kit,40 Series muffler,Pacesetter LT's + ORY,12 CD changer,3800lbs
    http://www.cardomain.com/ride/787506/1

  5. #5
    the cake is a lie twozs's Avatar
    Join Date
    Sep 2005
    Location
    hopewell jct, ny
    Posts
    489

    black 01 red 73
    01 z28 and 73 z28

    ac gauges are your freinds. hook them up, use them, love them! all kidding aside what are your pressures on the high and low side and is the return line at the compressor cold?

  6. #6
    Junior Member stevo5662's Avatar
    Join Date
    Feb 2006
    Location
    california
    Posts
    83

    Red
    1998 Z28 6-speed

    i do know this, whenever i turn on the ac or the heater i get a ticking noise like somthing isnt engaging all the way and it has a pretty good vibration with it. i can even feel it in my shifter. made me shit my pants before i realized it was an HVAC issue.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: 97 LT1 problems
    By james78657 in forum LT1
    Replies: 18
    Last Post: 01-20-2012, 10:30 AM
  2. Help: 62.9i problems
    By trooperrunner in forum Stereo and Electronics
    Replies: 1
    Last Post: 08-12-2009, 04:08 PM
  3. problems with my 66 g.t.o. (help)
    By 05gtoautoX in forum GTO
    Replies: 6
    Last Post: 07-11-2006, 04:49 AM
  4. Site problems or my problems?
    By oneBADDz in forum Request and Feedback
    Replies: 2
    Last Post: 04-03-2006, 07:26 PM
  5. A/C problems.
    By gnomee in forum General Help
    Replies: 2
    Last Post: 03-14-2006, 07:13 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •