Results 1 to 8 of 8

99 Z28 won't start

This is a discussion on 99 Z28 won't start within the Camaro / SS forums, part of the Vehicle Specific category; Tried starting it today, cranks but won't turn over. now it won't read my power programmer at all. I keep ...

  1. #1
    Junior Member
    Join Date
    Jul 2008
    Location
    massachusetts
    Posts
    1

    black
    1999 Z28

    99 Z28 won't start

    Tried starting it today, cranks but won't turn over. now it won't read my power programmer at all. I keep getting the message that's it's trying to communicate but nothing more. checked all the fuses everywhere nothing blown. ran fine last night. i was having a problem with the air pump fuse blowing every 3-4 months, replaced the fuse and it seems fine for another 3-4 months any suggestion ?

  2. #2
    Junior Member slonot81's Avatar
    Join Date
    Mar 2008
    Location
    massachusetts
    Posts
    5

    red
    1998 camaro Z28

    umm

    with out being there its hard to say. but a guess it could be a bad pcm or a wiring problem. fuel pump?

  3. #3
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    What power programer are you using/were you trying to program the PCM? Can you hear the fuel pump prime when you turn the key on? Blown air pump fuse won't keep the car from firing.

  4. #4
    Senior Member camarojunky74's Avatar
    Join Date
    Jun 2007
    Location
    corona ca
    Age
    31
    Posts
    2,258

    white, white and pewter
    Rip99SSA4,74Z28M4,02SSM6

    ignition and or vats problem try getting another key made, i bet that will take care of the problem

  5. #5
    Junior Member
    Join Date
    Nov 2005
    Location
    North Dakota
    Posts
    9

    Blue
    1983 Chevy Camaro Z-28

    ^^^^Ignition or vats. Possibly crank sensor.
    1983 Z-28
    LS1/4L60E - 342HP 362 ft/lbs

  6. #6
    Member first01SS's Avatar
    Join Date
    May 2008
    Location
    Dallas, TX
    Age
    37
    Posts
    184

    Pewter
    2001 Camaro Z28, Bolt-Ons

    When you turn the Key On, Engine Off (the selection right before actually starting the engine), does your instrument panel run through the normal diagnostics, meaning, all of the lamps illuminate, then go off? If not, the PCM isn't getting power. Also, if your PCM is getting power, try to remember the last thing you did before it stopped running.. maybe that will help us figure out how to help you...

  7. #7
    Your dealership guy konigandy6's Avatar
    Join Date
    Aug 2007
    Location
    Romeo, MI
    Posts
    6,557

    Velocity Yellow
    2008 Corvette Z06

    Mileage? I'm guessing fuel pump. Is the security light on?

  8. #8
    Member Blue_01_Z28's Avatar
    Join Date
    Mar 2008
    Location
    Midland, TX
    Posts
    349

    Metallic Blue
    2001 Chevrolet Camaro Z28

    Did you mean it cranks but it wont start? To me cranking and turning over is the same thing. If the security light is on its probly your key, my LT1 used to do that. I would just push the metal chip in the foward let the car sit for about 20 min and it would start.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: 97 TA won't start
    By ADAM-00SS in forum LT1
    Replies: 7
    Last Post: 07-08-2010, 04:13 PM
  2. Z28 won't start
    By flaggs_ls1 in forum General Help
    Replies: 4
    Last Post: 05-11-2008, 09:46 PM
  3. where to start?
    By Jane_says in forum Firebird / WS6
    Replies: 47
    Last Post: 02-25-2007, 09:14 PM
  4. Cold Start/Warm Start Problem
    By I'mLS1John in forum General Help
    Replies: 11
    Last Post: 02-23-2007, 08:11 PM
  5. Cold Start/Warm Start Problem
    By I'mLS1John in forum New Member Introductions
    Replies: 0
    Last Post: 02-22-2007, 06:26 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •