Results 1 to 18 of 18

99 z28 bogging badly

This is a discussion on 99 z28 bogging badly within the Camaro / SS forums, part of the Vehicle Specific category; i dont know what is going on with my z28 but it has been bogging really badly. seems like worst ...

  1. #1
    Junior Member
    Join Date
    Jul 2007
    Location
    ILLINOIS
    Posts
    7

    BLACK
    1999 Z28

    99 z28 bogging badly

    i dont know what is going on with my z28 but it has been bogging really badly. seems like worst when shifting form first to second. its an automatic and seems like it just falls on it face. it also seems like when im on the fuel and accelerating that it will pause and then regain power then pause again but i know i am not moving my foot at all. i want to fix this because i know that this thing can preform way better than it is right now. its a 1999 z28 stock its my daily driver and im looking to get it sold by the end of the summer but i want the next buyer to be happy with what it can offer and i want to fix it before trying to sell.... let me know if anyone else is having problems or if you have any ideas.

  2. #2
    Junior Member joker_01z28's Avatar
    Join Date
    Mar 2007
    Location
    Colorado Springs
    Posts
    51

    Maroon
    2000 Silverado

    MAybe a clogged fuel filter, my 89 firebird did the same thing, i got a new filter and it helped alot, the old one looked like it had choco milk coming out of it.

  3. #3
    2004 HEAD/CAM CTS-V 9t8z28's Avatar
    Join Date
    Oct 2006
    Location
    doylestown, Pa
    Posts
    6,818

    SILVER
    2004 CTS-V

    Mileage? We need more info? Any SES light?

  4. #4
    Junior Member
    Join Date
    Jul 2007
    Location
    ILLINOIS
    Posts
    7

    BLACK
    1999 Z28

    just about to turn 85000. no lights no warnings just started happing out of the blue. i maintenance it all the time, as i work on a race car so im always on top of that stuff.

  5. #5
    ls1ftw tigersport14's Avatar
    Join Date
    Sep 2006
    Location
    Tulsa
    Age
    29
    Posts
    2,035

    NBM
    98 trans am

    get a new air filter and buy some fuel injector cleaner. it could also be clogged cats, along with the dirty fuel injectors. so if you have time try to get the cats checked out

  6. #6
    Member cant.b.caught.z28's Avatar
    Join Date
    Feb 2008
    Location
    Wichita, KS
    Age
    29
    Posts
    476

    Silver
    2005 Ram Daytona

    its most likely fuel related. My z28 had the same problem. I replaced the fuel filter, it solved the problem, but then about 2 weeks later my fuel pump went out. I'm in the process of putting a new walbro pump in.

  7. #7
    ls1ftw tigersport14's Avatar
    Join Date
    Sep 2006
    Location
    Tulsa
    Age
    29
    Posts
    2,035

    NBM
    98 trans am

    why did your water pump go out?

  8. #8
    Member cant.b.caught.z28's Avatar
    Join Date
    Feb 2008
    Location
    Wichita, KS
    Age
    29
    Posts
    476

    Silver
    2005 Ram Daytona

    fuel pump

  9. #9
    ls1ftw tigersport14's Avatar
    Join Date
    Sep 2006
    Location
    Tulsa
    Age
    29
    Posts
    2,035

    NBM
    98 trans am

    feul pump*

  10. #10
    Member cant.b.caught.z28's Avatar
    Join Date
    Feb 2008
    Location
    Wichita, KS
    Age
    29
    Posts
    476

    Silver
    2005 Ram Daytona

    I miss my baby, I haven't been able to drive it for the last month because I don't have enough time ever to work on putting the new pump in.

  11. #11
    Senior Member camarojunky74's Avatar
    Join Date
    Jun 2007
    Location
    corona ca
    Age
    31
    Posts
    2,258

    white, white and pewter
    Rip99SSA4,74Z28M4,02SSM6

    you need to get a scanner hooked up with live data, such as a tech 2 or even your buddy's diablo sport,

    what you are looking for is a high fuel pulse and a lean a/f mixture under wide open accel if this is the case you are looking at a new pump and or filter, probably both. i would start their it seems as if your gonna need a pump.

    also under accel, does it shake when it has a lack of power or just doesnt go?

  12. #12
    Your dealership guy konigandy6's Avatar
    Join Date
    Aug 2007
    Location
    Romeo, MI
    Posts
    6,557

    Velocity Yellow
    2008 Corvette Z06

    hahaha, junky, I just have to say NICE avater!!! F'in Richard Simmons.

  13. #13
    Junior Member
    Join Date
    Jul 2007
    Location
    ILLINOIS
    Posts
    7

    BLACK
    1999 Z28

    it doesn't seem to shake when it looses power just doesn't go. although sometimes i notice a little shake when i'm at idle at a stop. i just noticed that i need to see how consistent that is. i figured it may be the cats being plugged up but haven't had a chance to get under it yet. thanks for all the suggestions i will try all these and let you know the results let me know if there are any more>

  14. #14
    Your dealership guy konigandy6's Avatar
    Join Date
    Aug 2007
    Location
    Romeo, MI
    Posts
    6,557

    Velocity Yellow
    2008 Corvette Z06

    Quote Originally Posted by snadoramac4 View Post
    it doesn't seem to shake when it looses power just doesn't go. although sometimes i notice a little shake when i'm at idle at a stop. i just noticed that i need to see how consistent that is. i figured it may be the cats being plugged up but haven't had a chance to get under it yet. thanks for all the suggestions i will try all these and let you know the results let me know if there are any more>
    Cut the cats off and replace it with a good exhaust setup. LS1's are notorious for plugged cats (I have seen many warranty claims on them since they carry a 8 year 80k mile warranty)

  15. #15
    Member cant.b.caught.z28's Avatar
    Join Date
    Feb 2008
    Location
    Wichita, KS
    Age
    29
    Posts
    476

    Silver
    2005 Ram Daytona

    Did you get it figured out?

  16. #16
    Junior Member niterunnr's Avatar
    Join Date
    Jun 2008
    Location
    chickasha oklahoma
    Posts
    58

    white
    01 Z-28

    what do u suggest for cat replacements... i was told headers heat up the fuel lines causing the gasoline to boil in the fuel lines and vapor lock......cause the headers are so close to where the fuel line comes up through the shock tower area..... thanks i am lookin at headers for my 01 z car....

  17. #17
    Your dealership guy konigandy6's Avatar
    Join Date
    Aug 2007
    Location
    Romeo, MI
    Posts
    6,557

    Velocity Yellow
    2008 Corvette Z06

    Quote Originally Posted by niterunnr View Post
    what do u suggest for cat replacements... i was told headers heat up the fuel lines causing the gasoline to boil in the fuel lines and vapor lock......cause the headers are so close to where the fuel line comes up through the shock tower area..... thanks i am lookin at headers for my 01 z car....
    Whoever told you that was hitting the crack pipe a little too hard then...

  18. #18
    Senior Member Too Fast's Avatar
    Join Date
    Nov 2006
    Location
    Indianapolis
    Age
    54
    Posts
    5,170

    Black
    2000 WS6 6spd Hooker LT

    Nobody has suggested a possible quick, easy fix: Get some MAF cleaner, you could have a dirty sensor (did you oil your K&N or similar air filter). That would skew the readings and not tell the PCM correct airflow (not as much as reality). And yeah, low fuel pressure/clogged catalytics will do the same as well. If it shakes as it is bogging, I would look for an ignition problem first.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. bogging out
    By 98camarols1 in forum General Help
    Replies: 29
    Last Post: 11-06-2011, 05:36 AM
  2. Bogging a bit
    By 99hawk in forum Firebird / WS6
    Replies: 5
    Last Post: 05-28-2010, 11:30 AM
  3. Mud bogging in a T/A!?
    By TempleU_WS6 in forum Firebird / WS6
    Replies: 19
    Last Post: 08-30-2008, 01:40 PM
  4. bogging motor
    By blackbird02 in forum General Help
    Replies: 6
    Last Post: 04-03-2007, 03:48 PM
  5. Bogging out of the hole
    By Mr. Luos in forum Drag Racing
    Replies: 8
    Last Post: 01-30-2007, 09:35 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •