Results 1 to 7 of 7

02 B4c

This is a discussion on 02 B4c within the Camaro / SS forums, part of the Vehicle Specific category; Hey guys, I have an 02 B4C with 109000 miles. It is a former Florida Highway Patrol car. It's running ...

  1. #1
    Junior Member
    Join Date
    Jun 2007
    Location
    Albany, NY
    Posts
    25

    black
    2002 Camaro B4C SS

    02 B4c

    Hey guys,
    I have an 02 B4C with 109000 miles. It is a former Florida Highway Patrol car. It's running al little rough and I am getting a cylinder 7 misfire code. I'm going to pull the heads to see what is happening in that cylinder. I already changed the plug, wire and coil pack. Does anyone have any other suggestions of what should be done?

  2. #2
    Member 35thz28camaro's Avatar
    Join Date
    Jul 2007
    Location
    mobile
    Posts
    312
    2002 z28 camaro

    check the compression, it could also be an injector

  3. #3
    Junior Member
    Join Date
    Jun 2007
    Location
    Albany, NY
    Posts
    25

    black
    2002 Camaro B4C SS

    Can you recommend a nice injector?

  4. #4
    Member 35thz28camaro's Avatar
    Join Date
    Jul 2007
    Location
    mobile
    Posts
    312
    2002 z28 camaro

    i have not tried any aftermarket injectors on my ls1, only stock

  5. #5
    Junior Member
    Join Date
    Jun 2007
    Location
    Albany, NY
    Posts
    25

    black
    2002 Camaro B4C SS

    any other reasons for a misfire that you know of?

  6. #6
    U.S. Army Scout T-TOPS's Avatar
    Join Date
    Mar 2008
    Location
    Alaska
    Posts
    56

    White
    1999 Z28 Camaro

    There is several guys parting out cars on here, try to get an injector off of one of them to save a couple bucks, if that don't fix it you might pull the head. Could be a chipped valve. I had a similar problem like this with an old jeep i used to own.

  7. #7
    James Bond Spikito's Avatar
    Join Date
    Aug 2007
    Location
    Texas
    Age
    30
    Posts
    4,546

    2001 3.8 Black - sold
    2000 SS Black M6

    Is it just a cylinder 7 misfire, or is it giving 2 cylinders, last time i got that code. "P0300" it was cylinders 1&3 multiple misfire.

    New coil fixed mine though, dunno what to tell ya

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •