Results 1 to 11 of 11

02 1500 express runs sluggish after restarting warm

This is a discussion on 02 1500 express runs sluggish after restarting warm within the Almost Anything Goes forums, part of the Off - Topic / Discussion forums category; ...

  1. #1
    Member qwik219d9's Avatar
    Join Date
    Sep 2008
    Location
    Atlanta, GA,Ft.Walton Bch,FL
    Posts
    411

    silver
    99 ws6

    02 1500 express runs sluggish after restarting warm

    02 1500 express runs sluggish after restarting warm

    5.7 vortec 2 wheel drive

    My van has 190K miles Iíve driven it for 10K miles and she was running fine.

    van is 100% stock.

    Recentely the van is a little sluggish after restarting the already warm engine,
    Like if I run into the store for a few minutes then restart, it will sometimes even
    Cutoff if I donít give it some extra gas to keep it alive.

    This is what Iíve done
    Replace w/ AC delco $35.ignition cap/rotor new spark w/ wires no joy.

    Edit I only replaced 7 plugs though the wheel well, the driver side closest plug to
    driver I couldínt figure out How to remove.


    Iím used to driving directly after the start up if I let her warm (even when warm)
    She does better is this sluggishness due to high milage?

    this is a tow vehical so I would like it running at it's best.

    Thanks

  2. #2
    Member qwik219d9's Avatar
    Join Date
    Sep 2008
    Location
    Atlanta, GA,Ft.Walton Bch,FL
    Posts
    411

    silver
    99 ws6

    anyone w/ advice
    cam-LTs-FAST78-Susp.-Rims

  3. #3
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,513

    98 Formula
    06 duramax

    don't have much to offer other than to maybe check fuel pressure but it doesn't really sound like a pump problem. Clean the MAF. Is it throwing any codes? What about cold starts? Have any issues with those?
    Quote Originally Posted by Mean Green Z28 View Post
    Don't worry about understanding women. Women understand women, and they hate each other

  4. #4
    Member qwik219d9's Avatar
    Join Date
    Sep 2008
    Location
    Atlanta, GA,Ft.Walton Bch,FL
    Posts
    411

    silver
    99 ws6

    she starts cold fine.

    I'll check FP and have codes checked

    apparentely the FP regulater is allmost worn out so maybe replace FP assembley to get the new FP regulater

    hows this look
    https://www.rockauto.com/en/moreinfo...sn=465&jsn=465

    then buy here it's same PN


    New Carter (Made in USA) Fuel Pump Module P74779M For Chevrolet GMC 1998-2002 | eBay
    thanks
    Last edited by qwik219d9; 08-02-2017 at 07:40 PM.

  5. #5
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,546

    Black & Blue
    '02 WS.6 / '07 Suburban

    Fuel pressure would be my guess too. Our Suburban acted up a few years back and it was low fuel pressure.

  6. #6
    Member qwik219d9's Avatar
    Join Date
    Sep 2008
    Location
    Atlanta, GA,Ft.Walton Bch,FL
    Posts
    411

    silver
    99 ws6

    is the fuel regulater built into the pump?

    thanks

  7. #7
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,546

    Black & Blue
    '02 WS.6 / '07 Suburban

    Yes, it is part of the assembly that is submerged in the fuel tank.

  8. #8
    Member qwik219d9's Avatar
    Join Date
    Sep 2008
    Location
    Atlanta, GA,Ft.Walton Bch,FL
    Posts
    411

    silver
    99 ws6

    Thanks
    Last edited by qwik219d9; 08-17-2017 at 04:59 AM.

  9. #9
    Member qwik219d9's Avatar
    Join Date
    Sep 2008
    Location
    Atlanta, GA,Ft.Walton Bch,FL
    Posts
    411

    silver
    99 ws6

    OK excellent advice as usalle I haven't checked the FP it requires removing engine cover a royal PITA however all that I read about this weird restarting problem points to FP

    I have a new Carter fuel pump from rock A I hope it will be as good as a delco like carter has been building carbs for a very long time.

    now the hard part reaching under there and mearsuring for a trap door. make the trap door then keep Fuel pump as a spare and swap when needed.

    can I lower the tank a tad then cover pump sheet of metal so when I cutting floor w/ grinder I dont cut a line or wires?
    Thanks
    Last edited by qwik219d9; 08-17-2017 at 05:03 AM.

  10. #10
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,546

    Black & Blue
    '02 WS.6 / '07 Suburban

    This is a van? Dropping the tank should be pretty simple.

  11. #11
    Senior Member
    Join Date
    Mar 2009
    Location
    Milwaukee
    Posts
    3,256

    Arctic White, red/gray
    1997 Corvette, 92 Typhoon

    Is there a of stuff under the fuel tank? If not dropping it from the bottom should be easy. But yes you can usually drop the tank a little before dropping it all the way. On the chevy trucks I have done I drop the tank as much as I can so I can reach up in there and unplug the lines... which is also a PITA depending on the connector. Then drop it the rest of the way.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Who likes my new tow vehical 02 Express 1500 5.7 vortec
    By qwik219d9 in forum Almost Anything Goes
    Replies: 13
    Last Post: 10-04-2016, 09:00 AM
  2. 98 z is sluggish
    By phil85 in forum General Help
    Replies: 21
    Last Post: 04-12-2011, 11:54 PM
  3. Sluggish acceleration?
    By onetroubledguy in forum General Help
    Replies: 23
    Last Post: 03-10-2009, 05:33 PM
  4. Sluggish
    By venom98 in forum General Help
    Replies: 22
    Last Post: 10-27-2007, 08:38 PM
  5. Sluggish LS1, WHY!!!!
    By Chicago TDP in forum General Help
    Replies: 12
    Last Post: 08-20-2007, 08:29 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •