Results 1 to 6 of 6

Ls1 to ls6 swap

This is a discussion on Ls1 to ls6 swap within the LSx Retrofit and Swap forums, part of the LSx Technical Help Section category; Drove to town car shifted really fast (460le) . Wouldn't down shift to power go go mode. Gave tps so ...

  1. #1

    Ls1 to ls6 swap

    Drove to town car shifted really fast (460le) . Wouldn't down shift to power go go mode. Gave tps so I changed that , starts up idles fine. Punch it and it turns them over, start driving normal runs great then dies . starts dies immediately wait 20 minutes runs normal . repeat lol please anyone

  2. #2
    Could it be the map sensor ?

  3. #3
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Any codes popping up? You have something odd going on as it sounds like "limp mode" is engaging.

  4. #4
    Just the oxygen rear oxygen sensor. It just straight dies and will fire up and die . If you I keep trying to start it stumbles and dies. New tps . Can I find anything out with my superchips tuner ?

  5. #5
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Fuel pressure is the first thing to check. You should have 58 psi at the rail. If your fuel pressure is good, take a look at your fuses to see if anything has popped off - start with the ENG SENS fuse in the underhood electrical panel.

  6. #6
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    If you installed a new tps you need to perform a ecm relearn for it.


    Key off
    Disconnect TPS
    Turn key on, no start, for 10-15 seconds
    Turn key off
    Connect TPS
    Turn key on, no start
    Open throttle body all the way open (100%) and close once or twice.
    Turn key off
    Turn key on, START

    This should reset the sensor for the ECM.


    I'm with Jeff though on this one, after the reset check fuel pressure.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Trans swap for swap
    By [CJ] in forum Drivetrain
    Replies: 0
    Last Post: 08-12-2011, 01:11 PM
  2. Engine swap and computer swap
    By mrmiatanut in forum Computer & Tuning
    Replies: 4
    Last Post: 09-08-2007, 06:10 PM
  3. To Swap, or not to swap, that is the question.
    By HasselZ28 in forum Camaro / SS
    Replies: 6
    Last Post: 08-11-2007, 08:58 AM
  4. Replies: 6
    Last Post: 01-30-2006, 02:02 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •