Results 1 to 9 of 9

Chevy Luv 4.8L Running Issues

This is a discussion on Chevy Luv 4.8L Running Issues within the LSx Retrofit and Swap forums, part of the LSx Technical Help Section category; Well Im excited to be a part of the board! But im having some issues with my swap. 4.8l w/ ...

  1. #1
    Junior Member
    Join Date
    Jun 2015
    Location
    washington
    Posts
    5

    Red
    1980 Chevy Luv

    Exclamation Chevy Luv 4.8L Running Issues

    Well Im excited to be a part of the board! But im having some issues with my swap.

    4.8l w/ 4l60e
    walbro 255( have also tried carter p5000)
    No codes

    The truck fires off at first bump every time and runs great and has all the power for about 30 secs. It then begins to really bog out and can barely pull its own weight and will backfire and pop. Could this be clogged injectors or a sensor? I tried another set of injectors and it ran better for a little while and then is back to how it was. I know the plugs are fouled and have new ones to go in but don't want to just wash out the next set as well. The weird part is that once it loads up i can put in Neutral shut off and restart and put in drive and it runs great again until symptoms reoccur, i can do this process all day. Im really stumped on this and am completely out of ideas.

  2. #2
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Welcome to the site!

    Is the engine wired such that you have an OBDII port to scan for codes? Are you running a stock GM PCM or an aftermarket controller? It certainly isn't warming up enough in 30 seconds to go into closed loop fueling, so it is not accepting feedback from the O2 senders yet. How about some more details?

  3. #3
    Junior Member
    Join Date
    Jun 2015
    Location
    washington
    Posts
    5

    Red
    1980 Chevy Luv

    Oem 4.8l ecu vats and emissions takin out by lt1swap.com. i have obd2 port no codes. When i unplug maf it runs worse.

  4. #4
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    Need to check pressure at the fuel rails. is this a new pump or a used one?

  5. #5
    Junior Member
    Join Date
    Jun 2015
    Location
    washington
    Posts
    5

    Red
    1980 Chevy Luv

    Both pumps were new

  6. #6
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Still a good idea to verify fuel pressure. Does your fuel system have a return or does it deadhead at the rail?

  7. #7
    Junior Member
    Join Date
    Jun 2015
    Location
    washington
    Posts
    5

    Red
    1980 Chevy Luv

    K ill check pressure, its return style and i can hear it flow to the tank so its not jammed up.

  8. #8
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    How are you regulating your fuel pressure?

  9. #9
    Junior Member
    Join Date
    Jun 2015
    Location
    washington
    Posts
    5

    Red
    1980 Chevy Luv

    01 truck setup regulator on the rail

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Any issues running FI setup NA?
    By Snowboardr18 in forum Forced Induction
    Replies: 3
    Last Post: 03-19-2010, 04:40 PM
  2. Running rough if running at all help
    By ichliebecamaro in forum LT1
    Replies: 3
    Last Post: 01-25-2010, 11:54 AM
  3. 01 chevy Camaro running ver badly
    By 01 camming red in forum General Help
    Replies: 11
    Last Post: 01-31-2009, 07:13 PM
  4. My car is having running issues...details inside
    By 34v6needhelp in forum General Help
    Replies: 12
    Last Post: 04-05-2006, 05:07 PM
  5. Replies: 0
    Last Post: 01-31-2006, 12:05 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •