Page 1 of 2 12 LastLast
Results 1 to 20 of 27

Prothane poly motormounts

This is a discussion on Prothane poly motormounts within the Parts Review forums, part of the Sponsors Group Pricing and Parts Review category; I recommend this mod if you have longtubes and the y pipe is banging on the floor....

  1. #1
    Member Pete Rock98's Avatar
    Join Date
    Aug 2005
    Location
    Bronx NY
    Age
    47
    Posts
    177

    Black
    1998 z28

    Prothane poly motormounts

    I recommend this mod if you have longtubes and the y pipe is banging on the floor.

  2. #2
    Member Justin93's Avatar
    Join Date
    Oct 2007
    Location
    CANFIELD, OHIO
    Age
    31
    Posts
    654

    PEWETER METALIC
    2002 CAMARO Z-28 M-6

    Can you Feel alot of vibration after install? Im intrested in this as well however I dont want it shaking the crap out of me lol.

  3. #3
    Member Pete Rock98's Avatar
    Join Date
    Aug 2005
    Location
    Bronx NY
    Age
    47
    Posts
    177

    Black
    1998 z28

    Poly motormounts and stock rubber tranny mount and no vibration .There is no shaking the motor moves very little. The stock rubber shake alot

  4. #4
    Old Enough to Know Better Crimson Sin's Avatar
    Join Date
    Feb 2006
    Location
    Seattle..Land of Constant Rain..
    Posts
    1,426

    Red Fire
    2007 Mustang GT/CS

    Quote Originally Posted by Pete Rock98 View Post
    Poly motormounts and stock rubber tranny mount and no vibration .There is no shaking the motor moves very little. The stock rubber shake alot
    +1
    I did the tranny as well initally. GOD DAMN lol the shake in Drive was INSANE.. Thought I lost the drive shaft first run I made. Put in a new OEM one and Almost normal again
    Do Not Anger the Horsepower Gods ! MOD !!

    2007 Mustang GT/CS
    2001 SS Cammed. Stalled. Geared. Tuned...Gone but not forgotten..
    Quote Originally Posted by bluefields88 View Post
    pornhub.com has a tribute thing for MJ at the top of page. I can't even jerk off without being bombarded by the bastard.


  5. #5
    Member emoFTW's Avatar
    Join Date
    Sep 2008
    Location
    Oklahoma
    Posts
    321

    black
    99 Z28

    anyone got a link to these prothane motor mounts? where can i buy these from? so what about the tranny mount? should it be upgraded to poly urethane or just leave the stock tranny mount alone?

  6. #6
    Old Enough to Know Better Crimson Sin's Avatar
    Join Date
    Feb 2006
    Location
    Seattle..Land of Constant Rain..
    Posts
    1,426

    Red Fire
    2007 Mustang GT/CS

    Quote Originally Posted by emoFTW View Post
    anyone got a link to these prothane motor mounts? where can i buy these from? so what about the tranny mount? should it be upgraded to poly urethane or just leave the stock tranny mount alone?
    Google is your friend..
    There are lots of places selling these
    http://www.jegs.com/vs/Prothane/311

  7. #7
    Member Pete Rock98's Avatar
    Join Date
    Aug 2005
    Location
    Bronx NY
    Age
    47
    Posts
    177

    Black
    1998 z28

    Summit racing fast shipping .
    http://store.summitracing.com/partde...5&autoview=sku

    I went with the black ones the red colored mounts were 11 bucks more .I guess for the dye they add.

  8. #8
    Member stephen02ws6's Avatar
    Join Date
    Jun 2007
    Location
    Dalzell, Illinois
    Age
    29
    Posts
    899

    red with black stripes
    2002 Trans Am WS6

    i put the motor and trans mounts in and had some vibration. it gradualy got better as i drove it.

  9. #9
    Make real real sure Johns00Z28's Avatar
    Join Date
    May 2006
    Location
    Germantown, MD
    Age
    40
    Posts
    2,404

    Black
    2000 Z-28

    I hear it's a real pain in the ass to swap the motor mounts....is it really worthwhile? My y-pipe bangs and I'd like to fix the problem which is why I'm asking.

  10. #10
    Junior Member Adam_WS6_'s Avatar
    Join Date
    Dec 2006
    Location
    Wisconsin
    Posts
    84

    White
    2001 Ws6

    i have the tranny mount . got a lil vibration but not too bad...

    over all i`ll take a lil vibration over felling like the trannys gonna come thou the floor.
    Patriot Stage 2 heads cam 228.228.581.581. 112 lsa, lts ory Magnaflow cat back, maf,full tune, LS7 Cluch w/ LS2 Flywheel,Pro 5.0,Slotted/Drilled Rotors,Subframe Connectors,Strut Tower Brace,panhard bar,lower control arms, 4.10 gear.

  11. #11
    Member Pete Rock98's Avatar
    Join Date
    Aug 2005
    Location
    Bronx NY
    Age
    47
    Posts
    177

    Black
    1998 z28

    Quote Originally Posted by Johns00Z28 View Post
    I hear it's a real pain in the ass to swap the motor mounts....is it really worthwhile? My y-pipe bangs and I'd like to fix the problem which is why I'm asking.
    I drilled out the the rivets and installed the the poly's into the clamshell that took me 2 hours.I had a shop put them on it took them almost 3 hours.

  12. #12
    O U 8 1 2 Spaz's Avatar
    Join Date
    Nov 1999
    Location
    over here...
    Age
    39
    Posts
    25,692

    []D [] []V[] []D
    1999 trans am

    i have poly motor and trans mounts... there is very little shake... if you guys think this is bad don't ever cam your car...

  13. #13
    Old Enough to Know Better Crimson Sin's Avatar
    Join Date
    Feb 2006
    Location
    Seattle..Land of Constant Rain..
    Posts
    1,426

    Red Fire
    2007 Mustang GT/CS

    I have a small cam. The shake at idle is NOTHING like the earth ending vibration I got at WOT in third with the poly trans mount. Knocked my freaking coffee cup out of the secondary holder by the glove box..
    I happen to like the shake at idle. Having my kidneys re-aligned at 80 mph, not so much.

  14. #14
    O U 8 1 2 Spaz's Avatar
    Join Date
    Nov 1999
    Location
    over here...
    Age
    39
    Posts
    25,692

    []D [] []V[] []D
    1999 trans am

    Quote Originally Posted by 01T-TopToy View Post
    I have a small cam. The shake at idle is NOTHING like the earth ending vibration I got at WOT in third with the poly trans mount. Knocked my freaking coffee cup out of the secondary holder by the glove box..
    I happen to like the shake at idle. Having my kidneys re-aligned at 80 mph, not so much.
    sounds like it wasn't installed right then or else your motor mounts were shot... mine hardly vibrates at all...

  15. #15
    Member
    Join Date
    Feb 2008
    Location
    NEW JERSEY
    Posts
    814

    PEWTER
    2001 TRANS AM WS6

    I heard that the trans mount makes it more likely to snap your trans tail shaft

  16. #16
    O U 8 1 2 Spaz's Avatar
    Join Date
    Nov 1999
    Location
    over here...
    Age
    39
    Posts
    25,692

    []D [] []V[] []D
    1999 trans am

    Quote Originally Posted by DIRTY JERZY View Post
    I heard that the trans mount makes it more likely to snap your trans tail shaft
    i doubt it...

  17. #17
    Member
    Join Date
    Feb 2008
    Location
    NEW JERSEY
    Posts
    814

    PEWTER
    2001 TRANS AM WS6

    Oh I probably should have said that was on cars that kept the stock motor mounts

  18. #18
    Member Pete Rock98's Avatar
    Join Date
    Aug 2005
    Location
    Bronx NY
    Age
    47
    Posts
    177

    Black
    1998 z28

    I have the spohn body mounted tq arm, I was told a tranny mounted tq is what brakes the tail shaft at the track with good vht lol

  19. #19
    O U 8 1 2 Spaz's Avatar
    Join Date
    Nov 1999
    Location
    over here...
    Age
    39
    Posts
    25,692

    []D [] []V[] []D
    1999 trans am

    Quote Originally Posted by Pete Rock98 View Post
    I have the spohn body mounted tq arm, I was told a tranny mounted tq is what brakes the tail shaft at the track with good vht lol
    maybe a stock tq arm... i know i snapped mine in half...

  20. #20
    Member
    Join Date
    Jul 2006
    Location
    Glen Carbon, IL
    Age
    39
    Posts
    397

    Silver
    2000 Camaro SS

    I'm running mid 10's on the stock 130k miles motor and tranny mounts. I have a set of poly mounts sitting in the garage (I've had them for 6+ months).

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question: Exhaust noise after Prothane Poly Tranny and Motor Mounts...
    By manibot in forum External Engine
    Replies: 22
    Last Post: 12-07-2013, 02:53 PM
  2. BMR poly adj. phb AND aluminum poly boxed LCA
    By xmarkx in forum Parts For Sale / Trade
    Replies: 3
    Last Post: 07-06-2010, 04:15 PM
  3. cause for bad motormounts?
    By Ramairgod84 in forum General Help
    Replies: 19
    Last Post: 04-09-2010, 09:30 AM
  4. LS1 Prothane Poly Motor Mounts
    By SSpdDmon in forum Parts For Sale / Trade
    Replies: 0
    Last Post: 05-18-2007, 02:29 PM
  5. prothane poly rear swaybar bushings
    By magilla in forum Parts For Sale / Trade
    Replies: 0
    Last Post: 01-30-2006, 11:07 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •