Results 1 to 3 of 3

turbo problem

This is a discussion on turbo problem within the Forced Induction forums, part of the LSx Technical Help Section category; ok i am the 17 year old who did my own rear mount that i posted about i just did ...

  1. #1
    Junior Member
    Join Date
    Jan 2008
    Location
    Pampa Tx
    Posts
    40

    White
    1998 Formula

    turbo problem

    ok i am the 17 year old who did my own rear mount that i posted about i just did my turbo setup and but i didnt have time to set up my waste gate and then the lines to the bov and wastegate i guess the refrence lines but all the oil lines and everything is hooked up and the turbo is getting oil .....becasue it is still spinning what will this do to my setup if anyting .we relocated the maf sensor to the back by the cone witht the rear mount turbo........ok well ive been driving around and stuff and getting on it a lil bit but my car is freaking slow i am getting beat by cars that i kill before...shouldnt my car be running like it was

  2. #2
    Junior Member
    Join Date
    Jan 2008
    Location
    Pampa Tx
    Posts
    40

    White
    1998 Formula

    or is it the maf sensor location or the engine trying to suck air from the turbo

  3. #3
    We'll be back... GatorSS's Avatar
    Join Date
    Aug 2005
    Location
    THE SWAMP
    Posts
    1,446

    Light Pewter Metallic
    2000 Camaro SS M6

    Have you tuned it for the turbo setup? If not, it will run like crap.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Wanted: Trade my HUGE turbo for your smaller turbo
    By Iknowthefuture in forum Parts Wanted / Trade
    Replies: 0
    Last Post: 08-30-2010, 06:47 PM
  2. Replies: 0
    Last Post: 09-29-2007, 07:50 AM
  3. Pontiac Firebird Turbo Installation - Subterranean Turbo System
    By Ed Blown Vert in forum Firebird / WS6
    Replies: 1
    Last Post: 09-12-2007, 07:16 PM
  4. sts turbo problem
    By aquickfive0 in forum Forced Induction
    Replies: 41
    Last Post: 09-04-2006, 08:47 PM
  5. STS Turbo problem
    By aquickfive0 in forum Forced Induction
    Replies: 46
    Last Post: 07-23-2006, 10:59 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •