Page 2 of 3 FirstFirst 123 LastLast
Results 21 to 40 of 42

sts turbo problem

This is a discussion on sts turbo problem within the Forced Induction forums, part of the LSx Technical Help Section category; i have this kit already installed on my car can you send me the article as well. gotbank15@yahoo.com...

  1. #21
    Junior Member
    Join Date
    Aug 2005
    Location
    champaign il
    Age
    36
    Posts
    9

    pewter
    2002 trans am ws6

    i have this kit already installed on my car can you send me the article as well.
    gotbank15@yahoo.com

  2. #22
    Member cailey37's Avatar
    Join Date
    Mar 2006
    Location
    Mississippi
    Posts
    832

    Silver
    1998 Pontiac Trans Am

    Quote Originally Posted by illcul8troffcr
    Could you be so kind as to forward me that article on STS as well?
    email address????

  3. #23
    Member cailey37's Avatar
    Join Date
    Mar 2006
    Location
    Mississippi
    Posts
    832

    Silver
    1998 Pontiac Trans Am

    Quote Originally Posted by CODE4LS1
    I was wondering if I could get that article as well.....will be intalling an STS on my SS next weekend
    email address???

  4. #24
    Senior Member illcul8troffcr's Avatar
    Join Date
    Apr 2006
    Location
    Virginia
    Posts
    1,344

    Sebring Silver
    2002 Camaro SS

    http://i55.photobucket.com/albums/g154/illcul8troffcr/My%20SS/signaturew.jpg
    2002 Camaro SS #1539
    MTI Clear AirLid /Magnaflow catback/Polished Hotchkis Strut Tower Brace/K&N Filter/Bilstein Suspension/
    http://www.cardomain.com/ride/553601
    http://www.fquick.com/illcul8troffcr

  5. #25
    could someone post it in the forum ?

  6. #26
    Junior Member
    Join Date
    Mar 2006
    Location
    Regina, Sask Canada
    Posts
    84

    Black
    2000 Camaro SS

    can i please get a copy

    thanks

    chris@toths.ca
    Click for full size
    2000 Camaro SS Black Loaded LS1 6-Speed T-Tops, STS Rear-Mount Turbo, 42Lb Injectors, Racetronixs Fuel pump upgrade system, Custom Tune by Rick Squires @ STS Turbo, Goodyear F1 DS-G3 275 40zr17's. 3.73Rear End.

  7. #27
    Junior Member
    Join Date
    Oct 2005
    Location
    texas
    Age
    34
    Posts
    2

    black
    2000 z28

    Quote Originally Posted by cailey37
    I just got a 7 page article from STS that addresses this issue....give me an email address and I'll send it to you
    negrovaldez.casadoguerra@us.army.mil

  8. #28
    Junior Member Schantin's Avatar
    Join Date
    Feb 2006
    Location
    Williamsburg, Virginia
    Age
    46
    Posts
    11

    White
    2002 Camaro Z28

    Another request for this article, please. SchantinP@yahoo.com

  9. #29
    Could you be so kind as to forward me that article on STS as well

    gsprockel@hotmail.com

    thanks

  10. #30
    Member cailey37's Avatar
    Join Date
    Mar 2006
    Location
    Mississippi
    Posts
    832

    Silver
    1998 Pontiac Trans Am

    If i've forgotten anyone let me know........I will say if you have this kit and you're having this problem make sure you have the oil line from the turbo to the pump routed OVER the differential and the fitting is pointed up towards the car and not the ground.....believe me....it makes a difference...

  11. #31
    Junior Member
    Join Date
    Aug 2006
    Location
    Lancaster Ca
    Posts
    1

    White
    1998 Z28 Camaro

    hey guys, im new to this forum and ive been thinking about buying a STS kit for my 98 LS1 Z28. STS told me that i will need a MSD fuel booster, higher PSI injectors and the Diablo Programer along with everything else in the kit. My main concern is the Booster, will the MSD Booster stress the stock pump causing early wear?
    Last edited by 98F-Body; 08-31-2006 at 10:59 PM.

  12. #32
    Junior Member
    Join Date
    Aug 2005
    Location
    West Palm Beach, FL
    Age
    40
    Posts
    58

    Pewter
    2002 Camaro SS

    It might...but you don't want to take chances on fuel when running a turbo. Play it safe, upgrade the fuel pump, and you can add the booster on top of that if you want.
    2002 Camaro SS-STS kit, LME built 370, h/c, and a bunch of other stuff

    5psi-456 rwhp 498 rwtq ran out of fuel!!

  13. #33
    Junior Member
    Join Date
    Mar 2006
    Location
    Regina, Sask Canada
    Posts
    84

    Black
    2000 Camaro SS

    Quote Originally Posted by 98F-Body View Post
    hey guys, im new to this forum and ive been thinking about buying a STS kit for my 98 LS1 Z28. STS told me that i will need a MSD fuel booster, higher PSI injectors and the Diablo Programer along with everything else in the kit. My main concern is the Booster, will the MSD Booster stress the stock pump causing early wear?
    Really?

    i guess that depends on who you talk to there.

    I spoke with STS and they said i will need to upgrade my 26LB injectors because the 2000 LS1 comes with 26's instead of 28's (small diffrent)

    They indicated that on 26's and stock pump the car could handle 4PSI boost.

    I upgraded to 42LB's which works the stock pump harder but they indicated that the stock pump with upgraded injectors will allow for a full 5PSI boost, but anything over this requires a fuel pump upgrade.

    I have to finish installing my racetronix fuel pump system (pump, and upgraded power supply to pump). but this wont happen until my stock starts to cause problems or else i up the boost.

    I guess my summary is my recommendations from STS was:
    1) Preditor tunner with custom tunes by Rick Squires.
    2) Upgraded Injectors (42LBs in my case)
    -The above is required for 5psi, anymore and fuel pump upgrades are required.

  14. #34
    Moving forward. Pyromaniacal's Avatar
    Join Date
    Apr 2006
    Location
    Utah
    Posts
    167

    Blue/Yellow/White
    95 T/A 383

    Megalomaniac1c3@hotmail.com -- hehe hate to bug you but I'd really like that 7 page doc on STS as well.

  15. #35
    Junior Member
    Join Date
    Sep 2006
    Location
    Lexington
    Age
    45
    Posts
    36

    Black
    87 Buick GN

    Quote Originally Posted by lynx853 View Post
    blown seals on turbo is my first guess
    Would also have been my first guess...but after reading about the polarity issue and the oil line routing I would check that first...btw...you never mentioned how old the system is.

  16. #36
    Junior Member
    Join Date
    Mar 2006
    Location
    Regina, Sask Canada
    Posts
    84

    Black
    2000 Camaro SS

    Quote Originally Posted by Forcedinductiontech View Post
    Would also have been my first guess...but after reading about the polarity issue and the oil line routing I would check that first...btw...you never mentioned how old the system is.
    what is the polarity problem?

    like physical pumbing side?

    or are we talking the wireing on the pump is wrongly indicated in the manual

  17. #37
    Junior Member
    Join Date
    Sep 2006
    Location
    Lexington
    Age
    45
    Posts
    36

    Black
    87 Buick GN

    Did you just install the kit? If yes, check the wires on the oil return pump. If the polarity is reversed, oil will come out of the tail pipe. I have seen oil in my intake pipes ever since I got the kit, nothing major...but it's always been there.

    Is the oil going to the throttle body causing any problems?
    AS quoted from NYSS Guy

  18. #38
    Junior Member
    Join Date
    Mar 2006
    Location
    Regina, Sask Canada
    Posts
    84

    Black
    2000 Camaro SS

    Quote Originally Posted by Forcedinductiontech View Post
    AS quoted from NYSS Guy
    i dont see oil in the exhuast pipe, but it seems that my pump always runs on the high speed, from what i understand under vac the pump runs at a lower speed when warmed up, once under boost the pump speeds up.

    I shorted out the presure switch by the pump today and it sounds the alarm (good thing) but the pump seems to sound exactly the same as if its not working any harder.

    Also i pulled my return cap off the car and ran it for 30 seconds or so and its just kindof spitting and gurgling oil out, should i not see a steady stream of oil spraying from this return line?

    if i should see a steady stream what should i start troubleshooting with?

    If anyone can check theres and let me know if its doing the same thing on their kit,

    just always concerned about oil circulation.
    want it to be as good as possible.

    it seems like that check valve on the turbo's oil inlet side is higher PSI rating then it needs to be maybe restricting flow of oil

  19. #39
    Junior Member
    Join Date
    Sep 2006
    Location
    Lexington
    Age
    45
    Posts
    36

    Black
    87 Buick GN

    How many miles on the turbo? Any shaft play? Lets start there.

  20. #40
    Junior Member
    Join Date
    Mar 2006
    Location
    Regina, Sask Canada
    Posts
    84

    Black
    2000 Camaro SS

    Quote Originally Posted by Forcedinductiontech View Post
    How many miles on the turbo? Any shaft play? Lets start there.
    1500 Miles

    Shaft has no play, feels great, spins freely and doesnt budge for play.

Page 2 of 3 FirstFirst 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Wanted: Trade my HUGE turbo for your smaller turbo
    By Iknowthefuture in forum Parts Wanted / Trade
    Replies: 0
    Last Post: 08-30-2010, 06:47 PM
  2. turbo problem
    By Fastformula in forum Forced Induction
    Replies: 2
    Last Post: 03-08-2008, 02:24 AM
  3. Replies: 0
    Last Post: 09-29-2007, 07:50 AM
  4. Pontiac Firebird Turbo Installation - Subterranean Turbo System
    By Ed Blown Vert in forum Firebird / WS6
    Replies: 1
    Last Post: 09-12-2007, 07:16 PM
  5. STS Turbo problem
    By aquickfive0 in forum Forced Induction
    Replies: 46
    Last Post: 07-23-2006, 10:59 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •