Page 2 of 2 FirstFirst 12
Results 21 to 27 of 27

sts remote turbo kit?

This is a discussion on sts remote turbo kit? within the Forced Induction forums, part of the LSx Technical Help Section category; ya I think it will be eisier if i just spray. I will keep everyone posted, Thanks for the info ...

  1. #21
    Member sscrazy's Avatar
    Join Date
    Aug 2005
    Location
    Warren MI. (detroit area)
    Age
    39
    Posts
    429

    red
    00 camaro ss

    ya I think it will be eisier if i just spray. I will keep everyone posted, Thanks for the info ..

  2. #22
    Member aquickfive0's Avatar
    Join Date
    Dec 2005
    Location
    cocoa beach florida
    Age
    42
    Posts
    124

    pewtr
    2002 Trans am WS-6

    i have a sts turbo on my 2002 ws6 and i have had the oil problem twice so ar but went away, it is a problem
    and im in florida and when we get our rain season i cant drive my car alot, i have a shield on mine and still get water coming in and in spits and sputters,

    if sum1 hasnt had the problem then they are the lucky ones, but i do like sts , great power, and the sound on the turbo is like a jet goin down the road, only flaw i dont like is the air filter location and i only have 1 exhaust pipe , besides that i love it

  3. #23
    FastPontiac
    Guest
    Quote Originally Posted by Sarge View Post
    I'll be damned....where are folks having the oil issue? I called Rick (STS Owner) after I read this and it's the first he has heard of this also. Now I am aware of some folks who wired their oil pumps up wrong...but that was an easy fix....and as far as water in the intake....Once again...show me one...I have yet to see one have any water issues....that is more a perception than reality..and I'm around a lot of em....
    I have had my STS system for 9 months and 7400 miles without any water issues. I have driven in snow storms and in heavy downpours. I had the shield on, but not the sock they give you to put around it and it is fine.

  4. #24
    Member cailey37's Avatar
    Join Date
    Mar 2006
    Location
    Mississippi
    Posts
    832

    Silver
    1998 Pontiac Trans Am

    A lot of the oil issues can come from the checkvalve that STS has on the oil line to the turbo. If anything....gets caught in it it will hang the valve open and cause the oil to drain into the turbo and then you have a mess......would like to see a better valve on there but hey....they are fun when they are working right.....

  5. #25
    Member cailey37's Avatar
    Join Date
    Mar 2006
    Location
    Mississippi
    Posts
    832

    Silver
    1998 Pontiac Trans Am

    Quote Originally Posted by Sarge View Post
    I dont doubt you...I run/ride and "play" with quite a few of the STS guys and Allen Nelson is a personal friend of mine...of course he is the tuner for STS....so when I read this I'm like WTF? I am aware of some oil issues however they have all been traced to installation issues....I have not heard of a single mechanical failure causing oil leakage issues....and Rick maybe like me is thinking your talking about some of the install issues....I dunno...
    I talked to Rick today about the checkvalve that feeds the oil to the turbo.....he said that they have upgraded that so hopefully that will help with the problem with it hanging open so easily...........

  6. #26
    Junior Member DadsYellowGoat's Avatar
    Join Date
    Dec 2005
    Location
    Woolwich Township NJ
    Age
    65
    Posts
    19

    Yellow w/ flames
    2004 GTO

    I have not had any oil issues either, the car is very well behaved on he highway. The only problem I had was a little hole in the piston from being too lean

  7. #27
    Member ericwilloughby's Avatar
    Join Date
    Apr 2006
    Location
    Louisville KY
    Age
    48
    Posts
    178

    Yellow
    2005 GTO

    I'm seeing under hood single and twin kits for $5,000 now. Don't do STS for the same price.

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. remote mount turbo question
    By cjg454ss in forum Forced Induction
    Replies: 20
    Last Post: 06-03-2015, 11:37 AM
  2. Turbo kits not remote mounted.
    By WS6ICK2K in forum Forced Induction
    Replies: 18
    Last Post: 04-28-2008, 03:26 PM
  3. Replies: 0
    Last Post: 09-29-2007, 07:50 AM
  4. Pontiac Firebird Turbo Installation - Subterranean Turbo System
    By Ed Blown Vert in forum Firebird / WS6
    Replies: 1
    Last Post: 09-12-2007, 07:16 PM
  5. Exhuast work on remote mount turbo worth it?
    By grandkodiak in forum Forced Induction
    Replies: 14
    Last Post: 05-24-2006, 10:16 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •