Results 1 to 2 of 2

sts kit and guage problems

This is a discussion on sts kit and guage problems within the Forced Induction forums, part of the LSx Technical Help Section category; i installed a sts kit among tons of other stuff but the placed where they say to run the boost ...

  1. #1
    Junior Member
    Join Date
    Nov 2006
    Location
    las cruces nm
    Age
    40
    Posts
    8

    silver
    1999 z/28

    sts kit and guage problems

    i installed a sts kit among tons of other stuff but the placed where they say to run the boost guage dosent supply boost to the guage it also dosent run the the meth kit. i can blow into the line for the meth and it sprays but when hooked up to the vaccum line nothing need some help please thanks.

  2. #2
    Member OreoLt1's Avatar
    Join Date
    Oct 2005
    Location
    P'cola Florida /Moore,Okc, OK
    Posts
    520
    I would make sure that there are not any vacuum leaks that would drop vacuum pressure, also I would call STS techs. and ask them before tapping into a stronger manifold vacuum.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Guage Problems?
    By RagTop in forum General Help
    Replies: 11
    Last Post: 06-19-2012, 09:48 PM
  2. 4 guage or 8
    By ss2000 in forum Stereo and Electronics
    Replies: 3
    Last Post: 04-14-2010, 12:31 PM
  3. temp guage problems
    By maxwax in forum General Help
    Replies: 1
    Last Post: 10-02-2007, 08:38 AM
  4. guage ?
    By djbcrazy7 in forum Stereo and Electronics
    Replies: 2
    Last Post: 09-13-2007, 05:46 PM
  5. Triple guage pillar and cobalt guage for sale
    By mikewood21 in forum Parts For Sale / Trade
    Replies: 11
    Last Post: 06-20-2006, 04:47 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •