Results 1 to 13 of 13

Single fan from Procharger kit not enough?

This is a discussion on Single fan from Procharger kit not enough? within the Forced Induction forums, part of the LSx Technical Help Section category; I installed a Procharger kit in a 2000 formula and now we are experiencing the engine overheating. Has anyone had ...

  1. #1
    Junior Member
    Join Date
    Apr 2011
    Location
    Tallahasse Fl
    Posts
    46

    Black
    1991 T/A GTA

    Single fan from Procharger kit not enough?

    I installed a Procharger kit in a 2000 formula and now we are experiencing the engine overheating. Has anyone had this issue and what was the remedy? As long as the car is over 45 mph it's fine the fan is running low speed with the ac on till it's almost in the red then fan speeds up. Procharger tech told me to go here to find out what people were doing but my search results didn't find what I was looking for. I wasn't thrilled about putting a singe fan in a car like this but it's what Procharger sent with the kit and I figured it would have been researched by them and it would be perfect. Thank you for your time.

  2. #2
    Blown, Stroked, & Sprayed

    Ed Blown Vert's Avatar
    Join Date
    Aug 1999
    Location
    San Diego, Ca
    Posts
    50,747

    Black
    383 Procharged & N20 Vert

    I had to install an extra fan like this.
    Attached Images Attached Images

  3. #3
    Moderator 35th-ANV-SS's Avatar
    Join Date
    Oct 2008
    Location
    Wherever life takes me
    Posts
    12,465

    Red
    02 35th LE Camaro SS

    I'm running a single fan, but changed to a different coolant. Haven't had an issue really. The car definitely runs a little warmer than before the Procharger install though. On a hot day, the temp has creeped up at idle to about the 2/3 mark on the temp gauge when sitting in traffic for awhile. Once she gets moving again though it comes back down.

  4. #4
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    Jon, he is also much further south then you.

    I wonder if in this case an electric water pump and a bigger radiator might help.

    I've also heard that Royal Purples "Ice" additive does work.

  5. #5
    Moderator 35th-ANV-SS's Avatar
    Join Date
    Oct 2008
    Location
    Wherever life takes me
    Posts
    12,465

    Red
    02 35th LE Camaro SS

    Midwest sees triple digits with very high humidity during the summer months, although this summer has been cooler. That's a good point though as his location doesn't show from the app.

    It's a really tight fit in there with everything installed. Would be interested in knowing if a bigger radiator would fit.
    It's on jackstands.

  6. #6
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    Also is the nose piece open enough for the air to pass through the intercooler & radiator?

  7. #7
    Junior Member
    Join Date
    Apr 2011
    Location
    Tallahasse Fl
    Posts
    46

    Black
    1991 T/A GTA

    Quote Originally Posted by SMWS6TA View Post
    Also is the nose piece open enough for the air to pass through the intercooler & radiator?
    Intercoolers are mounted behind the parking lights on both sides.
    1993 Gmc Typhoon good by GTA

  8. #8
    Junior Member
    Join Date
    Apr 2011
    Location
    Tallahasse Fl
    Posts
    46

    Black
    1991 T/A GTA

    Quote Originally Posted by Ed Blown Vert View Post
    I had to install an extra fan like this.
    What size is that fan? What you did seems like the best remedy so far. Thank you for that picture. Are you using the fan to hold the driver side together or are the bolts still there?

  9. #9
    Moderator 35th-ANV-SS's Avatar
    Join Date
    Oct 2008
    Location
    Wherever life takes me
    Posts
    12,465

    Red
    02 35th LE Camaro SS

    Ah, you have the twin intercoolers. I have the larger FMIC from ATI. How much boost are you running?

  10. #10
    Junior Member
    Join Date
    Apr 2011
    Location
    Tallahasse Fl
    Posts
    46

    Black
    1991 T/A GTA

    I don't have a boost gauge hooked up I believe it's the 8psi kit. It's 544 hp at the wheels. It is the 8 rib kit which I feel is really the best way to go due to having to pin the crank and the ati balancer.

  11. #11
    Blown, Stroked, & Sprayed

    Ed Blown Vert's Avatar
    Join Date
    Aug 1999
    Location
    San Diego, Ca
    Posts
    50,747

    Black
    383 Procharged & N20 Vert

    Quote Originally Posted by rob2000gt View Post
    What size is that fan? What you did seems like the best remedy so far. Thank you for that picture. Are you using the fan to hold the driver side together or are the bolts still there?
    If I remember correctly, that was the 9 Spal fan. The fan holds that side together.

    I tried larger radiator, better Spal fan. But in the end, an extra fan worked the best.
    Black 1999 Blown Convertible A4
    Forged 383, ATI D-1SC
    NX MAF Kit | 222/226 .585 115
    AS Stage II 6.0L FI Heads
    Moser 9" | 3.70 | Wavetrac | 35 Spline | Vigilante 3600
    548.0 RWHP - 563.8 RWTQ - 10# - D1

    666.0 RWHP - 734.2 RWTQ - 125 Shot - P1

    Black 2009 Escalade Hybrid 4WD
    Black 2008 GMC Yukon Hybrid 4WD (Totaled)

    Black 2013 Chevy Volt (Gone)

  12. #12
    Junior Member
    Join Date
    Apr 2011
    Location
    Tallahasse Fl
    Posts
    46

    Black
    1991 T/A GTA

    Quote Originally Posted by Ed Blown Vert View Post
    If I remember correctly, that was the 9 Spal fan. The fan holds that side together.

    I tried larger radiator, better Spal fan. But in the end, an extra fan worked the best.
    Thank you for that info

  13. #13
    Junior Member
    Join Date
    Nov 2014
    Location
    switzerland
    Posts
    8
    so would it help to remove the plastic "block-offs" in the bumper and open up/get ridd of the plastic plate in fron of the radiator?


LinkBacks (?)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. I wonder why she's still single?
    By SMWS6TA in forum Almost Anything Goes
    Replies: 21
    Last Post: 06-04-2012, 08:51 AM
  2. Single Gauge pod
    By JwMonE99 in forum Parts For Sale / Trade
    Replies: 4
    Last Post: 07-30-2009, 09:07 PM
  3. I am single
    By c5z28 in forum Almost Anything Goes
    Replies: 15
    Last Post: 05-15-2009, 05:28 AM
  4. Sound clip needed for single-in single out exhaust.
    By KIXASS in forum External Engine
    Replies: 0
    Last Post: 09-13-2007, 07:27 PM
  5. single pipe 5.0
    By az gt eater in forum Kill Stories
    Replies: 3
    Last Post: 04-23-2006, 12:30 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •