Results 1 to 7 of 7

P1SC Overheating at 2K but not idle.

This is a discussion on P1SC Overheating at 2K but not idle. within the Forced Induction forums, part of the LSx Technical Help Section category; ...

  1. #1
    Member Double0me's Avatar
    Join Date
    Dec 2005
    Location
    FT Carson
    Age
    38
    Posts
    124

    Blue
    1999 Blown Trans Am

    P1SC Overheating at 2K but not idle.

    OK this is kicking my ass, here is what I am working with. I have a 1999 Trans Am LS1 4L60E P1SC at 15LB Boost max. I have an LS6 Intake, 85mm Throttle body, large intercooler, Griffin 400-600HP Radiator (17X19X3), 16” shrouded 2400CFM fan, new 160* thermostat, 60lb injectors, NKG TR6, Stock internals, Moser 12bolt 3.42 gears, Sub-Frame, sway-bar and tower strut brace. Tuned by me with HP Tuners Pro and a NGK Wideband.

    The issue is I am over heating at 2000RPM’s. Idle at a light and I will cool down. I have tried switching my fan from a pusher to a puller with no change. I have tried “riching” up my tune from 14.5 to 14 to 13.5. I have changed my fan setting to account of the 160 thermo, and tried not cutting the fan off till 270* to see if that helped. It didn’t…. My only line of thought now is that since my radiator has less surface space and is wider it’s not cooling down as well and its pushing through the thicker radiator quicker…..
    Anyone done this before or had any similar issues? Would the fix be a larger fan or scrap the radiator and go a different wrought with a wider unit? I have been messing with this for so long that I need a fresh look. Thanks for the help

  2. #2
    Senior Member FasstChevys's Avatar
    Join Date
    Oct 2005
    Location
    Minnesota
    Posts
    3,315

    White
    '10 ZR1

    hmm........I know that there is a specific procedure for refilling your radiator..........

    I'm not trying to be too simple - and you've probably already ruled it out - but.

    I'll keep thinking about it - fwiw.

  3. #3
    Member Double0me's Avatar
    Join Date
    Dec 2005
    Location
    FT Carson
    Age
    38
    Posts
    124

    Blue
    1999 Blown Trans Am

    Yes, I did try the jacking up the front passenger side ad turned the heater on high to make sure I was air bubble free. For the record. Thanks for the input this has me about to bring it to a professional and I have never done that before. LOL.

  4. #4
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,519

    98 Formula
    06 duramax

    do you have access to your tune? When are the fans set to turn on and off and are they running when they should be?

  5. #5
    Member Double0me's Avatar
    Join Date
    Dec 2005
    Location
    FT Carson
    Age
    38
    Posts
    124

    Blue
    1999 Blown Trans Am

    They are coming on at 160* and still set to go off at 270*. They are turning on at the right time and staying on.

  6. #6
    Moderator 35th-ANV-SS's Avatar
    Join Date
    Oct 2008
    Location
    Wherever life takes me
    Posts
    12,465

    Red
    02 35th LE Camaro SS

    Have you verified the engine temp by another means aside from your gauge? Maybe the gauge is faulty.

    Is this during normal outside temperatures? I noticed mine runs a little hotter now, but only when I'm sitting in traffic on a hot summer day.
    It's on jackstands.

  7. #7
    Member Double0me's Avatar
    Join Date
    Dec 2005
    Location
    FT Carson
    Age
    38
    Posts
    124

    Blue
    1999 Blown Trans Am

    I had to paint the basement.... I will check to make sure the the fans are conning on at the right temp and will take a few temp readings with my tempature laser. I did pick up a Taurus fan today so I will see if that helps.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. idle issues... idle high. unplugged tps runs good?
    By okiels1 in forum Firebird / WS6
    Replies: 2
    Last Post: 12-31-2016, 04:36 AM
  2. Question: Need pulley for P1SC
    By ccarpenter85 in forum Forced Induction
    Replies: 3
    Last Post: 08-11-2011, 09:49 PM
  3. WTB: P1SC or D1SC kit
    By JC70SS in forum Parts Wanted / Trade
    Replies: 0
    Last Post: 05-22-2009, 01:36 PM
  4. P1SC and Pistons!!!
    By 00RedZ in forum Parts For Sale / Trade
    Replies: 1
    Last Post: 12-15-2006, 05:53 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •