Results 1 to 5 of 5

No boost on the 17 year old build up

This is a discussion on No boost on the 17 year old build up within the Forced Induction forums, part of the LSx Technical Help Section category; ok i have comepleted the rear mount Turbo set up but there is no boost just goes to o and ...

  1. #1
    Junior Member
    Join Date
    Jan 2008
    Location
    Pampa Tx
    Posts
    40

    White
    1998 Formula

    No boost on the 17 year old build up

    ok i have comepleted the rear mount Turbo set up but there is no boost just goes to o and it kinda slugish and cuts out when wot......OK i ran the vacum line for my waste gate at the end of the compressor housing right before the intake tube to the engine..........i ran the vacume line from the bov and gauge to the break booster line..........and the maf sensor is in the back on the intake side of the turbo right after the cone filter .......can anyone help me and tell me why im not getting boost and why it is cutting out and slugish is it my refrence line of the maf sensor location or leaks in the exhaust or intake side/

  2. #2
    Member ProwlerZ's Avatar
    Join Date
    Dec 2005
    Location
    Myrtle Beach
    Age
    33
    Posts
    404

    Silver
    2002 Z28

    I can tell you that telling us your age in the title isn't going to make anyone want to respond or help more...
    She's baaaaaccccck...

    '02 Z/28 M6 Hardtop

  3. #3
    Junior Member Syclone354's Avatar
    Join Date
    Feb 2008
    Location
    Taneytown, Maryland
    Posts
    19

    Black
    1991 GMC Syclone

    the vacuum line coming off the compressor housing needs to go to the wastegate. sounds like your wastegate is just hanging open.

  4. #4
    TunedbyFrost.com Tuner Frost's Avatar
    Join Date
    Jul 2007
    Location
    Richmond VA
    Posts
    2,415

    LS1.com Sponsor
    GM Tuner

    Quote Originally Posted by Syclone354 View Post
    the vacuum line coming off the compressor housing needs to go to the wastegate. sounds like your wastegate is just hanging open.
    You'd be better referencing the manifold rather than the compressor scroll of the turbo. Any boost lost through leaks or the intercooler will be made up for if referencing the manifold.

    Poster, you aren't gonna make any boost until you drive it down the road, which you won't be doing without tuning.

  5. #5
    SS Driver
    Join Date
    Aug 2005
    Location
    Third Rock
    Posts
    66

    Black
    00 Camaro SS #5255

    Are you talking about the STS setup? If so and if your in Pampa, there is a guy that works at Beatons in Amarillo, I believe his name is Toby. He has the STS on his car. He might be able to help. You can try and get ahold of him thru amarilloracers.com, I don't remember his screen name.

    Never mind I just read your other posts. Still there's some guys around your area that could probably help.
    Last edited by SS goblin; 03-14-2008 at 08:20 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Callaway will build you a Corvette AeroWagen this year
    By Ed Blown Vert in forum Corvette
    Replies: 0
    Last Post: 04-05-2016, 08:40 PM
  2. Boost Gauge vs Boost/Vacuum Gauge
    By ls1camino in forum Forced Induction
    Replies: 6
    Last Post: 09-28-2008, 07:02 PM
  3. 1k Turbo build by 17 year old
    By Fastformula in forum Forced Induction
    Replies: 15
    Last Post: 03-13-2008, 09:00 PM
  4. Boost Baby Boost
    By DanWS6 in forum Rocky Mountain Members
    Replies: 16
    Last Post: 04-03-2007, 12:37 PM
  5. Replies: 25
    Last Post: 03-13-2006, 07:46 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •