Results 1 to 7 of 7

any STS problems?

This is a discussion on any STS problems? within the Forced Induction forums, part of the LSx Technical Help Section category; I was wondering what kind of problems anybody is having. Has anybodies turbo actually fallen off....

  1. #1
    Junior Member
    Join Date
    Jul 2006
    Location
    ohio
    Age
    38
    Posts
    2

    white
    2000 Camaro

    any STS problems?

    I was wondering what kind of problems anybody is having. Has anybodies turbo actually fallen off.

  2. #2
    Senior Member JD_Z28's Avatar
    Join Date
    Aug 2005
    Location
    Hot ass Arizona!!
    Posts
    1,723
    I've never had any major problems with my kit. If your looking towards buying a kit there is a good deal for one on the for sale section.

  3. #3
    Member koolaid_kid's Avatar
    Join Date
    Sep 2005
    Location
    Indianapolis
    Posts
    209

    Arrest Me Red
    1997 Formula

    Quote Originally Posted by fbodyfiend View Post
    Has anybodies turbo actually fallen off.
    Please tell us you are kidding...
    I'm not trying to flame you, but it just seems a bit silly to me.

  4. #4
    Member jmhvenom's Avatar
    Join Date
    Oct 2005
    Location
    Cincinnati, OH
    Age
    32
    Posts
    823

    Silver
    2002 Z28

    Dont think its too silly, as much as I bang my ypipe, I could see stuff hanging down there catching on stuff and causing some damage. My friend had his qtp cutout ripped off while driving.

  5. #5
    Member koolaid_kid's Avatar
    Join Date
    Sep 2005
    Location
    Indianapolis
    Posts
    209

    Arrest Me Red
    1997 Formula

    O.K., then as a serious reply, no. It has never been an issue. More an issue was the K&N FilterCharger (pre-turbo), which was removed.
    Although I do drive with the knowledge that there is a turbo on my butt.
    And when I need it, it is available. Instantly. With no lag. My biggest issue has been traction. None available with Nitto 555s on 16 wheels. Going sideways at 80 mph is no fun.

  6. #6
    Junior Member
    Join Date
    Jul 2006
    Location
    bismarck ND
    Age
    31
    Posts
    4

    black
    1998

    the only odd thing i have heard is oil shooting out of the turbo, and when i mean shooting out really shooting out. but the preoblem was fixed due to the install...i want one...now...and bad.

  7. #7
    Member cailey37's Avatar
    Join Date
    Mar 2006
    Location
    Mississippi
    Posts
    832

    Silver
    1998 Pontiac Trans Am

    Quote Originally Posted by fbodyfiend View Post
    I was wondering what kind of problems anybody is having. Has anybodies turbo actually fallen off.
    One of the things I dont like about the system is the location of the air filter....tends to suck up water if you live in an area where it rains a lot.....you could build a system on your own if you're mechanically inclined and do some research....I built one off the STS system because I wanted to keep my A/C.....if it was a strict race car....then the turbo would be up front.........

    oh yea....as for the turbo falling off.....good question......I ran over a board that was in the road and i thought for sure it would of damaged something under there......luckily it didn't.....but anything is possible.....I may buy another f-body to toy with a twin turbo setup....I think I can make it work where they are located right behind the manifolds..........I looked at it while I was building my current car......

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: 97 LT1 problems
    By james78657 in forum LT1
    Replies: 18
    Last Post: 01-20-2012, 10:30 AM
  2. Help: 62.9i problems
    By trooperrunner in forum Stereo and Electronics
    Replies: 1
    Last Post: 08-12-2009, 04:08 PM
  3. problems with my 66 g.t.o. (help)
    By 05gtoautoX in forum GTO
    Replies: 6
    Last Post: 07-11-2006, 04:49 AM
  4. Site problems or my problems?
    By oneBADDz in forum Request and Feedback
    Replies: 2
    Last Post: 04-03-2006, 07:26 PM
  5. A/C problems.
    By gnomee in forum General Help
    Replies: 2
    Last Post: 03-14-2006, 07:13 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •