Results 1 to 8 of 8

Zex kit not spraying, help

This is a discussion on Zex kit not spraying, help within the Nitrous forums, part of the LSx Technical Help Section category; I have a LSX Zex wet kit on my GTO, now here's what's troubling me. When the car is moving ...

  1. #1
    Member 05gtoautoX's Avatar
    Join Date
    Jan 2006
    Location
    riverton
    Posts
    556

    Impulse Blue
    2006 Pontiac G.T.O.

    Zex kit not spraying, help

    I have a LSX Zex wet kit on my GTO, now here's what's troubling me. When the car is moving and the bottle IS open and full and all things are a go it only sprays fuel which causes it to bog badly etc. I know it's bad but I keep trying to fix it and test it. So I bring it back into the garage check everything, pull the N2O and fuel hoses from the intake get in the car and it punch it and it sprays both fuel and N20. I'm at a loss here, everytime I test it it checks out, but as soon as I spray it into the intake it bogs etc. I've checked my jetting, bottle pressure wiring etc it all looks good. What do you guys think could be causing this? Any Ideas?


    EDIT: When I first installed it everything worked everytime no issues, now my purge solenoid don't even work when the car is running.

  2. #2
    Awaiting Activation
    Join Date
    Aug 2007
    Location
    odessa,texas
    Posts
    1,056

    69 hugger orange
    98 z28

    do you have a fuel pressure safety switch?
    it might be set to high
    at idle it would have enough pressure but driving your pressure could be lower
    just a thought

    the only other things that come to mind right now are loose wiring or if you have a controller maybe you have the gear lockouts set up wrong or i have seen people mount the wide open throttle switch to something that didnt flex and with the motor under a load the switch would not work but in park it worked fine

  3. #3
    Junior Member svnltr's Avatar
    Join Date
    Dec 2007
    Location
    australia
    Posts
    5

    silver
    03 Maloo

    for it to bog like that it must be fuel related-

    u sure u got the right fuel jet in

    Thanks

    Nick--

  4. #4
    Member 05gtoautoX's Avatar
    Join Date
    Jan 2006
    Location
    riverton
    Posts
    556

    Impulse Blue
    2006 Pontiac G.T.O.

    I got a .034 for fuel and .054 for N20 which is what it calls for, but I think I may have found the problem. I removed both jets and blew through them the wrong way, I found a small piece of plastic inside the N20 jet, it looks like it came off from a piece of zip tie or something. I haven't tested yet but it sounds good in theory, this is all after going through the wiring completely checking the nozzle and even removing the jets, hell I can't figure out how the piece of plastic wouldn't have fallen out today let alone how it got there in the first place. It really is weird because I am very cautious when taking the intake apart etc. and sort of a clean freak. I'll test it tomorrow
    and I'll let you guys know how it turns out, appreciate the help.
    Last edited by 05gtoautoX; 09-19-2008 at 09:19 PM.
    2006 impulse blue G.T.O
    Iron Block 408
    Cam
    Pacesetter ceramic coated L.T.s
    LMII exhaust
    K&N CAI
    Ported TB
    Custom Tune
    FAST 90
    ZEX 125hp wet shot

  5. #5
    Junior Member svnltr's Avatar
    Join Date
    Dec 2007
    Location
    australia
    Posts
    5

    silver
    03 Maloo

    Question

    Seems a bit odd-

    whats the part number of the n20 kit

    Thanks

  6. #6
    Junior Member
    Join Date
    Aug 2005
    Location
    Severna Park, MD
    Posts
    65

    Sounds like bottle / tube position

    Sounds like bottle position, the N2O moves around when the vehicle is moving. Ensure bottle outlet is facing down and bottle is mounted parallel with vehicle. At next re-fill pull out tube and verify location; tube should locate (bow) to lower bottom of bottle when outlet is facing down.


    Quote Originally Posted by 05gtoautoX View Post
    I have a LSX Zex wet kit on my GTO, now here's what's troubling me. When the car is moving and the bottle IS open and full and all things are a go it only sprays fuel which causes it to bog badly etc. I know it's bad but I keep trying to fix it and test it. So I bring it back into the garage check everything, pull the N2O and fuel hoses from the intake get in the car and it punch it and it sprays both fuel and N20. I'm at a loss here, everytime I test it it checks out, but as soon as I spray it into the intake it bogs etc. I've checked my jetting, bottle pressure wiring etc it all looks good. What do you guys think could be causing this? Any Ideas?


    EDIT: When I first installed it everything worked everytime no issues, now my purge solenoid don't even work when the car is running.

  7. #7
    Member 05gtoautoX's Avatar
    Join Date
    Jan 2006
    Location
    riverton
    Posts
    556

    Impulse Blue
    2006 Pontiac G.T.O.

    I tried it now and it works great, I've actually pulled the tube out and verified it's location along with making sure the outlet is pointed down. Thanks guys appreciate your help.

  8. #8
    Junior Member
    Join Date
    Aug 2005
    Location
    Severna Park, MD
    Posts
    65

    Great

    Great, glad its fixed....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Thinking of Spraying
    By Blue_01_Z28 in forum Nitrous
    Replies: 13
    Last Post: 04-02-2010, 01:29 PM
  2. Thinking about spraying
    By Tx98Formula in forum General Help
    Replies: 11
    Last Post: 03-10-2010, 03:17 PM
  3. how much is everyone spraying.
    By william SS in forum Nitrous
    Replies: 11
    Last Post: 11-09-2007, 11:53 AM
  4. Spraying!!!
    By GT Griller in forum Nitrous
    Replies: 3
    Last Post: 03-03-2007, 04:05 PM
  5. Spraying 10-12oz NOS bottles
    By FloridaPowerHitter in forum Nitrous
    Replies: 12
    Last Post: 05-15-2006, 07:36 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •