Results 1 to 6 of 6

Idle's high after installing HSW plate

This is a discussion on Idle's high after installing HSW plate within the Nitrous forums, part of the LSx Technical Help Section category; Anyone else have this problem? It ildes anywhere from 950 to 1100. The throttle bracket obviously didnt set it out ...

  1. #1
    Junior Member
    Join Date
    Sep 2006
    Location
    Long Island
    Age
    46
    Posts
    48

    Hugger Orange
    '99 Hugger SS

    Idle's high after installing HSW plate

    Anyone else have this problem? It ildes anywhere from 950 to 1100. The throttle bracket obviously didnt set it out far enough and now it doesnt rest on the idle screw. What's the best solution here, bend the bracket, elongate the holes? Thanks, Jim

  2. #2
    Senior Member bills98ta's Avatar
    Join Date
    Feb 2007
    Location
    St Thomas, PA
    Posts
    5,047

    White
    1998 Trans Am

    Stock cable may be adjustable. If not, time for some custom modding !!! LOL

  3. #3
    Junior Member
    Join Date
    Sep 2006
    Location
    Long Island
    Age
    46
    Posts
    48

    Hugger Orange
    '99 Hugger SS

    How do you adjust the cable? I've got a '99.

  4. #4
    Senior Member bills98ta's Avatar
    Join Date
    Feb 2007
    Location
    St Thomas, PA
    Posts
    5,047

    White
    1998 Trans Am

    If you have the adjuster, it will be on the main cable, from the TB, and it will have a block molded into the cable. There will be a flat snap, that you will pop up, then the cable slides in & out, then snap the lock back down. Slide it in, to give more slack.

  5. #5
    Junior Member
    Join Date
    Sep 2006
    Location
    Long Island
    Age
    46
    Posts
    48

    Hugger Orange
    '99 Hugger SS

    Thanks. That took care of it. I appreciate the help.

  6. #6
    Senior Member bills98ta's Avatar
    Join Date
    Feb 2007
    Location
    St Thomas, PA
    Posts
    5,047

    White
    1998 Trans Am

    Quote Originally Posted by jhenke View Post
    Thanks. That took care of it. I appreciate the help.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. idle issues... idle high. unplugged tps runs good?
    By okiels1 in forum Firebird / WS6
    Replies: 2
    Last Post: 12-31-2016, 04:36 AM
  2. Installing A Zex Perimeter Plate Nitrous System - Step Up To
    By Ed Blown Vert in forum Firebird / WS6
    Replies: 0
    Last Post: 06-10-2011, 03:30 AM
  3. high shift points & high idle
    By Red 99 T/A in forum General Help
    Replies: 5
    Last Post: 07-26-2010, 09:04 PM
  4. high idle?
    By hutch1999 in forum General Help
    Replies: 11
    Last Post: 12-02-2007, 08:44 PM
  5. High Idle
    By T/Aboo in forum General Help
    Replies: 2
    Last Post: 05-19-2006, 08:55 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •