Results 1 to 2 of 2

having problems

This is a discussion on having problems within the Nitrous forums, part of the LSx Technical Help Section category; Ive been running a 125 wet shot for a while now and it picked me up right at a second ...

  1. #1
    Junior Member
    Join Date
    Nov 2006

    blue/green chameleon
    98 formula

    having problems

    Ive been running a 125 wet shot for a while now and it picked me up right at a second in the 1/8th for the past couple months that its been on the car.
    But the past 2 times I brought it to the track Im barely picking up 3 tenths on the bottle.Nothing has been changed and its got a fresh set of plugs,and its not throwing any codes. No pinging,knocking,or detnation and with good bottle pressure.
    Used to I could lay in it in 3rd and shoot her the juice and it was a noticeable hit now you can barely tell Im spraying it with out watching the tach.
    Any ideas? Ive checked everything I can think of
    The plugs looked a little on the lean side so I went up a little on my gas jet and still no change.

  2. #2
    Senior Member mrr23's Avatar
    Join Date
    Jul 2005
    orlando, fl

    dark bowling green
    2000 corvette

    make sure the nozzle isn't twisting out of place when you hit it. had a firend of mine have that happen to on the dyno. as soon as you hit it, the nozzle would twist 90* upward.

    another thing would be the solenoid ground coming loose. this could keep the solenoids from fully opening. i've had to replace mine from the coils not fully functioning.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Three transmissions later = electrical problems ???
    By t-topsonline in forum Automatic Transmission
    Replies: 7
    Last Post: 02-21-2007, 11:13 PM
  2. Cold Start problems?
    By SteveCZ28 in forum General Help
    Replies: 3
    Last Post: 12-16-2006, 06:54 AM
  3. Tranny problems?
    By GottaHaveLS1 in forum Manual Transmission
    Replies: 0
    Last Post: 04-07-2006, 09:01 AM
  4. Site problems or my problems?
    By oneBADDz in forum Request and Feedback
    Replies: 2
    Last Post: 04-03-2006, 06:26 PM
  5. ASR Inoperable, ABS Problems. Need Some Help.
    By Jinxed in forum Drivetrain
    Replies: 0
    Last Post: 11-04-2005, 07:46 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts