All Blog Entries

  1. Trans Am WS6 Seat Lumbar pump and hose not work ?

    by , 02-09-2016 at 08:26 AM
    Quote Originally Posted by BobbyGFirebird View Post
    I just tried lumbar/lateral air inflators on my used Trans Am WS6 30th Ann Ed. (white leather power seats). Pass side works like it was delivered from factory yesterday, but Driver side has no balloon movement at all. I can hear the motor whizzing for Driver side though. Is this likely a busted hosehose or a balloon when BOTH lumbar and lateral do not work? Is there one pump in driver seat, and it crosses over to Pass. side? (I only ask that based on what I saw on forum elsewhere?) p.s. Is
  2. How often would you change your fluid in a 4L60E???????

    by , 08-20-2015 at 07:27 AM
    Ive got a 01 Trans Am with 180k....Not having any problems just wanna prolong the life of the tranny....I looked at the fluid color and its a little discolored but not bad???? Also heard don't touch the fluid unless having problems?? but also heard about every 15-30k????
  3. New 2014 SS/1LE/2SS/RS

    by , 10-22-2014 at 03:22 PM
    2014 1LE
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	01aa9caa863faae38b52320883f63e99cc4aee1f3b.jpg 
Views:	639 
Size:	109.7 KB 
ID:	25990   Click image for larger version. 

Name:	01d4fe65c3671b83d9f6469e3aeca988d1877af3f4.jpg 
Views:	586 
Size:	107.4 KB 
ID:	25989  
  4. Cool & Breezy

    by , 03-26-2014 at 05:08 PM
    Quote Originally Posted by Agarcia67 View Post
    Out for a spin here in Lawton, OKClick image for larger version. 

Name:	20140324_133150 (3).jpg 
Views:	533 
Size:	83.3 KB 
ID:	25707
  5. Including pictures in a post.

    by , 02-13-2014 at 09:57 PM
    How do you insert pictures in these posts? When I click on the photo link above, all I get is a URL space. What am I supposed to put for a URL? My computer IP just shows on the post, but not a picture. I also can not find instructions on How To Insert a picture on the whole site? Whats up?
Page 1 of 9 12345 ... LastLast